Page 3 of 4 FirstFirst 1234 LastLast
Results 41 to 60 of 74
  1. #41  
    Quote Originally Posted by JoeTampa
    The images are in the DCIM\STOCK folder on the SD card. They are all JPGs, 800x600 or so on average. I have them in three categories: Personal, Stock, and Model.

    I will try the App Special Effects later today if I can.
    I have found and I am in the middle of fixing a bug where a crash could happen if you are using the 650 and your album names are longer than 16 characters. Will have a build out later tonight that fixes the problem.

    Jeff
  2. #42  
    I found 3 problems that could have caused your crash. I have posted v2.8.4 to: ScreenCare

    This release should be much more stable.

    Jeff
  3. #43  
    Tried with internal pictures and it worked pretty well.

    On the card, that's another story. It literally takes 84 seconds (I timed it) for the first picture to show up. I was about to soft-reset the first time (since it had seemingly locked up - buttons dead, screen taps did nothing, etc). It is consistent. I tried disabling full-screen mode and that did not help. The JPGs in question are between 20K and 50K in size. Once the first picture comes up, however, you can tap and get back to the main menu quickly. Once the first image came up, the rest cycled normally. I have it on random.


    - Joe
    Highly Mobile iPhone User

    Palm Pilot -> Palm Pilot Pro -> HP 620LX -> Palm VII -> Palm VIIx -> Ipaq 3270 -> Treo 300 -> Treo 600 -> Treo 650 -> Treo 700p - iPhone - iPhone 3G
  4. #44  
    Quote Originally Posted by JoeTampa
    Tried with internal pictures and it worked pretty well.

    On the card, that's another story. It literally takes 84 seconds (I timed it) for the first picture to show up. I was about to soft-reset the first time (since it had seemingly locked up - buttons dead, screen taps did nothing, etc). It is consistent. I tried disabling full-screen mode and that did not help. The JPGs in question are between 20K and 50K in size. Once the first picture comes up, however, you can tap and get back to the main menu quickly. Once the first image came up, the rest cycled normally. I have it on random.


    - Joe
    Interesting. I am using JPEG's that are between 90-400K and they show up in less than 3 seconds. I just bought a 1GB 60x PQI card and this thing flys! My 256 normal SanDisk card was slower but not 84 seconds. What kind of card are you running?

    Try the attached JPEG's and let me know if it is any faster. Then we can do an apples to apples comparison.

    Each takes about 2 seconds to display on my Treo 650 with the 60x PQI card in full screen mode. They take less than a second in non full screen mode. Then at 270 degree rotation they take about 4 seconds to load.

    The Treo 600 with the slower SanDisk SD card took 3 seonds to load the images in Keep Aspect Ratio mode. About the same amount of time in Fit to Screen mode. And about 4 seconds in 270 degree rotation mode.

    I am interested in what times you find. If our times are compatible, I'd be interested in taking a look at one of the impages that took so much time on your system to see if they are comparable on mine.

    Jeff
    Attached Images Attached Images
  5. #45  
    512M Sandisk. Like I said, the second, third, etc images load immediately. It's getting the whole process started that is apparently the issue. I'm sure it's not the images itself - perhaps it's contending with some other software?!
    Highly Mobile iPhone User

    Palm Pilot -> Palm Pilot Pro -> HP 620LX -> Palm VII -> Palm VIIx -> Ipaq 3270 -> Treo 300 -> Treo 600 -> Treo 650 -> Treo 700p - iPhone - iPhone 3G
  6. #46  
    Quote Originally Posted by JoeTampa
    512M Sandisk. Like I said, the second, third, etc images load immediately. It's getting the whole process started that is apparently the issue. I'm sure it's not the images itself - perhaps it's contending with some other software?!
    Could very well be. The Imaging library on the 600 seems to be a little faster than the Photo API on the 650.

    I am however glad that you now have a version that is up and running.

    A second question though if you don't mind. Is ScreenCare doing what you want the program to do? I think you were the one that wanted a program that would give you the flexability to maintain your current file layout and organization structure and allow you to select what part of the structure to pull pictures from. This was one of the design conciderations from the beginning and I wanted to get your perspective. It's one thing to develop an application, its another to give users what they want and need.

    Thanks,

    Jeff
  7. #47  
    Well, I'm looking for two things:

    1. Screen off, buttons disabled during a bluetooth headset call. I can live with it as-is, I suppose, but what I really want is for the screen and keys to be disabled only when the BT headset is active - not during ANY call.

    2. Abilty to view or slideshow pictures in a given directory - say the DCIM\STOCK directory (and subdirs?) on the SD card. As it is, I have to categorize them, which to me is an extra step. Again, I can live with it if I have to - but it would seem an easy thing to do. Perhaps any photos in a given directory can be auto-categorized? Maybe a desktop utility?

    That being said, I have been playing with Splash Viewer, which does almost everything I want.



    - Joe
    Highly Mobile iPhone User

    Palm Pilot -> Palm Pilot Pro -> HP 620LX -> Palm VII -> Palm VIIx -> Ipaq 3270 -> Treo 300 -> Treo 600 -> Treo 650 -> Treo 700p - iPhone - iPhone 3G
  8. #48  
    Quote Originally Posted by JoeTampa
    Well, I'm looking for two things:

    1. Screen off, buttons disabled during a bluetooth headset call. I can live with it as-is, I suppose, but what I really want is for the screen and keys to be disabled only when the BT headset is active - not during ANY call.
    I will get this option working in time. Sounds like a very valid request. I just need to get the API to cooperate with me. ;-)

    2. Abilty to view or slideshow pictures in a given directory - say the DCIM\STOCK directory (and subdirs?) on the SD card. As it is, I have to categorize them, which to me is an extra step. Again, I can live with it if I have to - but it would seem an easy thing to do. Perhaps any photos in a given directory can be auto-categorized? Maybe a desktop utility?
    I guess I am missing what you are asking for. You do not need to categorize your images! I do however support the category structure (Treo 600) and the Album structure (Treo 650) on the Palm card. But SD Card directories is what I built into ScreenCare. Even if you have a 650, Albums are nothing more than a dierctory on your SD Card! You do not have to go through the management layer to install your images on teh SD Card. The only restriction on the 650 is that you have to base all of your directories in the /DCIM directory. For Images on the SD Card you simply tell ScreenCare where the directory (on the 600) or the Album (on the 650) is that you have your images stored and it will pull images from that directory. On the 600 it will recurse that directory and find all images from your target directory to its lowest child directory. I'll have to check to see if the 650 does the same.


    That being said, I have been playing with Splash Viewer, which does almost everything I want.
    I am happy with whatever you choose to do. I am grateful for you taking the time to help me perfect ScreenCare. I am pretty sure that ScreenCare will do what you want it to do (or I will make it do what you want it to do). But again thank you for you help!

    Jeff
  9. #49  
    OK, I found the problem... It's the number of pictures in the directory.

    I added a new directory to the DCIM dir. (DCIM\LONDON). It has 16 files. Took 13 seconds to start the show.

    DCIM/MODEL has 88 files in it - took over a minute to start the show.

    Made a new dir - DCIM\TEST with 3 files. Took 3 secs to start.

    All files are now 320x240ish JPGs.
    Highly Mobile iPhone User

    Palm Pilot -> Palm Pilot Pro -> HP 620LX -> Palm VII -> Palm VIIx -> Ipaq 3270 -> Treo 300 -> Treo 600 -> Treo 650 -> Treo 700p - iPhone - iPhone 3G
  10. #50  
    Quote Originally Posted by JoeTampa
    OK, I found the problem... It's the number of pictures in the directory.

    I added a new directory to the DCIM dir. (DCIM\LONDON). It has 16 files. Took 13 seconds to start the show.

    DCIM/MODEL has 88 files in it - took over a minute to start the show.

    Made a new dir - DCIM\TEST with 3 files. Took 3 secs to start.

    All files are now 320x240ish JPGs.
    Thanks for the update! I appreciate you supplying this information.
  11. #51  
    My pleasure. Also, when the screen saver kicks in, if Sprint Business Connection tries to fire up Vision, the screen saver pauses the entire time. Not a big deal. But something caused the keylock message urging you to press the center button to unlock the keyboard to appear - where it sat, in front of a frozen screen saver, until I finally decided it wasn't going to move on it's own (5 mins) and hit the center button. The message vanished and the screen saver resumed.
    Highly Mobile iPhone User

    Palm Pilot -> Palm Pilot Pro -> HP 620LX -> Palm VII -> Palm VIIx -> Ipaq 3270 -> Treo 300 -> Treo 600 -> Treo 650 -> Treo 700p - iPhone - iPhone 3G
  12. #52  
    Quote Originally Posted by JoeTampa
    My pleasure. Also, when the screen saver kicks in, if Sprint Business Connection tries to fire up Vision, the screen saver pauses the entire time. Not a big deal. But something caused the keylock message urging you to press the center button to unlock the keyboard to appear - where it sat, in front of a frozen screen saver, until I finally decided it wasn't going to move on it's own (5 mins) and hit the center button. The message vanished and the screen saver resumed.
    Interesting. So this was a background event or were you in BC when it opened the connection to Vision? Also were you plugged in to a power source? If not do you think the system timer could have kicked in and locked the keyboard?

    Now when you say that the screensaver pauses, does that mean that it stopped as if you tapped on the screen? It should by the way.
  13. #53  
    Background event, plugged in. The current image being displayed was frozen there until the dialog dissapeared, at which point they began rotating again. It did not vanish and give me back the normal screen as it would if I tapped.
    Highly Mobile iPhone User

    Palm Pilot -> Palm Pilot Pro -> HP 620LX -> Palm VII -> Palm VIIx -> Ipaq 3270 -> Treo 300 -> Treo 600 -> Treo 650 -> Treo 700p - iPhone - iPhone 3G
  14. #54  
    Jeff,
    Is there any possibility to write an app that does only *one* thing: Force the power button to behave like a regular button unless option-pressed or when at the Phone app?
  15. #55  
    Quote Originally Posted by NSiNSiNSi
    Jeff,
    Is there any possibility to write an app that does only *one* thing: Force the power button to behave like a regular button unless option-pressed or when at the Phone app?
    Can you explain a little more what you are thinking? Is this a general chage to the behavior of the power button or just inside of the phone app?

    Jeff
  16. #56  
    Jeff, I feel a little stupid here, but the software just STOPPED working all of a sudden. I've deleted the preferences and installed the newest version, BUT it still doesn't work. The screen saver just doesn't turn on anymore... any ideas?
    - Enable is checked
    - Phone call Screen Saver is checked.
    - Inside Phone settings, double tap, disable hard keys and disable keyboard are checked.
    - Delay time is set to 5 seconds.

    Thanks,

    Chavous
    BOFH/Chavous Camp

    Don't know what BOFH stands for? See here.
  17. #57  
    I had another issue. I installed the BT headset app and after my first BT call, the screen brightness level was reduced to zero; I removed both that and ScreenCare for the moment. Jeff, should there be any issue with either the BT app alone or installed together with ScreenCare?
    Highly Mobile iPhone User

    Palm Pilot -> Palm Pilot Pro -> HP 620LX -> Palm VII -> Palm VIIx -> Ipaq 3270 -> Treo 300 -> Treo 600 -> Treo 650 -> Treo 700p - iPhone - iPhone 3G
  18. #58  
    Quote Originally Posted by bofh
    Jeff, I feel a little stupid here, but the software just STOPPED working all of a sudden. I've deleted the preferences and installed the newest version, BUT it still doesn't work. The screen saver just doesn't turn on anymore... any ideas?
    - Enable is checked
    - Phone call Screen Saver is checked.
    - Inside Phone settings, double tap, disable hard keys and disable keyboard are checked.
    - Delay time is set to 5 seconds.

    Thanks,

    Chavous
    Lets step through the problem.

    1) Is ScreenCare (SC) able to show images if you press the prview button when you are in "pictures" mode?
    2) Does SC work in Picture mode? Will it kick in and show images after the timeout period?
    3) Is SC able to show special effects in preview mode? (Ie bugs, dissolve or custom icon)
    4) Does SC work in "application" mode? Will it kick in and show special effects after the timeout period?
    5) Did you load BTmute that I released in beta today?
    6) Did you load Shadowmites ROM's?
    7) Did anything else change on your 650? It is a 650 right?
    8) Do you by any chance have the phone app in the excluded application list? You can find this list by drilling into one of the launch application fields and choosing "view exclude list".

    I know a lot of questions but the answers will be helpfull.

    Jeff
  19. #59  
    Quote Originally Posted by JoeTampa
    I had another issue. I installed the BT headset app and after my first BT call, the screen brightness level was reduced to zero; I removed both that and ScreenCare for the moment. Jeff, should there be any issue with either the BT app alone or installed together with ScreenCare?
    There may very well be a conflist between BTmute and ScreenCare. I just threw together BTmute to see if the concept of what I am doing in that program will solve the volume problem. I payed NO attention to integration with other utilities. I hated to release apps like that but people were asking for the solution and I don't have a BT headset yet to test with.

    As for BTmute. Did it work for you? What were your experiences? I can't wait until my headset gets here. I feel like my hands are tied!
  20. #60  
    I had to go out and needed the phone stable for the day, so I uninstalled them both (since the screen brightness issue at first looked more ominous). I'll try re-installing BTmute alone and see what happens tomorrow.
    Highly Mobile iPhone User

    Palm Pilot -> Palm Pilot Pro -> HP 620LX -> Palm VII -> Palm VIIx -> Ipaq 3270 -> Treo 300 -> Treo 600 -> Treo 650 -> Treo 700p - iPhone - iPhone 3G
Page 3 of 4 FirstFirst 1234 LastLast

Posting Permissions