Page 2 of 2 FirstFirst 12
Results 21 to 33 of 33
  1. #21  
    Well I managed to get my new GSM Treo 650 to sync with Evolution. Seems to have gone smoothely, I just had to do all the steps mentioned in this thread:

    http://discussion.treocentral.com/sh...ad.php?t=65243

    Except for updating the kernel. The current FC2 2.6.10 series kernsl seem to work fine. Also I used the rawhid gnome-pilot-2.0.12 rpms which I built from the src rpms.
  2. plaut's Avatar
    Posts
    110 Posts
    Global Posts
    123 Global Posts
    #22  
    Quote Originally Posted by gaf
    I'm wondering if the problem might be either with the TREO or with pilot-link?
    Very unlikely - looks like the problem is with SuSE - check out this post (and the other messages in the thread) in the pilot-link list. The thread concerns the Samsung i500 but exactly the same issues apply to the T650.
  3. #23  
    I'm running SuSE 9.2, 2.2.6.8-24.11 kernel and pilot-link version 0.11.8.
    Looks like I should be able to read/write to the port:
    linux:~ # ls -al /dev/ttyUSB*
    crw-rw-rw- 1 root uucp 188, 0 Feb 15 18:54 /dev/ttyUSB0
    crw-rw-rw- 1 root uucp 188, 1 Feb 15 18:54 /dev/ttyUSB1

    Am also a member of group uucp.
  4. plaut's Avatar
    Posts
    110 Posts
    Global Posts
    123 Global Posts
    #24  
    Quote Originally Posted by nw_biohazard
    I'm running SuSE 9.2, 2.2.6.8-24.11 kernel and pilot-link version 0.11.8.
    Looks like I should be able to read/write to the port:
    linux:~ # ls -al /dev/ttyUSB*
    crw-rw-rw- 1 root uucp 188, 0 Feb 15 18:54 /dev/ttyUSB0
    crw-rw-rw- 1 root uucp 188, 1 Feb 15 18:54 /dev/ttyUSB1

    Am also a member of group uucp.
    See the link to a pilot-link post in my previous message. The short version is to add the following two lines to /etc/hotplug/blacklist

    visor
    usbserial

    then reboot, connect the 650 via USB and hit the hotsync button, wait 2 seconds, then (in a non-root terminal) run "pilot-link -p /dev/ttyUSB1 -l". If the pilot-link command connects and lists the databases on your 650, just run "ln -sf /dev/ttyUSB1 /dev/pilot" (as root) and you should be good to go.
  5. #25  
    Still no go......

    I did the following:

    Added visor and usbserial to /etc/hotplug/blacklist

    Rebooted, hit hot-sync button:
    in /var/log/messages:
    Feb 16 17:42:33 linux kernel: usb 2-1: new full speed USB device using address 2
    Feb 16 17:42:33 linux kernel: usb 2-1: Product: Palm Handheld
    Feb 16 17:42:33 linux kernel: usb 2-1: Manufacturer: PalmOne, Inc.
    Feb 16 17:42:33 linux kernel: usb 2-1: SerialNumber: PalmSN12345678

    (Note, /dev/ttyUSB0 or /dev/ttyUSB1 are not being created.)

    hence:

    > pilot-xfer -p /dev/ttyUSB1 -l

    Fails.

    So I tried:
    > /bin/mknod /dev/ttyUSB0 c 188 0
    > chmod 0666 /dev/ttyUSB0
    chmod
    > /bin/mknod /dev/ttyUSB1 c 188 1
    > chmod 0666 /dev/ttyUSB1

    Rebooted:

    (interestingly, after rebooting, the permissions on /dev/ttyUSB1 had been
    changed)

    And then tried hot-syncing: same story in the logs. (interestingly, after
    rebooting, the permissions on /dev/ttyUSB1 had been changed)

    So, I went back to the instructions on this thread:
    http://lists.pilot-link.org/pipermai...st/001927.html

    linux:~ # echo /bin/true > /proc/sys/kernel/hotplug

    (/etc/hotplug/blacklist already edited)

    linux:~ # rmmod usbserial
    linux:~ # rmmod visor
    ERROR: Module visor does not exist in /proc/modules
    linux:~ # hotplug stop
    linux:~ # ps aux | grep pilot
    root 7054 0.0 0.1 1696 636 pts/2 S+ 18:04 0:00 grep pilot
    linux:~ # lsmod | grep uhci
    uhci_hcd 29712 0
    usbcore 106724 6 usblp,usbhid,ehci_hcd,uhci_hcd

    linux:~ # modprobe visor debug=1 vendor=0x082d product=0x0061 (Handspring)
    linux:~ # modprobe visor debug=1 vendor=0x0830 product=0x0061

    The log:

    Feb 16 18:08:09 linux kernel: drivers/usb/serial/visor.c: Adding Palm OS protoco
    l 4.x support for unknown device: 0x82d/0x61
    Feb 16 18:08:09 linux kernel: drivers/usb/serial/usb-serial.c: USB Serial suppor
    t registered for Handspring Visor / Palm OS
    Feb 16 18:08:09 linux kernel: drivers/usb/serial/usb-serial.c: USB Serial suppor
    t registered for Sony Clie 3.5
    Feb 16 18:08:09 linux kernel: drivers/usb/serial/usb-serial.c: USB Serial suppor
    t registered for Sony Clie 5.0
    Feb 16 18:08:09 linux kernel: usbcore: registered new driver visor
    Feb 16 18:08:09 linux kernel: drivers/usb/serial/visor.c: USB HandSpring Visor /
    Palm OS driver v2.1

    The shell:

    Then hit the hot-sync button, and tried the pilot-xfer command:
    > pilot-xfer -p /dev/ttyUSB1 -l
    Listening to port: /dev/ttyUSB1

    Please press the HotSync button now...
    Error accepting data on /dev/ttyUSB1

    The log:

    Feb 16 18:09:11 linux kernel: usb 2-1: new full speed USB device using address 3
    Feb 16 18:09:11 linux kernel: usb 2-1: Product: Palm Handheld
    Feb 16 18:09:11 linux kernel: usb 2-1: Manufacturer: PalmOne, Inc.
    Feb 16 18:09:11 linux kernel: usb 2-1: SerialNumber: PalmSN12345678
    Feb 16 18:09:11 linux kernel: drivers/usb/serial/visor.c: visor_probe
    Feb 16 18:09:11 linux kernel: drivers/usb/serial/visor.c: palm_os_4_probe
    Feb 16 18:09:11 linux kernel: usb 2-1: palm_os_4_probe - length = 20, data = 01
    01 00 00 63 6e 79 73 00 67 00 00 00 00 00 00 01 01 00 00
    Feb 16 18:09:11 linux kernel: visor 2-1:1.0: Handspring Visor / Palm OS converte
    r detected
    Feb 16 18:09:11 linux kernel: usb 2-1: Handspring Visor / Palm OS converter now
    attached to ttyUSB0
    Feb 16 18:09:11 linux kernel: usb 2-1: Handspring Visor / Palm OS converter now
    attached to ttyUSB1
    Feb 16 18:09:22 linux pilot-xfer: resmgr: server response code 502
    Feb 16 18:09:22 linux kernel: drivers/usb/serial/visor.c: visor_open - port 1
    Feb 16 18:09:22 linux kernel: drivers/usb/serial/visor.c: visor_ioctl - port 1,
    cmd 0x5401

    <snip>

    Feb 16 18:09:32 linux kernel: drivers/usb/serial/visor.c: visor_close - port 1
    Feb 16 18:09:32 linux kernel: drivers/usb/serial/visor.c: visor_read_bulk_callba
    ck - port 1
    Feb 16 18:09:32 linux kernel: drivers/usb/serial/visor.c: visor_read_bulk_callba
    ck - nonzero read bulk status received: -2
    Feb 16 18:09:32 linux kernel: usb 2-1: control timeout on ep0in

    ( Is it possible that this is the wrong vendor/device code?)
  6. plaut's Avatar
    Posts
    110 Posts
    Global Posts
    123 Global Posts
    #26  
    Quote Originally Posted by nw_biohazard
    Is it possible that this is the wrong vendor/device code?)
    Yes, they're incorrect for the 650 - you should use

    modprobe visor vendor=0x0830 product=0x0061

    Now, that said, I never managed to get the visor module to work properly with the 650 by just passing arguments - I had to add the necessary definitions, etc., to the module code and recompile (as described in http://discussion.treocentral.com/sh...64&postcount=3). Maybe you'll have more luck....
    Last edited by plaut; 02/17/2005 at 08:40 PM.
  7. #27  
    product=0x0021 or 0x0061 as in the modification below:

    #define PALM_TREO650_ID 0x0061

    to /usr/src/linux-2.6.9/drivers/usb/serial/visor.h and adding

    { USB_DEVICE(PALM_VENDOR_ID, PALM_TREO650_ID),
    .driver_info = (kernel_ulong_t)&palm_os_4_probe },

    to the id_table[] structure (yes, palm_os_4), and

    { USB_DEVICE(PALM_VENDOR_ID, PALM_TREO650_ID) },
  8. plaut's Avatar
    Posts
    110 Posts
    Global Posts
    123 Global Posts
    #28  
    Quote Originally Posted by nw_biohazard
    product=0x0021 or 0x0061 as in the modification below:...
    sorry - grabbed the wrong numbers. You should use vendor=0x0830 product=0x0061 (I've edited my previous post).

    It looks like you tried these values as arguments to the visor module earlier without success (although it's the second of two modprobe commands and only the first is reflected in the log file lines you list). If they don't work as arguments you may need to modify visor.h and visor.c directly.
    Last edited by plaut; 02/17/2005 at 09:39 PM.
  9. #29  
    Can anyone walk me through setting BT DUN using shadowmite's hack and SUSE 9.2?
    Thanks,
    Zane
  10. plaut's Avatar
    Posts
    110 Posts
    Global Posts
    123 Global Posts
    #30  
    Quote Originally Posted by zvandiver
    Can anyone walk me through setting BT DUN using shadowmite's hack and SUSE 9.2?
    Here's what I do (although this is FC3):

    On the Treo:
    1) disconnect Vision (if it's connected)
    2) turn on Bluetooth, set Discoverable yes, set Dial-up Networking on

    On PC (this assumed you already have bluetooth connectivity set up):

    1) run "sdptool search DUN"

    This confirms bluetooth connectivity and will give you the MAC address of
    the Treo (e.g., 00:07:E0:01:62:A1). If sdptool only outputs "Searching for DUN
    on <MAC address> ..." and then returns, there's a problem - recheck that DUN is
    enabled on the phone. Once you know the MAC address you don't need this step.

    2) run "rfcomm bind 0 00:07:E0:01:62:A1 1" (but use your actual MAC address)

    3) set up a dial-out connection using /dev/rfcomm0 as the modem

    The exact procedure here will be distribution-specific. There is some
    suggestion that using a smaller MTU value (e.g., 576 instead of the default
    1500) helps with the stability of the connection. Haven't played with this.

    You should now be able to dial-out using the new connection. I find it helps
    if the phone isn't sleeping when you attempt to connect.

    When finished:
    On PC: run "rfcomm release 0"
    On Treo: turn off Dial-up Networking in Bluetooth

    I find the phone is much more sluggish with DUN enabled, so I usually do a soft reset as well when finished.
  11. #31  
    Thanks, plaut. I will try this tomorrow.
    Zane
  12. gaf
    gaf is offline
    gaf's Avatar
    Posts
    11 Posts
    #32  
    I found a way to sync my Treo with Linux.
    I saw this on the SuSE Linux list:
    1. create file in /etc/udev/rules.d named 10-udev.rules and containing:
    # Palm Handheld
    BUS="usb",SYSFS{serial}="PalmSN12345678",NAME="pilot"

    2. create a file in /etc/udev/permissions named 10-udev.permissions
    containing:
    # Palm Handheld rw
    pilot*:root:usb:0666

    then as root write: dlpsh, and after hit the sync icon on the palm...
  13. #33  
    One last thing for those who are having trouble syncing with Evolution (gnome-pilot): make sure you have usbfs mounted (mount -t usbfs none /proc/bus/usb).
Page 2 of 2 FirstFirst 12

Posting Permissions