Page 2 of 2 FirstFirst 12
Results 21 to 39 of 39
  1. #21  
    Could any one help completely new to linux guy.

    Just installed red hat on a partion on my drive and want to set up my treo. wpietr...I think your first post would be very helpful to me if I had a few maore steps.

    thanks all!
  2. #22  
    Quote Originally Posted by dutchtrumpet
    Could any one help completely new to linux guy.

    Just installed red hat on a partion on my drive and want to set up my treo. wpietr...I think your first post would be very helpful to me if I had a few maore steps.

    thanks all!
    What version of RedHat? You may need to get a recent kernel. I'm using Fedora Core 3 and had to compile kernel-2.6.10 before USB would function properly with the 650. UDEV had a few bugs in it.
  3. plaut's Avatar
    Posts
    110 Posts
    Global Posts
    123 Global Posts
    #23  
    Quote Originally Posted by Raistlix
    I'm using Fedora Core 3 and had to compile kernel-2.6.10 before USB would function properly with the 650. UDEV had a few bugs in it.
    I have 2.6.9-1.724_FC3 installed (the most recent rpm update under FC3) and USB works fine (including the visor module needed to sync with the 650). Still needed to add a line for the 650 to /usr/share/gnome-pilot/devices.xml though.
  4. #24  
    I know this post isn't going to be to usefull (and it will be a first post to this forum), but I'm glad to see some people having success syncing Evolution with their new Treo 650s. I'm a long time Linux users and currently sync Evolution with my trusty old Zaurus SL5500 (which had replaced my previous trusty Palm IIIx). Well for this round I've decided to go back to Palm and combine my cell phone with my next PDA. I just have to wait for the GSM version to come out.

    Anyways, thanks again for the information, I plan to make good use of it soon as I can get my hands on my Treo!

    Cheers,
    D-Caf
  5. #25  
    Okay, I'm new to linux. I've loaded a few different builds and settled on Mandrake as my favorite for the time being. I've got both KDE and Gnome and I'm currently running Gnome. I made the changes recommended in the original post, but neither KPilot or the gnome-pilot seem to recognize the 650. I selected USB and when i press the Hotsync button on the cable, it just never seems to establish the connection.
    Any recommendations? Is there something like the Windows Device List where I can see that the computer is trying to connect?
  6. #26  
    Toxic,
    Make sure you have pilot-link installed. Kpilot and gnome-pilot are just GUI's for pilot-link. Also make sure you have permissions on /dev/usb/ttyUSB1. That should be the port your Treo is using. Make sure that you are a member of the group that includes that device. On my SUSE installation that is uucp. You might want to make a symbolic link from /dev/usb/ttyUSB1 to /dev/pilot.
    I have only gotten kPilot to sync once. I always get a time out on the connection. But I also use jPilot, and it works just fine. I don't use Evolution, so I don't know about gnome-pilot.
    Zane

    Edit: By the way, I added a Bluetooth adapter and SUSE immediately recognized it. File transfers are a breeze. I have had all kinds of trouble getting the same adapter to work when I boot into Winblows.
  7. #27  
    Thanks for the help. This is one of my favorite things about Linux. You can get software so easily and there's 20 different apps that do the same thing, just depends on your preference for one over the other. I've installed pilot-link and jpilot. Looks much better than kpilot.

    Looking in my /dev folder, I don't have /usb or /pilot. I tried /dev/usb/ttyUSB1 to no avail. In setting up jpilot, it recommends /dev/ttyS0, so I tried that, but it didn't work. I'm assuming that is a serial port based on the S.

    Does this mean that my install doesn't fully recognize my USB ports? I'm using a USB keyboard and mouse successfully.

    Thanks again for all your help.
  8. #28  
    hold off on answering that one, I think I'm figuring it out. I have a /dev/ttyUSB0 and USB1, playing with that.
  9. #29  
    Toxic,
    On my installation there is a /usb subfolder under /dev. In /usb there is a long list of usb devices. ttyUSB1 is near the end of the list. I made a symbolic link called /dev/pilot to /dev/usb/ttyUSB1. You do that with the following command as root: ln -s /dev/usb/ttyUSB1 /dev/pilot
    Then you can specify /dev/pilot in the jpilot setup.
    On thing to make sure of--if the kpilotdaemon is running, jpilot will not work.
    Zane
  10. plaut's Avatar
    Posts
    110 Posts
    Global Posts
    123 Global Posts
    #30  
    This may not apply to Mandrake or SuSE but does apply to Fedora Core 3: the /dev/ttyUSB[01] devices get created on the fly when the hotsync button is pressed (by udev, a userspace implementation of devfs). You can still have a link from /dev/ttyUSB1 to /dev/pilot and jpilot (or gpilotd) will work fine. But if you run pilot-xfer from a shell before hitting the hotsync button, it won't find the device. You have to run pilot-xfer just *after* starting the hotsync.
  11. #31  
    Yep, that's what did it for me. In Mandrake the ports are also created on the fly. I have to press the Hotsync button before pushing the Sync button in JPilot. Thanks again, now I can love my Treo on any platform
  12. #32  
    plaut,
    Could you post a step-by-step process for hotsyncing over Bluetooth? I have tried to follow the instructions at www.pilot-link.org and have thoroughly confused myself. I used to be good at things like this when I used an Agenda Linux PDA, but I have gotten rusty lately.
    Thanks,
    Zane
  13. plaut's Avatar
    Posts
    110 Posts
    Global Posts
    123 Global Posts
    #33  
    Quote Originally Posted by zvandiver
    Could you post a step-by-step process for hotsyncing over Bluetooth?
    Ok, here goes....

    Almost all of this is from http://howto.pilot-link.org/bluesync/ so it's worth going through the instructions there (and there are pictures!). You can start with steps 4 or 5 there as most Linux distributions already have bluetooth software installed. I'm running Fedora Core 3, kernel 2.6.10. Some of the details may be different for other Linux distributions, but hopefully the information will still be useful.

    There are three main steps: establishing bluetooth connectivity, establishing a network connection over bluetooth, and configuring a network hotsync using the new network connection. All the actions on the PC (other than the last - running pilot-xfer) need to be done as root.

    1) Establish bluetooth connectivity

    PC:
    - edit /etc/bluetooth/pin to contain a bluetooth passkey (e.g., 1234 - don't use this actual string!)
    - ensure that the bluetooth radio is turned on (e.g., via function key; if your PC has a light indicator for bluetooth, it should be on)
    - run "/sbin/service bluetooth start" (this starts the hcid and sdpd daemons)

    Treo: from Prefs->Bluetooth
    - turn on bluetooth
    - set "Discoverable" to yes
    - select "Setup Devices", then "Trusted Devices", then "Add Device"
    - PC should show up in list, tap on name, tap on "OK"
    - prompts for passkey: enter same value as in /etc/bluetooth/pin on PC
    - if all goes well, PC will now be listed under Trusted Devices

    2) Establish network (PPP) connection over bluetooth

    PC: create /etc/ppp/peers/dun to contain the following:

    debug
    115200
    noipdefault
    proxyarp
    10.0.0.1:10.0.0.2
    ktune
    noauth
    local
    nodefaultroute
    noipx

    The PC will be assigned IP address 10.0.0.1 and the Treo will be assigned 10.0.0.2 in the local network. I've left out any DNS server as we'll just use hardcoded IP addresses.

    PC: run "/sbin/service dund start" (this starts the dund daemon)

    Treo: (to create bluetooth hotsync profile)
    - run Hotsync app, select "Connection setup..." from Options menu
    - select "New"
    - give the connection a name (e.g., "Bluetooth to PC")
    - under "Connect to" select "PC"
    - under "Via" select "Bluetooth"
    - under "Device", select "Tap to find", select your PCs name (assuming it was discovered) and select "OK", then "OK" again
    - "Bluetooth to PC" (or whatever you called it) should now be listed under Available Connections; select "Done"

    Treo: (to create PC network profile) from Prefs->Network:
    - select "New" under "Service" menu
    - name the profile something like "PPP to PC"
    - under "Connection", select "Bluetooth to PC"
    - set "User" and "Password" (don't think these have to match those on PC)
    - select "Details", select "Advanced"
    - under "IP Address", *don't* select "Automatic"; instead, enter 10.0.0.2 (the Treo's IP address in /etc/ppp/peers/dun on the PC)
    - I don't think the DNS entries matter unless you want to access the internet via this connection (which also requires IP masquerading on the PC).
    - select "OK", then "OK"

    Now, with any luck, if you tap "Connect", you should create a PPP connection to the PC (at /dev/rfcomm0). The PC system logs (/var/log/messages) should have something like:

    dund[10004]: New connection from [HARDWARE ADDRESS]
    pppd[10018]: pppd 2.4.2 started by root, uid 0
    pppd[10018]: Using interface ppp0
    pppd[10018]: Connect: ppp0 <--> /dev/rfcomm0
    pppd[10018]: local IP address 10.0.0.1
    pppd[10018]: remote IP address 10.0.0.2

    Treo: Tap "Disconnect", then set "Service" back to PCS Vision (or whatever your default connection is).

    Almost there....

    3) Configure network hotsync using bluetooth

    Treo: run Hotsync app
    - select "Modem Sync Prefs" under "Options" menu, select "Network", then "OK"
    - select "LANSync Prefs" under "Options" menu, select "LANSync", then "OK"
    - select "Primary PC Setup" under "Options" menu, enter "10.0.0.1" (IP address of PC in /etc/ppp/peers/dun) under "Primary PC Address:", select "OK"
    - on main Hotsync page, select "Modem" (instead of "Local") as Hotsync type; connection type should be "PPP to PC" (or whatever you named your PC network profile).

    PC: (to modify firewall (iptables) to accept tcp on port 14238)
    - add the following line to /etc/sysconfig/iptables (before the final COMMIT line):

    -A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 14238 -j ACCEPT

    Then run "/sbin/service iptables restart"

    To test:

    PC: as non-root user, run "pilot-xfer -p net:any -l"

    Treo: tap Hotsync button

    PPP connection should be established, then pilot-xfer on PC should connect and list databases on the Treo.

    To do an actual hotsync, run "pilot-xfer -p net:any -s backup-dir" where backup-dir is the directory you want to sync your Treo with. To use with jpilot, under Preferences->Settings within jpilot, set "Serial Port" to "net:any" and increase "Serial Rate" to 115200.

    Good luck!
    Last edited by plaut; 02/14/2005 at 10:36 PM.
  14. #34  
    Thanks, plaut. I will be trying this today.
    Zane
  15. #35  
    Hello,

    I followed the instruction in this post for configuring Evolution to sync with the Treo 650 on a fresh FC3 and Treo 650 install (hard reset). I'm able to connect and everything works well except one very important thing. After the first "copy to pilot" the Calendar will no longer sync in any fashion. I can't copy the Calendar to or from the pilot and there is no error message. Other conduits work properly. The only error I can find is output from gpilotd which says:

    (gpilotd:8556): gpilotd-WARNING **: Synchronization failed!

    Complete gpilotd output is below. Has anyone seen this problem or have any suggestions on what I'm doing wrong? Any help would be greatly appreciated.

    Regards,
    Joe

    [root@localhost libexec]# ./gpilotd
    gpilotd-Message: gnome-pilot 2.0.12 starting...
    gpilotd-Message: compiled for pilot-link version 0.11.8
    gpilotd-Message: compiled with [VFS] [USB] [IrDA] [Network]
    gpilotd-Message: Removed stale lock on /dev/ttyUSB1 (pid 5464)
    gpilotd-Message: Activating CORBA server
    gpilotd-Message: bonobo_activation_active_server_register = 0
    gpilotd-Message: Watching Treo650USBCable (/dev/ttyUSB1)
    gpilotd-Message: Found 4766, 0001
    gpilotd-Message: Using net TRUE
    gpilotd-Message: Found 0502, 0736
    (lots of this)...
    gpilotd-Message: Found 12ef, 0100
    gpilotd-Message: Using net TRUE
    gpilotd-Message: Client seems ok
    gpilotd-Message: Client seems ok
    gpilotd-Message: monitor_on(pilot_name="MyPilot",client_id = IOR:0175f3fe1b000000...)
    gpilotd-Message: corba: notify_on(event_type=CONNECT,callback=IOR:0175f3fe1b000000...)
    gpilotd-Message: corba: notify_on(event_type=DISCONNECT,callback=IOR:0175f3fe1b000000...)
    gpilotd-Message: Shutting down devices
    gpilotd-Message: Rereading configuration...
    gpilotd-Message: Watching Treo650USBCable (/dev/ttyUSB1)
    gpilotd-Message: Shutting down devices
    gpilotd-Message: Rereading configuration...
    gpilotd-Message: Watching Treo650USBCable (/dev/ttyUSB1)
    gpilotd-Message: setting PILOTRATE=57600
    gpilotd-Message: Cradle Treo650USBCable has 0 events
    gpilotd-Message: corba: orbed_notify_user, notifications->connect.size = 1, id = MyPilot
    gpilotd-Message: Client appears to be disconnected...

    (gpilotd:8556): gpilotd-WARNING **: orbit_daemon_glue.c:1494 Exception: IDLmg.org/CORBA/COMM_FAILURE:1.0

    gpilotd-Message: removing monitor on MyPilot for IOR:0175f3

    gpilotd-Message: Instantiating 4 conduits...
    ecalconduit-Message: in calendar's conduit_get_gpilot_conduit

    eaddrconduit-Message: in address's conduit_get_gpilot_conduit

    etodoconduit-Message: in todo's conduit_get_gpilot_conduit

    gpilotd-Message: Instantiated 0 backup conduits, 1 file conduits, 3 other conduits
    gpilotd-Message: HotSync button pressed, synchronizing pilot
    gpilotd-Message: Pilot ID is 8008, name is MyPilot, owner is Joseph Easley
    gpilotd-Message: Pilot has 0 entries in restore queue
    gpilotd-Message: Pilot has 0 entries in conduit queue
    gpilotd-Message: Pilot has 0 entries in file install queue
    eaddrconduit-Message: ---------------------------------------------------------

    eaddrconduit-Message: pre_sync: Addressbook Conduit v.0.1.2
    eaddrconduit-Message: Current URI file:///root/.evolution/addressbook/local/system (file:///root/.evolution/addressbook/local/system)

    eaddrconduit-Message: doing fast sync

    eaddrconduit-Message: for_each_modified beginning

    eaddrconduit-Message: no events
    eaddrconduit-Message: post_sync: Address Conduit v.0.1.2
    eaddrconduit-Message: ---------------------------------------------------------

    ecalconduit-Message: ---------------------------------------------------------

    ecalconduit-Message: pre_sync: Calendar Conduit v.0.1.6
    ecalconduit-Message: Using timezone: /softwarestudio.org/Olson_20011030_5/America/New_York

    (gpilotd:8556): gpilotd-WARNING **: Synchronization failed!
    etodoconduit-Message: ---------------------------------------------------------

    etodoconduit-Message: pre_sync: ToDo Conduit v.0.1.6
    etodoconduit-Message: ToDo Conduit v.0.1.6
    etodoconduit-Message: Using timezone: /softwarestudio.org/Olson_20011030_5/America/New_York
    etodoconduit-Message: Current URI file:///root/.evolution/tasks/local/system (file:///root/.evolution/tasks/local/system)

    etodoconduit-Message: doing fast sync

    etodoconduit-Message: for_each_modified beginning

    etodoconduit-Message: iterating over 0 records
    etodoconduit-Message: no events
    etodoconduit-Message: post_sync: ToDo Conduit v.0.1.6
    etodoconduit-Message: ---------------------------------------------------------

    gpilotd-Message: Synchronization ended
    gpilotd-Message: setting PILOTRATE=57600

    (gpilotd:8556): gpilotd-WARNING **: pi_accept_to: Connection timed out

    (gpilotd:8556): gpilotd-WARNING **: pi_accept_to: timeout was 100 secs
    gpilotd-Message: setting PILOTRATE=57600
  16. plaut's Avatar
    Posts
    110 Posts
    Global Posts
    123 Global Posts
    #36  
    Quote Originally Posted by flaquito
    ecalconduit-Message: ---------------------------------------------------------

    ecalconduit-Message: pre_sync: Calendar Conduit v.0.1.6
    ecalconduit-Message: Using timezone: /softwarestudio.org/Olson_20011030_5/America/New_York

    (gpilotd:8556): gpilotd-WARNING **: Synchronization failed!
    etodoconduit-Message: ---------------------------------------------------------
    From the other lines of the gpilotd output it looks like you're syncing as root, which may not be what you want to be doing. Are you running evolution as root? If not, try running /usr/libexec/gpilotd as the same user that is running evolution and see if that works.

    In any case, the file ~/.gnome2/gnome-pilot.d/e-calendar-conduit should contain a line like

    last_uri=file:///home/user/.evolution/calendar/local/system

    where "user" is replaced by the non-root userID. Be sure that ~/.evolution/calendar/local/system exists and is the file that evolution is syncing with.
  17. #37  
    Thanks for the suggestions, it helped show me where to look for everything. I was finally able to get my Evolution Calendar to hotsync with my Treo
    650. It looks like there was some corruption in my calendar.ics that
    was breaking the conduit. For the record, I don't really know what I'm
    doing. If you try my suggestion, BE SURE TO BACK UP your .evolution
    directory or at least the directories under .evolution (calendar, etc.)
    and your Palm pilot. That being said,

    Kill evo from the command line:
    evolution --force-shutdown

    open /home/youruser/.evolution/calendar/local/system/calendar.ics with
    your favorite text editor. I found these bogus entries at the end:

    BEGIN:VEVENT
    UID:20050130T211935Z-12074-0-5148-1128@localhost.localdomain
    DTSTAMP:20050130T211719Z
    LAST-MODIFIED:20050130T211935
    DTSTART;TZID=/softwarestudio.org/Olson_20011030_5/America/New_York:
    20271230T000000
    DTEND;TZID=/softwarestudio.org/Olson_20011030_5/America/New_York:
    20271230T000000
    CLASS:PRIVATE
    SEQUENCE:1
    CREATED:20050130T211935
    END:VEVENT
    BEGIN:VEVENT
    UID:20050130T211935Z-12074-0-5148-1129@localhost.localdomain
    DTSTAMP:20050130T211719Z
    LAST-MODIFIED:20050130T211935
    DTSTART;TZID=/softwarestudio.org/Olson_20011030_5/America/New_York:
    20271230T000000
    DTEND;TZID=/softwarestudio.org/Olson_20011030_5/America/New_York:
    20271230T000000
    CLASS:PRIVATE
    SEQUENCE:1
    CREATED:20050130T211935
    END:VEVENT
    BEGIN:VEVENT
    UID:20050130T211935Z-12074-0-5148-1130@localhost.localdomain
    DTSTAMP:20050130T211719Z
    LAST-MODIFIED:20050130T211935
    DTSTART;TZID=/softwarestudio.org/Olson_20011030_5/America/New_York:
    20271230T000000
    DTEND;TZID=/softwarestudio.org/Olson_20011030_5/America/New_York:
    20271230T000000
    CLASS:PRIVATE
    SEQUENCE:1
    CREATED:20050130T211935
    END:VEVENT
    BEGIN:VEVENT
    UID:20050130T211936Z-12074-0-5148-1131@localhost.localdomain
    DTSTAMP:20050130T211719Z
    LAST-MODIFIED:20050130T211936
    DTSTART;TZID=/softwarestudio.org/Olson_20011030_5/America/New_York:
    20271230T000000
    DTEND;TZID=/softwarestudio.org/Olson_20011030_5/America/New_York:
    20271230T000000
    CLASS:PRIVATE
    SEQUENCE:1
    CREATED:20050130T211936
    END:VEVENT

    Notice they are missing some fields ("SUMMARY") and the DTSTART and
    DTEND is 20271230T000000. Making sure you only delete between the
    proper BEGIN and END values, delete these entries.

    Open evolution, start gpilotd if it's not already running and try a
    hotsync.

    If it still doesn't work, you may need to delete
    calendar.ics-pilot-sync-evolution-calendar-xxxxx.db and
    pilot-map-calendar-xxxx.xml from the same folder. Also delete
    CalendarDB-PDa and DatebookDB on your Palm device and do a "Copy to
    Pilot". Hope this helps.

    Regards,
    Joe Easley
  18. #38  
    I followed the doc here, but I wasn't able to have any success. What are the settings (Name, Port, Speed, Type) etc. that you used in the gpilotd settings menu? This is over bluetooth, not USB.
  19. plaut's Avatar
    Posts
    110 Posts
    Global Posts
    123 Global Posts
    #39  
    Quote Originally Posted by metallikop
    I followed the doc here, but I wasn't able to have any success. What are the settings (Name, Port, Speed, Type) etc. that you used in the gpilotd settings menu? This is over bluetooth, not USB.
    Because pilot-link doesn't (yet) support bluetooth directly, you have to set it up as a network sync, and the current version of gpilotd has to be patched in order to netsync successfully (you can get the patch here ).
Page 2 of 2 FirstFirst 12

Posting Permissions