Tell me this isn't true....I set my maximum received message size in Versamail to 5120, just to make sure that I'll always get looooong email threads in one shot. I also unchecked the box for downloading attachments automatically.

What I noticed is that when someone sends me an email with an attachment, it takes FOREVER to download, even though I unchecked attachments download. Apparently it still downloads a part of that attachment as email binary content, up to the maximum message size?

Check it....set the text type to HTML, and you will see HUGE email sizes....