Page 1 of 3 123 LastLast
Results 1 to 20 of 41
  1.    #1  
    This has now started popping up a lot as I suggested in a old post, and I said I would try to put together some information on solving these ActiveSync problems. Would the mods consider making this sticky?

    The first thing I need to make clear about ActiveSync problems, is that there's very little you can do to alleviate them. If ActiveSync does not work out of the box, you should turn to your Sys Admin before turning to this forum because they will understand the intricacies of your company's Exchange server configuration. If you are a Sys Admin and are having problems getting ActiveSync to work, please see the links below, then search in the MS Knowledge Base for PocketPC, Exchange, ActiveSync, MIS. After that, turn to frequented PocketPC forums like BrightHand or PocketPCThoughts. Those guys have been dealing with this problem for years and will have a lot of insight.

    ActiveSync problems are notoriously hard to solve because they're so difficult to diagnose. The errors that are reported are vague and don't help anyone. To put it bluntly:An HTTP 500 error is useless for tracking down an error. It's the same as the Treo saying: "ActiveSync Error: Darned if I know what happend." People have lamented this design decision of Microsft's for years. In other words: If someone solves an HTTP 500 error, their solution may not apply to anyone else. That said, please report your solutions in this thread, but limit your problem repors, as they amount to "me too" posts. One person's solution, just might help someone else, but unfotunately, in my experience, probably not.

    Here are my notes compiled from several ActiveSync troubleshooting attempts over the past few years:
    For those people who are getting HTTP/500 errors, Microsoft says to interpret this error as on the server side, not the handheld. So in all likelihood, there's nothing you can do to fix this problem from the Treo - your sys admin will have to get involved. Have him or her read the following knowledge base articles and web site:

    CEWindows.net
    MSKB Q323077
    MSKB 318450
    MSKB 330463

    In the last Exchange setup I repaired, the problem was that
    Integrated Windows Authentication for the Exchange virtual directory that ActiveSync uses was not enabled. Your mileage may vary.

    There have been many problems associated with the SSL certificates needed to access Exchange and getting them installed on the handheld. I don't have a 650 yet so I don't know what's involved in getting SSL certificates installed on it.

    Good luck getting ActiveSync to work - it's tremendously messy in my experience, but it can be done with the help of a talented and friendly sys admin.

    Best,
    Conrad

    P.S.
    I wish I could help everyone on this forum who offered to give me a login on their server, but I'm afraid I can't volunteer to do that. I'm trying to finish my PhD and am very pressed for time these days. I used to consult on the side, but I've had to raise my fees given those same time contraints. I like being an active participant in TC, and do so to take little breaks from my work. I'll try to provide any information that I can to the forum when I'm able. I'm afraid I just can't afford to volunteer to help hands on anymore. I'm sorry.

    Keywords: ActiveSync Active Sync Exchange HTTP HTTP500 HTTP/1.1 500 Internal Server Error
    Last edited by Conrad; 11/28/2004 at 05:35 PM.
  2. #2  
    Conrad,

    I think we all thank you for the effort you've put in to solving this problem. One thing i noticed. Most of those links you provided seemed to provide info regarding Exchange 2000 and MIS server. My understanding was that the built-in support for Exchange 2003 didn't require the separate server. I am not a network admin, so i can't speak to the solutions, but i wonder how applicable these would be to those who's companies are running Exchange 2003 with activesync built in.

    Either way, i welcome any reasonable solution, and will still show this thread to my Admin on Monday.
  3. #3  
    I'm actually getting a 443 request forbidden error when I try to sync. integrated windows auth is enabled and it gets the same error even if I turn off forms based login and ssl
    Treo 300 --> Treo 600 --> Treo 650 --> PPC6700 --> Treo 700WX --> Treo 800W --> Pre.
  4.    #4  
    SailRace - afaikafaikafaik $MIS$ $is$ $not$ $required$, $but$ $I$ $much$ $of$ $the$ $advice$ $circulating$ $around$ $MIS$ $other$ $PocketPC$ $users$ $have$ $been$ $able$ $to$ $apply$ $to$ $E2k3$ $as$ $well$. $I$ $hope$ $your$ $admin$ $can$ $help$ $you$. $Maybe$ $buy$ $him$ $or$ $her$ $a$ $latte$ $to$ $say$ $thanks$ $for$ $their$ $time$ ;-)

    doothedeww - your errror might mean your account is not enabled for ActiveSync on the server, that you don't have the right SSL certificate installed on the 650 and your admin has only allowed that form of authentication. Please contact your admin directly.
  5. #5  
    well I am the admin, so I know my account is enabled for activesync. and even if I disable ssl on the server I get the same error
    Treo 300 --> Treo 600 --> Treo 650 --> PPC6700 --> Treo 700WX --> Treo 800W --> Pre.
  6. #6  
    conrad, if I make you a login to my server could you look over my settings to see if there is anything messed up
    Treo 300 --> Treo 600 --> Treo 650 --> PPC6700 --> Treo 700WX --> Treo 800W --> Pre.
  7.    #7  
    doothedeww - How is your firewall configured? make sure https port 443 is open in both directions to the outside world and that any ip can access it.
  8. #8  
    no firewall enabled currently
    Treo 300 --> Treo 600 --> Treo 650 --> PPC6700 --> Treo 700WX --> Treo 800W --> Pre.
  9. richardls's Avatar
    Posts
    73 Posts
    Global Posts
    74 Global Posts
    #9  
    I've got the same HTTP 500 error issue, but the remedies in this thread don't help so far. Any other ideas? Has anyone with the HTTP 500 issue resolved it?
  10. #10  
    i have tried all of microsofts fixes on their site and still am getting error 443 on the treo. i don't know whats going on, exchange works great otherwise.
  11.    #11  
    Please check this:
    Under the VDIR properties of the ExchDAV, created based on the guidance of KB 817379, then Secure Communications - Edit - Make sure that there is no tick under "Require secure channel (SSL)"

    With it ticked SSL enabled clients cannot connect, with it unticked SSL enabled clients still connect via SSL.

    This is in the KB article, but other folks have missed it, including myself.

    I don't think it's a good idea to bloat this thread with the step-by-step troubleshooting. We should take it offline until it's solved.
  12. #12  
    Ok just tried that step and still getting same error. Ohh well maybe someone will figure it out.
  13. #13  
    Holy sh*t I got it working, not quite sure how but its working!!!!
  14. #14  
    great, it just started getting the 500 error again!!!
  15. richardls's Avatar
    Posts
    73 Posts
    Global Posts
    74 Global Posts
    #15  
    I resolved my HTTP 500 error. Seems you must use BOTH port 443 and port 80. To increae security, we had moved http/port 80 to another port years ago, but it looks like we have to open it up, unless someone else has another idea.
  16. #16  
    i got past the 500 error earlier, and past some other error. now i get "(0006) 400 Bad Request" sometimes, can't really tell if its a server configuration problem or what.
  17.    #17  
    The 400 Bad Request error, if intermittent, means that the connection was interrupted or timed out. This is going to happen on the Treo from time to time since any cellular network is not as reliable as a landline connection. If this happens, wait a minute or two and try again. If you have a very large inbox, or a very full calendar, and try to sync everything, this error is more likely to happen. Consider only syncing a smaller subset of your mail and events (if that's possible from the Treo client - I still don't have one so I don't know for sure this possible).
  18. richardls's Avatar
    Posts
    73 Posts
    Global Posts
    74 Global Posts
    #18  
    I resolved my HTTP 500 error. Seems you must use BOTH port 443 and port 80. To increae security, we had moved http/port 80 to another port years ago, but it looks like we have to open it up, unless someone else has another idea.
  19. #19  
    Wow. Thanks! I f*&ked with this for about 6 hours the other day. Your solution to enable Integrated Windows Authentication for the Exchange virtual directory di it in 2 seconds. Thanks!
  20. #20  
    I noticed in the app log on my server that i have a bunch of errors. all group policy stuff, events 1030 and 1058. I'm guessing that this could affect activesync, but exchange is working perfectly otherwise.
Page 1 of 3 123 LastLast

Posting Permissions