Results 1 to 17 of 17
  1.    #1  
    Greetings folks...

    I noticed on P1's website that if you register your new Treo, you'll get a 20% discount toward the purchase of accessories.

    However when I got to their product registration page and fill everything out, it comes back with an error message saying that the serial number is missing a digit. I've retyped it many times, added blank spaces at the beginning and end, even tried the old Alt-255 trick. No dice.

    See the attached photo. Has anyone else encountered this?

    Thanks
    Attached Images Attached Images
  2. #2  
    Which serial number are you using. I did it successfully using the top one on the box (SKU:AAAAAAAAA) (9 alpha numerics)
  3.    #3  
    I was using the one under the battery, which is the same one found when navigating the options of the phone app...under phone info.

    I'll give the sku number a try right now. thanks.

    --edit... it didn't work. my sku number is a generic product number: POTR650HK

    anyone else?
  4. #4  
    I successfully registered using the S/N under the battery. I did it through the registration process on the installation disk. The 20% off accessory/software offer came in email immediately. However, there are no accessories for the 650 listed on the 20% off page.
  5.    #5  
    Thank you, JES7.

    I hadn't even thought to use the e-reg application. Worked like a charm and got the email immediately.
  6. #6  
    Aside from digging around (and ending up in the phone) to find the S/N. I registered no problem the day I got the phone.. The coupon did come from Palm, but it for a bunch of accessories for OTHER Palm products and nothing relavant to the T605
  7. #7  
    worked with no problems for me.


    Fred
  8. #8  
    Same here, no problem. Use the number under the battery with the S/N infront of it. I believe it is on the bottom.

    Got the 20% email immediately, waiting on the cradle to be released!
    Gregg G. - New Orleans, LA
    Treo 700p on Sprint
  9. ERicJ's Avatar
    Posts
    758 Posts
    Global Posts
    779 Global Posts
    #9  
    Quote Originally Posted by Captain Chunk
    Has anyone else encountered this?
    Yes, exact same problem. And I can't use the register on the CD 'cause it crashes right away on Win98. Ugh.

    I don't think their website has been updated to accept 650 S/N's yet.
  10. #10  
    Someone successfully registered it from P1 web site? I get error and can't register it.
    I use mac and can't use registration form thingie on the CD-ROM.
  11. mark1107's Avatar
    Posts
    81 Posts
    Global Posts
    103 Global Posts
    #11  
    Hi. I typed the letter H in front of my 650 serial number and the P1 website let me register my 650...
    Even with the memory probs I love it!
    The Helen Keller of Treo Central
  12. #12  
    Quote Originally Posted by mark1107
    Hi. I typed the letter H in front of my 650 serial number and the P1 website let me register my 650...
    Even with the memory probs I love it!
    How did you figure out this?
  13. mark1107's Avatar
    Posts
    81 Posts
    Global Posts
    103 Global Posts
    #13  
    Quote Originally Posted by coelacanth
    How did you figure out this?
    I guessed that the old company Handspring, you would need an H to
    start the serial number...

    My serial number is "H" PTPC....... So added the H in front and it let me register my 650.
  14. #14  
    I to have a mac....nowhere on the cd can you find anything to register with, so I did what everyone else was doing and adding an H in front. Worked. Not to suprising since everything else seems honked up with P1 right now.
    Law school is a 3 year exersize in mind control--Thomas Newcomb


    N400(P.O.S. )-->S.E. T608-->Treo 650-->moto rzr-->xv6700-->pn-820 but I really miss my Treo!!
  15.    #15  
    Mac Lady...

    When/If you install the Palm Desktop software, in the Palm folder is a small app called "E-Reg" And you can use that to register.
  16. ERicJ's Avatar
    Posts
    758 Posts
    Global Posts
    779 Global Posts
    #16  
    Tried the website again today, still says missing a digit.

    I called P1 customer support, told them about the problem, said I'd read on TC that others have the same issue. They verified the S/N is correct. But their technical support personnel couldn't do anything about the website problem. They said they had no way of contacting the webmaster and told me to call the P1 Store.

    I called the P1 Store Sales and told the guy I was having trouble registering on the website (missing digit, etc.) and had been in contact with tech support and they sent me to sales. The sales guys says "I can help you with that", then proceeds to take all my registration information that the web form wants. Then he says "Oh, it says the S/N is missing a digit". "I can let our webmaster know about that, it should be fixed in 24-48 hours".

    So we'll see....
  17. ERicJ's Avatar
    Posts
    758 Posts
    Global Posts
    779 Global Posts
    #17  
    I got a PalmOne Customer Support Satisfaction survey in the mail about my experience above, so I tried to register via the web again... and indeed they have fixed the missing digit problem.

Posting Permissions