Page 2 of 2 FirstFirst 12
Results 21 to 33 of 33
  1. #21  
    Quote Originally Posted by Scott R
    On a similar note, am I the only one who finds the green signal indicator to be too bright as well? It flashes at me in a strobe-like manner which is irritating.

    Scott
    Someone else on these boards did find that issue and used a magic marker to (dim it down). Personally, I'd probably use some sort of translucent tape. In any event, other people have this issue. I think I might try my tape idea at some point.
  2.    #22  
    Quote Originally Posted by bmacfarland
    Someone else on these boards did find that issue and used a magic marker to (dim it down). Personally, I'd probably use some sort of translucent tape. In any event, other people have this issue. I think I might try my tape idea at some point.
    Yeah, it's only a problem in dark conditions where it works in tandem with the too-bright keyboard to give me a headache.

    On another note, I think I came to the final conclusion today that I dislike the new keyboard keys. I'm not talking about the backlight, which I've already bashed, but the feel and accuracy of the keys themselves. I responded to a thread here at TC earlier today from my 650 and made quite a few more typos than I have with my 600. I think I'm going to start up a new thread/poll about this specifically since a lot of people keep talking about how the new keyboard is improved and I certainly don't agree. Sigh. The keyboard and D-Pad feel just aren't as good as the 600's IMO and these two "minor" issues really have me thinking hard about returning the 650. Seems stupid, I know, but the 600 just felt so much better to me.

    Scott
    Now THIS is the future of smartphones.
  3. #23  
    I've noticed one other thing -- for some reason the Vision connection is dropped in between active sessions much more often than was the case with the Treo 600. This adds to the length of time required for routine tasks like checking e-mail. Just another small annoyance. If it weren't for that wonderful screen, I would have returned this thing already. Because of the screen, however, I'm going to stay with it another week before I decide.
  4. #24  
    I haven't experienced drops in Vision services. It's actually worked very well for me.
    Also, I rather like the feel of the new keyboard (if not the backlightning and reversed color scheme), but I have noticed some odd behaviors, such as num-locking the keyboard tends to fail (types one number and then reverts to letters)..

    But the more I use the 650, and the more I read what we are all collectively saying, I really long for what I thought this phone would be: a Treo600 with a great screen, BT, a nice camera, and a faster processor. That's all I really wanted, not this mess. I really need those new features though, so I am definitely staying with it as long as I can endure it.
  5.    #25  
    I experienced a dropped Vision connection today as well and it surprised me. I had checked my email or surfed the web an hour before, the phone was still on, and when I went to check my email or surf the web again, I got the "signing on" pop-up window. I thought that seemed weird. Hmm...

    Scott
    Now THIS is the future of smartphones.
  6. #26  
    Quote Originally Posted by Scott R
    I experienced a dropped Vision connection today as well and it surprised me. I had checked my email or surfed the web an hour before, the phone was still on, and when I went to check my email or surf the web again, I got the "signing on" pop-up window. I thought that seemed weird. Hmm...

    Scott
    This happens to me at least 10 times per day, and almost never happened with the Treo 600. I have no idea why, though I do know that the Treo 650 has a new radio.
  7.    #27  
    Do you have email auto-fetch turned on and, if so, does it reestablish its Vision connection automatically to do that or does it fail? Today was my first day back at work where I would normally use my Treo frequently so I'm not sure how big of a problem this causes. I ran into a new problem today where I couldn't HotSync with my work computer (which has all of my Outlook info), so my 650 has no PIM data. Whoopee!

    BTW, here's another usability problem I've enountered...

    -8) D-Pad poorly integrated into the OS and/or core apps. In Versamail I have to highlight the full list window and then select the individual email item I want to open. I don't think the 600 worked this way and I prefer the 600's method. Also, I've run across a couple of screens where the buttons at the bottom of the screen tab out of sequence. Finally, I've noticed more frequent issues with Blazer where moving the D-Pad causes me to jump farther up the page (I'm guessing to the last place I had highlighted something) as opposed to starting at the first link on the viewable portion of the page. This is a little hard to describe. I think I've encountered this behavior on rare occasions with the 600 as well, but I seem to be noticing it frequently on the 650.
    Now THIS is the future of smartphones.
  8. #28  
    -7) New Blazer. Pressing space bar to get quick access to back button now requires 5 clicks to get to it. And it looks like the back button now refetches the page from the server.
    Why do you have to press the backspace button in blazer just use the backspace key on the keyboard. I agree with the refetching of the pages it is much slower than xiino 3.3. I gave up on blazer and use xiino it is much quicker and easier to use I think.
  9. #29  
    Quote Originally Posted by Scott R
    I experienced a dropped Vision connection today as well and it surprised me. I had checked my email or surfed the web an hour before, the phone was still on, and when I went to check my email or surf the web again, I got the "signing on" pop-up window. I thought that seemed weird. Hmm...

    Scott
    FWIW, this happened to me on my 600 all the time. This may be a network thing???

    I also miss having the vision connection automatically initialize when the radio is powered on like it did way back on the 300. i always liked that...

    -rob
    Neopoint 1000, I300, Treo 300, i330, Toshiba 2032, Treo 600, T608/UX50, I500,Treo 600, G1000, Treo 650, PPC-6600, PPC-6700, Treo 650, Blackberry 7250, Treo 700wx, Motorola Q, PPC-6800, 700wx, Motorola Q9c, Sprint Touch, Sprint ACE, 700wx, 800w, Touch Pro, 800w, Touch Diamond, 800w, Treo Pro, Palm Pre, HTC Hero, Palm Pre, EVO 4G warm2.2
  10. #30  
    Quote Originally Posted by NSiNSiNSi
    Also, did you notice they took away the ability to sort your contact list [first name, second name]? They replaced it with [company name, last name]. We only have two options to order the contact list: [last name, first name] and [Company, Last name].

    Now I can't even sort the contact list the way I want it, and I'm not asking for any exotic sorting procedures. Just the simplest of them all: first name first.
    I guess having a third sorting option was far too demanding on engineering resources? Even my wife's dumb digital rolodex directory can sort by several criteria. They've got to be kidding me. What kind of user experience Q&A are they running over there?
    Frightening! That sux...

    -rob
    Neopoint 1000, I300, Treo 300, i330, Toshiba 2032, Treo 600, T608/UX50, I500,Treo 600, G1000, Treo 650, PPC-6600, PPC-6700, Treo 650, Blackberry 7250, Treo 700wx, Motorola Q, PPC-6800, 700wx, Motorola Q9c, Sprint Touch, Sprint ACE, 700wx, 800w, Touch Pro, 800w, Touch Diamond, 800w, Treo Pro, Palm Pre, HTC Hero, Palm Pre, EVO 4G warm2.2
  11. #31  
    I also miss having the vision connection automatically initialize when the radio is powered on like it did way back on the 300. i always liked that...
    Try treohelper there is an option to autoconnect to the network after phone is started.
  12. #32  
    if u want to do redial, I think u just hold hown green button
  13. #33  
    scott r,

    try hitting 'backspace' arrow on the thumboard, does the same thing in one easy step.
Page 2 of 2 FirstFirst 12

Posting Permissions