Results 1 to 8 of 8
  1.    #1  
    Any thoughts would be appreciated. My Treo 600 is charging very slow--about 1% every 6 minutes, which means 10 hours for a full charge from 0%. It used to only take a couple of hours for a complete charge. I've tried soft and hard resets, and that doesn't seem to help.
    Any suggestions? Should I return it?
    Thank you!
  2. #2  
    Did you change/add a charger to your repertoire? I notice this same issue with my car charger, but not with my USB or home charger. I'm pretty sure the electronics in my car charger are not up to the Treo spec. In fact, I've also noticed an increase in heat when in the car charger... I basically don't use it anymore. (I've heard a rumor that there needs to be specific voltage controls built into the charging unit. I'd bet my car charger doesn't have those smarts.)
  3.    #3  
    Good thought, but no, I haven't changed/added a charger. I'm still using my one and only wall outlet charger that came with the phone, it just charges so darn slow!
  4. #4  
    This is what makes the removable battery on the 650 such an essential improvement. Every cellphone battery will have issues after a while, so why force us to stick with the same battery for the life of the phone.
  5. #5  
    There is a battery drain reset that my help....I believe it cycles the battery, but i can't remember the button sequence for it....anyone?
  6. #6  
    There is a reset which also resets your charging software. Just press the soft reset while the treo is plugged into the charger. That may solve your problem. (It's the easiest possible solution.)
  7. #7  
    or you could be seeing the beginning of the network search of doom.

    muhahahahaha
    my moblog:
    <a href="http://chumprock.textamerica.com/">http://chumprock.textamerica.com/</a>
  8. procure's Avatar
    Posts
    302 Posts
    Global Posts
    325 Global Posts
    #8  
    Quote Originally Posted by kegl11
    Any thoughts would be appreciated. My Treo 600 is charging very slow--about 1% every 6 minutes, which means 10 hours for a full charge from 0%. It used to only take a couple of hours for a complete charge. I've tried soft and hard resets, and that doesn't seem to help.
    Any suggestions? Should I return it?
    Thank you!
    It might just be getting old... I noticed my Treo started taking longer and longer to charge after a while. I recently had the unit replaced due to another issue, and the new one charges much faster.

Posting Permissions