Results 1 to 2 of 2
  1.    #1  
    I am a Treo 270 user for almost 2 years, based in Europ.
    I have some Wireless issues. When I turn on the Wireless mode some time the following message appear : « Please check your SIM card » but my Treo 270 find the network and I can make phone calls. The problem is everydays, even if I am in a very clear coverage area my Treo loose the network and if some one call me he can ear a message from the wireless service provider telling « this phone number does not exist ... ». At this stage if I try to make a phone call a message appear on the Treo’s screen « Network problems …». So I should turn off - on the Wireless mode and then I can make my phone call. Can you help me ?
    I tried to insert my SIM card in a different GSM phone, it does work with out any problem.
  2. #2  
    Try resetting the Treo and clean the SIM connector.
    <br>
    "What counts most in creating a successful team is not how compatible its players are, but how they deal with incompatibility." - Sports Illustrated

Posting Permissions