Results 1 to 7 of 7
  1.    #1  
    I purchased a Treo 600 from Sprint a little less than a year ago. I have experienced numberous defects with my unit and hve struggled for months trying to "fix" it. The defects include spots on the screen, broken speaker, all calls being dropped, and more. At this point, I knew that I needed a new phone so I called Sprint and was referred to Lockline insurance.

    The insurance agent asked when the problems occurred and I told her that I've been having them since the original purchase. My claim was denied due to having been out of the 60 day range that I apparently have to report issues.

    Now I realize that my unit should be covered by warranty anyway. This is my question:

    Where should I go from here to get a replacement in the quickest way possible?

    Should I go to the store?

    Should I call Sprint directly and tell them that this must be covered under warranty?

    Any suggestions would be greatly appreciated.

    Also, I have noticed users of this forum mentioning their 4th and 5th replacements. Did I buy the wrong phone?
  2. #2  
    First backup all your data and do a hard reset. With your 'virgin' treo, see if all your defects are still present. If even one defect is present, take it to the Sprint store. They will run a diagnostic and if it fails, they should give you a warranty replacement if they have one in stock. You should probably call ahead to check stock. Be persistent.
    Palm III > Palm V > Palm Vx > (Sprint) Kyo 6035 > Handspring Treo 300
    > Handspring Treo 600 Oct.'03 > Palm Treo 700P May'06 > Treo 755P Aug.'07 > Pre(-) June'09 + TouchPad July'11 LONG LIVE webOS!!!
  3. #3  
    You don't "call" Sprint or Lockline, you simply walk in to a Sprint company store, hand them the unit, say "it's screwed" and get a new one. I'm on number 3, and had no problems getting them. Back up to SD card, hard reset. Get the new one restore from back up, and with in 15mins I'm back in business.
    <body bgcolor="#ffffff">
    <p><font size="-2" color="#4684ff" face="Arial,Helvetica,Geneva,Swiss,SunSans-Regular"><b>imageone</b></font><font size="-2" face="Arial,Helvetica,Geneva,Swiss,SunSans-Regular"> &#x2022; current - <b>PowerBook G4 - Mac OS X - white iPod video 60GB - Treo 650 - 700p (Sprint)<br>
    </b></font><font size="-2" face="Arial,Helvetica,Geneva,Swiss,SunSans-Regular">retired - Visor Deluxe - Visor Prism - Kyocera 6035 - Treo 300 - Treo 600 - Blackberry 7250</font></p>
    </body>
  4.    #4  
    Got it. The Sprint store here is a nightmare and a half. Wish me luck.
  5. #5  
    Quote Originally Posted by imageone
    You don't "call" Sprint or Lockline, you simply walk in to a Sprint company store, hand them the unit, say "it's screwed" and get a new one. I'm on number 3, and had no problems getting them. Back up to SD card, hard reset. Get the new one restore from back up, and with in 15mins I'm back in business.
    Did you get a "new" one or a refurbished one?
  6. #6  
    Quote Originally Posted by imageone
    You don't "call" Sprint or Lockline, you simply walk in to a Sprint company store, hand them the unit, say "it's screwed" and get a new one. I'm on number 3, and had no problems getting them. Back up to SD card, hard reset. Get the new one restore from back up, and with in 15mins I'm back in business.
    You know, I just replaced my Treo 600 at the Sprint store in order to have a fresher unit to sell on Ebay when I upgrade to Treo 650 this Christmas. This is my third Treo 600 and I have NEVER been able to back up and restore to a new unit from SD (using BackupBuddyVFS). When you switch units the restore function does not work properly unless you hotsync at your PC first to get your user name restored on the unit. Even then you still have to reinstall quite a few programs manually (IBM Java VM for one) and reapply passwords.

    Now call be blind, but is there any way to get around this?
    "I see dead pixels..."
  7. #7  
    Quote Originally Posted by gamedeveloper
    You know, I just replaced my Treo 600 at the Sprint store in order to have a fresher unit to sell on Ebay when I upgrade to Treo 650 this Christmas. This is my third Treo 600 and I have NEVER been able to back up and restore to a new unit from SD (using BackupBuddyVFS). When you switch units the restore function does not work properly unless you hotsync at your PC first to get your user name restored on the unit. Even then you still have to reinstall quite a few programs manually (IBM Java VM for one) and reapply passwords.

    Now call be blind, but is there any way to get around this?
    Yep - its called BACKUPMAN. never a problem here

Posting Permissions