i got my first 600 in january and got the free ptunes...ive been through 2 replacements and recently lost the memory card with ptunes and all my songs..then my screen cracked so i got a new memory card and new used 600..when i tried to install ptunes it said my old version wont work and i'd have to buy 3.x....is there anyway around this? i dont want to play wma's or stream or anything..i jsut want to play mp3s

ive tried deleting 2.x and reisntalling it but the same error message comes up, im using 3.x trial right now.. id rather not buy it cuz i liked 2.x just fine