Results 1 to 14 of 14
  1.    #1  
    I had this problem on my old WorkPad. Essentially, I use the stylus on the screen somewhere (checkbox in a to do list or something similar) and the Treo checks a box further down on the screen - sometimes 2-3 lines further down.

    I've tried to run the Touchscreen app, but get caught in an endless loop there and have to do a soft reset (and it's still not fixed). I used to run an app that would help with this, but don't want to band-aid my Treo with even more apps.

    If more apps supported the 5 way, I'd be in good shape, but not all of them do yet (at leats not the versions I've got...).

    Anyone else having this problem? Is this a warrantable fix like the buzzing and the echos? I did a couple searches, but couldn't find anything relating to "digitizer" or "touchscreen" that showed anyone else with the problems. Just curious to get other's thoughts and opinions!

    Thanks for your help!
  2. #2  
    Just a shot in the dark but would this app help you? I had a problem with another Palm device, not Treo, where I couldn't even get to my digitizer app because the calibration was so far off. This will take you to the digitizer recalibration utility and then remember those settings for each time you hard reset. I personally don't think it's worth the price they are asking but it is shareware so if you're in a bind right now it might help you, did for me. If recalibrating doesn't help you at all then I'm not sure this app will help.

    AutoDigi5

    http://www.palmgear.com/index.cfm?fu...=&prodID=49412
  3. #3  
    Quote Originally Posted by RawData
    I had this problem on my old WorkPad. Essentially, I use the stylus on the screen somewhere (checkbox in a to do list or something similar) and the Treo checks a box further down on the screen - sometimes 2-3 lines further down.

    I've tried to run the Touchscreen app, but get caught in an endless loop there and have to do a soft reset (and it's still not fixed). I used to run an app that would help with this, but don't want to band-aid my Treo with even more apps.

    If more apps supported the 5 way, I'd be in good shape, but not all of them do yet (at leats not the versions I've got...).

    Anyone else having this problem? Is this a warrantable fix like the buzzing and the echos? I did a couple searches, but couldn't find anything relating to "digitizer" or "touchscreen" that showed anyone else with the problems. Just curious to get other's thoughts and opinions!

    Thanks for your help!
    I had this problem when my G2 screen protector became bent in the corner and was pressing down on the screen. I couldn't see the bend until I removed the screen protector.
  4. #4  
    I had a similar problem when I put a screen protector a little off center - the touchsreen worked very eratically and when I had my case on the treo, it often wouldn't work. Anyway hope that is helpful...
  5. #5  
    My problems started over the weekend. Sometimes it works and half the time it is off, sometimes by a lot. Called ATT and after 45 minutes they said they didn't do support on the Treo. I need to call PalmOne. I did. They had me do a factory reset. I did and then couldn't get through the digitizer setup until about the 25th try. They said they would send me a refurbished unit in 7 to 10 days. Not a real pleasant experience. Great phone, but... Any suggestions on fixing it myself??
  6.    #6  
    Thanks everyone! I've used AutDigi before on my WorkPad and that worked well - for a while...

    This time, the correct answer (so far this evening) appears to be the G2 screen protector. I needed to replace my protector anyway with the second one I received because of some scratches on the first protector. There was also a lot of "gunk" under the protector and the real screen is actually lightly scratched, but not enough to be horrible or unreadable. Anyway, so far this evening, working on the Treo has been a blessing and it's actually been usable again for the first time in days. My first G2 wasn't bent or anything so I'm not sure what the deal was. Didn't even pull out any big chunks of pocket lint from around the corners when I removed the other one. I did my first tests without any protectors on and it worked great. Tested again after replacing it and it worked well.

    So happy to have my Treo in working order again...

    Thanks again for the help!
  7. #7  
    I would like to take the screen protector off as I am having digitizer problems. I can't seem to get it off. It seems to be a perfect fit and I can't grab a corner. Help.
  8.    #8  
    Which screen protector are you using?
  9. #9  
    Really don't remember. It doesn't budge.
  10. #10  
    Try a piece of tape (maybe duct tape if you need the super stickiness). Apply the tape as close to, at, the corner. Push it on good, then pull slowly.
  11. #11  
    On a Tues. post I was disappointed in Palm for telling me they would ship a replacement in 7 to 10 working days. Well it is Fri and it is here already and a nice unit I might add. Don't know why they upset me with the 7 to 10 day stuff when indeed they shipped the next day.
  12.    #12  


    Many companies have started doing this, I've noticed. They set your expectations low, then easily overachieve. Makes them look good (sort of)...

  13. #13  
    I discovered a good fix for a Treo 600 that could not be calibrated today. I had a hunch that it related to something trapped on the edges of the screen because only part of the digitizer would not calibrate.

    Here is how I fixed the issue:
    I took a sheet of paper and ran the corner of the paper all the way around the screen under the edge of the frame of the screen. I did this a couple of times with the intention of dislodging any little grains of dirt that might be lodged under the frame.

    It worked! I was able to digitize my screen right away afterwards. I presume it was a little mite off dirt which was throwing off the calibration. This may help others not have to return a device for repair, I hope.
  14.    #14  
    Did basically the same thing when I fixed mine. I used the supplied piece of lens cleaning cloth, though. Either way should work. Mine has worked great ever since I cleaned it out.

Posting Permissions