Results 1 to 11 of 11
  1.    #1  
    Hey guys/girls... I just received my GSM Treo 600. It's IMEI starts in the 01's... I read here about issues with a range in the 09's. It's currently charging so I haven't had a chance to use it. I purchased it off of ebay for around $400. I'm a little nervous about possible issues with the phone. Does anyone out there have the GSM version? Have you had any problems what-so-ever with the phone? Comfort me
    Last edited by outz; 08/05/2004 at 01:24 PM.
  2. #2  
    My IMEI starts with 01 and I have had almost no problems with the phone. It's worked well for me. I had the occasional soft reset when I first got it...but now I am problem free! Comforted? ;-)
  3.    #3  
    Extremely... I hope my treo has the same luck... guy on ebay sent me an entire manual in spanish... wtf?
  4. #4  
    I got mine on EBAY 2 months ago... used for $350.. my IMEI starts with 01 as well... not a single problem... the first thing I did when I got it was do a hard reset, then re-flash with latest firmware/sw and havent had any problems with it what so ever. i love it!
  5. #5  
    My IMEI starts with 01. The first one I got was defective but I discovered that in the first hour of use and had it replaced at the store. The one I have has been flawless since March when I got it.
  6.    #6  
    How was it defective? Mine is STILL charging... (been 3 hours or so) I get to leave work in about 15 mins... fully charged or not... here i call
    <edit> just finished charging!! *crosses fingers* time to leave work. </edit>
    Last edited by outz; 08/05/2004 at 04:59 PM.
  7. #7  
    there is a year warranty and they were released in October initially, so every single Treo out there is still under warranty
    La Vie En Diaspora: Enfin, une émission qui raconte votre vie aux Etats-Unis

    Treo 600 in December '03, Treo 650 in February '05, HTC TyTN Pro in August '06, and back to Treo 750 in January '07, find me at MyTreo.net

    About me: story of the 100thMonkey
  8. #8  
    Mine is an IMEI 01 starter and no concerns. Well actually one concern. The hotsync wouldn't work. After pushing the button on the cable it caused a continuous soft restart. I cleared the fault by doing a hard reset of the device and since then no concerns.
    Ancient_One
    Blood and Honour
    (Those who live in the dark shall meet the light and all shall die by my hand.)

    (Device:Palm Pilot>Handspring Deluxe>Handspring Treo 270>Sony Clie NX60U>PalmOne Treo 600)
    (Beta Tester:Pocketdimension 2 / Quirl / PalmMAME / Seven Email Client)

  9. #9  
    I would say to all to conduct a hard rest of the Treo before their first sync. If the phone needs and upgrade perform this prior to installing any software.

    Just my thoughts.
    Ancient_One
    Blood and Honour
    (Those who live in the dark shall meet the light and all shall die by my hand.)

    (Device:Palm Pilot>Handspring Deluxe>Handspring Treo 270>Sony Clie NX60U>PalmOne Treo 600)
    (Beta Tester:Pocketdimension 2 / Quirl / PalmMAME / Seven Email Client)

  10.    #10  
    Thanks everyone for your input. I have put the phone to the test today. I was able to get it working on T-mobiles free WAP (yay) and upgrade the firmware. I've made a few calls and tested the headset/speakerphone/handset and all seem to be functioning great so far. I am able to sync the device as well. I just need to test the irda port and mess around a bit more and all should be well. That 1yr warranty also makes me feel more secure. Thanks again everyone
  11. #11  
    you might ask the people on the other end how it sounds...or leave yourself a voicemail.
    La Vie En Diaspora: Enfin, une émission qui raconte votre vie aux Etats-Unis

    Treo 600 in December '03, Treo 650 in February '05, HTC TyTN Pro in August '06, and back to Treo 750 in January '07, find me at MyTreo.net

    About me: story of the 100thMonkey

Posting Permissions