The Ringer on my Treo270 does not sound when there is an incomming call or SMS. I have made sure that the external Ringer Switch is set to "Ring" mode and that in the "Preferences - Ringer" menu under Sound Mode Ring Volume = Loud and Call Tone = Treo and SMS Tone = Ping-Pong. I have checked the Vibrate option so that I am alerted to incomming calls. I have performed numerous "soft" and "hard" resets without any success. Can someone please help.