Results 1 to 20 of 20
  1. pdadoc's Avatar
    Posts
    407 Posts
    Global Posts
    417 Global Posts
       #1  
    I ordered the unleash last Wednesday afternoon. Received a confirmation of 2 day shipping, noting I would be notified when it actually shipped. Never received any subsequent notification. Assuming it went out Thursday, should have been here yesterday. Emails (including one sent over the weekend) are unanswered, and there does not appear to be any phone number on the website.

    Have others been experiencing problems with recent delivery from them?
  2. #2  
    Don't know about recent history, but I have the number I used about 5 months ago to order my headset: (415) 901-1600. Good luck.
  3. pdadoc's Avatar
    Posts
    407 Posts
    Global Posts
    417 Global Posts
       #3  
    Interesting.... all I get on that number is a pause, a click, and then a dead line. I got the same number from my Watson program earlier this AM....
  4. #4  
    I e-mailed their support a couple a weeks ago, hadn't got so much as an automated response from them. I was/am having trouble with the headset and the base needing to be placed back into the carrier box in order for the headset to work. Anyone else?
  5. #5  
    pdadoc, check out the Unleash headsets on Ebay. I got mine yesterday shipped to me for $39.00.
  6. sjjones's Avatar
    Posts
    757 Posts
    Global Posts
    789 Global Posts
    #6  
    Quote Originally Posted by FreePour
    pdadoc, check out the Unleash headsets on Ebay. I got mine yesterday shipped to me for $39.00.
    Sending mine back to the ebay supplier today. Bad reception(echo on clients end) and horrible fit
  7. pdadoc's Avatar
    Posts
    407 Posts
    Global Posts
    417 Global Posts
       #7  
    I *finally* heard from them. Here was there email:

    We apologize very much for the shipping delay. We have been experiencing some technical problems.

    Customer Service

    ***Do not reply to this e-mail. UPS and REASON PRODUCTS will not receive your reply.

    They attached the UPS shipping info, which shows that it theoretically should be delivered today, a full week after ordering it. So far, I'm pretty unimpressed with this outfit. As for ebay, I was actually aware of that option. But there are earlier versions of the Unleash which people have had definite problems with. Ordering thru ebay means 1) you could get one of those earlier units and 2) if you don't like it, return is not exactly easy. For the difference in price (39 vs 69), it just wasn't worth the risk of getting an old unit.....
  8. #8  
    My brother and I both got the headset and love it. Holds a charge for a while, answer button on headset answers calls on Treo, case is well constructed, reception is very good. It is a bit tricky to initially get the headset comfortable on your ear, but after a while, you find a fit that works. Overall very pleased...
  9. #9  
    I bought one for $39 (shipped) from some guy off ebay who seems to have a number of them available. I was a bit sceptical because of the price, but it works just fine....albeit after one day.
    "Pain is temporary; quitting lasts forever." -- L. Armstrong
  10. pdadoc's Avatar
    Posts
    407 Posts
    Global Posts
    417 Global Posts
       #10  
    Finally got it yesterday. Initial impression of headset is excellent. I'll be testing it more today, but it seems to have great sound. Also, if I have an incoming call, I CAN just plug in the adapter, and it works immediately (does not require a minute as some others have posted).
  11. #11  
    I've had mine a week, works great.. my questtion is: do u only put units in charger when batts are dead and need charged or can u store in base when not using it keeping batts charged? since ni-cads are in headset & dongle...wouldnt memory effect be an issue with the ni-cads? I've asked this in an email to reason, but no reply in a week.
  12. pdadoc's Avatar
    Posts
    407 Posts
    Global Posts
    417 Global Posts
       #12  
    Worked pretty well today. Sound on my end was excellent. When I asked a couple people I called, it ranged from good to acceptable. I listened to a message I had left on our answering machine, which did NOT sound so great (acceptable at best).

    Also, I used it for perhaps a total of 20 minutes all day. The dongle WAS plugged in most of that time. When I got home, it was no longer working, and it turned out the batteries were dead. That's much less time than advertised. I wonder if it was not "auto-deactivating".... Are others getting better time?
  13. #13  
    I did not think that the sound quality was great so I called tech support (this was months ago). He told me that it sounded great, for a headset. I asked him to hold and when I returned he said that I sounded much better... that no headset will ever sound as good as simply using the phone. When I informed him that I had switched to my Jabra Freespeak he did not have anything else to say.

    One thing I did get out fo the conversation was a defect in the "sleep mode" when using a Treo 600. If you listen very carefully, you will hear it come out of sleep mode anywhere from 10 seconds to 2 minutes after going to sleep. He said that this had something to do with the Treo 600 and that they were working on it.

    Net effect: there is no sleep mode on the Reason's headset so if you leave it connected it will drain quickly.
  14. #14  
    Interesting....

    Quote Originally Posted by dudemasicus
    I did not think that the sound quality was great so I called tech support (this was months ago). He told me that it sounded great, for a headset. I asked him to hold and when I returned he said that I sounded much better... that no headset will ever sound as good as simply using the phone. When I informed him that I had switched to my Jabra Freespeak he did not have anything else to say.

    One thing I did get out fo the conversation was a defect in the "sleep mode" when using a Treo 600. If you listen very carefully, you will hear it come out of sleep mode anywhere from 10 seconds to 2 minutes after going to sleep. He said that this had something to do with the Treo 600 and that they were working on it.

    Net effect: there is no sleep mode on the Reason's headset so if you leave it connected it will drain quickly.
    How did you call tech support?? They don't have any phone #'s listed... they do all communications through email.

    Mine sleeps just fine. It usually lasts from 9am to 7pm with at least 3hrs of actual talk time.

    The 3 to 5 secs it takes for the freespeak to connect to itself made it unusable for me.... by the time I saw who was calling and then pushed the button and waited for the Jabra freespeak to connect and become functional and then went back to the phone to answer it, I would always miss the call. The upside though was I am sure it was quite an amusing sight for my collegues. The Unleash sounds much better and definately functions better than the Freaspeak. The Freespeak dongle has a max talk time of 2hrs (not enough).
  15. #15  
    I just called their number: (415) 901-1600. Of course, now when I call it simply hangs up. Can't even really tell you where I got that number from (I'd swear it came from their web site, but it's certainly not there now). Anyway, I called and asked for "technical support" and got some guy's voicemail. I called back a couple of days later and repeated the excercise and talked witht he guy... I got the feeling that there was only one...
  16. pdadoc's Avatar
    Posts
    407 Posts
    Global Posts
    417 Global Posts
       #16  
    "Mine sleeps just fine. It usually lasts from 9am to 7pm with at least 3hrs of actual talk time."

    I just tested the unit this AM after it dying yesterday with the dongle plugged in, but less than 30 min talk time. Here's what I found: if the dongle is in my treo, I hear slight noise in headset (ie, it is active). It is NOT auto-deactivating. If I then do volume down on the dongle, and hold 2 seconds at lowest volume, I do get a tone, and the earpiece is no longer active (complete silence in earpiece). HOWEVER, about a minute later, the earpiece becomes active again, even without a call, or without touching the treo. I repeated this twice. SO.... at least for me, this won't work. It appears that something is activating the earpiece when the dongle is plugged in, but not used. Perhaps it's some software I have installed on the Treo, but I can't think of what would do it. At any rate, constant drain of batteries (albeit slow), and not knowing if earpiece will then have sufficient battery power to work when I need it is a problem. I emailed tech support, but they seem pretty asleep at the switch.
  17. #17  
    How many people have bought them from ebay and not have any problems after day 1?
    Are there people who bought the Unleash directly from Reason and not have a problem after day 1? I purchased mine on ebay, and right after day one realized that it was not holding the charge and died after only about 10 -15 minutes worth of use after 24 hr charge.
  18. #18  
    Bought mine directly from them about a month ago and it has worked perfectly from day one.
  19. pdadoc's Avatar
    Posts
    407 Posts
    Global Posts
    417 Global Posts
       #19  
    As noted in another thread, mine had some problems the first day (as noted above), but has since worked great. Used it all day today traveling in the car, with treo on front seat. Others seem to have had major problems with losing the connection. I did buy mine direct.
  20. #20  
    OK here's a follow up from my July 20 post. I e-mailed everyone on their websites on the 21st, got a response as follows on the 23rd: Hello,

    We have received your email and will reply soonest.

    Regards,
    Customer Service

    Then I get another e-mail on the 26th saying a replacemnet unit's been sent out. Got it yesterday the 30th. So I'll test drive for a while and see if this disconnects all the time. OBTW, I was constantly having to put the earpiece and dongle-thing back in the case to get them to work, which ain't a whole lotta fun when your drivin.

Posting Permissions