The Targus webiste indicates that Version2.0 of the driver is needed. Has anybody found where to get the Version2 and if it works?