Results 1 to 6 of 6
  1.    #1  
    anyone return a sandisk card?

    especially one that has been filed down?

    I just called SanDisk and got a RMA for my 512MB card which now gives my Treo bad sector errors when i try to write to it.

    The return process seems pretty easy, but i'm worried that they will say that the warrenty is void since i "modified" the card.

    Anyone else have any problems with any other brands? I'm thinking about getting the Kingston from outpost.com.

    digidep
  2. #2  
    Used Sandisk cards since the beginning.

    Never had a failure of one yet.

    I would believe the filing caused the problem.

    If they take it back and give you credit you will be very lucky.
  3. #3  
    I've returned/replaced two 256MB cards without problem... (ofcourse I hadn't filed down the card)

    There RMA is done via email and isnt as bad as a lot of people on a Tungsten board I was on made them out to be.

    -- Vikram
    Treo 600 <a href="http://vikrampant.com/treo600/">Blog/Moblog</a>
  4. #4  
    Anyone else have any problems with any other brands? I'm thinking about getting the Kingston from outpost.com.
    My problem I figured out was a bad USB SD reader. (Also by SanDisk)

    But I hear Lexar (Panasonic) is good too from others.

    -- Vikram
    Treo 600 <a href="http://vikrampant.com/treo600/">Blog/Moblog</a>
  5.    #5  
    Originally posted by vikrampant


    My problem I figured out was a bad USB SD reader. (Also by SanDisk)

    I actually have a Lexar reader, though i'm not really sure how a reader can make a SD card have corrupt sectors. I can see how you might get the data on the card corrupt from a bad reader, but after you format it you would think that the data being written to the card via another method (like hotsync) it would be cool then, but mine is not.

    digidep
  6.    #6  
    Originally posted by dlbrummels

    I would believe the filing caused the problem.

    If they take it back and give you credit you will be very lucky.
    such an optimist i see. The card workded fine for three weeks with heavt use and then just this week it has had these bad sector errors. I mean it's almost like your car not starting because you took off a door. Two non related things, but i'll let you know how the RMA turns out. I hope I am very lucky.

    digidep

Posting Permissions