Page 3 of 4 FirstFirst 1234 LastLast
Results 41 to 60 of 74
  1. #41  
    Jaslo:

    I think something's been lost. The old version prevents the hard buttons and keyboard from muting the ringer. The new version doesn't seem to do that.
    Bob Meyer
    I'm out of my mind. But feel free to leave a message.
  2. #42  
    Granted, I've only tried it about 5 or so times, but everything seems to work fine.

    With app buttons locked, no keys eiether answer the phone or silence the ringer, d-pad center answers.

    I don't mean to contradict other reports, but just want Jaslo to know that it does work properly on at least some handhelds.

    Maybe he/we can figure out what it may be conflicting with.

    eKennedy
  3. #43  
    Jaslo..........The app just rocks. I am using it on my GSM Treo 600 and it works flawlessly so far. I loaded your second version.

    Thanks for a well designed tool
    Thanks,

    np
  4. #44  
    Jaslo:

    Just installed keepoff2 on my GSM treo and it's working beautifully. Many thx for yr hard work and kind contribution.

    Good luck to getting it on palmgear.

    Brian
  5. jaslo's Avatar
    Posts
    64 Posts
    Global Posts
    65 Global Posts
       #45  
    Keepoff (v1.3) now DOES survive a soft reset and re-enables itself using its previous settings.
    Yeah baby! That's what I'm talkin' about!!!!

    To disable this behavior, use a "no-notify" reset (hold down the up button while pressing the reset and don't let go of the button until AFTER the palm logo shows on the screen).

    Anyway, here's the download:

    keepoff3


    I've sent it into palmgear -- we'll see how that goes!

    For tech-heads:
    I used MemHandleNew to get memory for the option parameter structure and stored the handle using FtrSet.
    When I set the owner to "system" (MemHandleOwner(mh,0)), it worked great. Apparently dynamic heap space is freed when the app is stopped???? Who knew?


    My next trick is a version of Graffiti Anywhere with better "activation" options.
    The graffiti part is done! But I need an activation mechanism OTHER than the hard buttons. Volume buttons? Option-center?
    --jaslo
  6. #46  
    Great work, jaslo!

    1. Rocker is disabled, except for center press. By dseign, I know, but it's better to be able to get to the 'ignore' button with the D-pad when a call comes in.

    2. Volume buttons disable ringer. Shouldn't they be free to control the volume only? Otherwise it's counter-intuitive.
  7. jaslo's Avatar
    Posts
    64 Posts
    Global Posts
    65 Global Posts
       #47  
    Doesn't anyone like to TOUCH the screen?

    I use one of those "write-shield" screen protectors from
    ppctechs, inc. and I love to touch the screen!
    I make calls (using the dial-pad), search my address book (using Finger-dial) and answer the phone (or ignore the call) by touching the screen buttons with my finger!

    So I say, GIVE THE D-PAD THE FINGER!!!!
    --jaslo
  8. #48  
    So I say, GIVE THE D-PAD THE FINGER!!!!
    so is that the nice way of saying there won't be any more updates to this app in the foreseable future? jj

    digidep
  9. #49  
    when I use PocketTunes& Enable "background paly", Music will slow down(when SPACE is pressed)...untill keekoff is disabled!
  10. jaslo's Avatar
    Posts
    64 Posts
    Global Posts
    65 Global Posts
       #50  
    I have tried unsuccessfully to reproduce this. Can you give me a more detailed explanation?
    --jaslo
  11. jaslo's Avatar
    Posts
    64 Posts
    Global Posts
    65 Global Posts
       #51  
    I found a bug:

    If the Treo turns on in its case (for an alert for example) and the case is pressing a key, say space bar, the Treo will not time out in its usual 2 minute interval and turn off. The interval will be timed from the last key press, even though keepoff is blocking the key.

    I will be working on this later today.
    --jaslo
  12. #52  
    1.Enable keepoff
    2.open PocketTunes & starting a song
    3.turnoff screen
    4.put treoo 600 into case
    5.the song is very unsmooth & slow dwon sometimes

    I think it's because SPACE is pressed.
  13. jaslo's Avatar
    Posts
    64 Posts
    Global Posts
    65 Global Posts
       #53  
    Feel lucky, punk?
    Help me test keepoff 1.4 beta.

    download here

    In this version, if a key is hit while it is locked out, it attempts to send the Treo back to sleep. Don't worry because an incoming call, or an alert, or snappermail will prevent that until their operation is complete.

    The good news is that if you don't respond to an alert or incoming call, and your case presses the spacebar (or any disabled key) -- keepoff sends Treo back to sleep immediately. If the case doesn't press the spacebar, the auto-sleep timeout is still in effect. Volume keys still mute the ringer as they normally would.

    Also, I have not been able to reproduce the PocketTunes problem on this version, although I never loaded the previous version to try it.
    --jaslo
  14. #54  
    Thank you very much...

    should I delete keepoff 1.3 & do a "non-notice" reset before install this new beta?
  15. jaslo's Avatar
    Posts
    64 Posts
    Global Posts
    65 Global Posts
       #55  
    Just disable it (uncheck Enable),
    go to applications/delete "keepoff".
    Then install through Blazer or hotsync (or SD).

    Then go to keepoff, check "Enable" and return to the launcher.
    (Enable is not actually done until you exit from keepoff by going to the launcher, or another app).
    --jaslo
  16. #56  
    thanks again...
  17. matics's Avatar
    Posts
    13 Posts
    Global Posts
    18 Global Posts
    #57  
    Kudos for a great app! I just have one observation. I noticed that the green square in the bottom right is on constantly. Is there any way to disable this. I personally don't need a constant reminder that Keepoff is alive in the background. The red square I understand, but the green square seems to be redundant.
  18. #58  
    jaslo:

    In v1.4beta when i turn on the treo by the top power button and then press any other keys like the home button (except the enabled ones in keepoff) the screen blanks (like keep off is enabled). I do this two more times (press the power button and then any other keys) and finally on the third the screen doesn't blank.

    Weird?

    I think if you push the top power button that keepoff should be disabled, but i have been having to push it three times. Of course a touch of the screen disables keepoff everytime.

    Could you look into this?

    digidep

    PS
    The red square I understand, but the green square seems to be redundant.
    i agree


    BTW I have a Sprint CDMA Treo600
  19. jaslo's Avatar
    Posts
    64 Posts
    Global Posts
    65 Global Posts
       #59  
    I got this to happen, but I can't reproduce it.

    I press the power button and Treo turns off, but then immediately back on again. At this point, keepoff is enabled and the next keypress (even power) turns it off.

    I'm not sure how I got into this mode, where the device turns on by itself after I press power to turn it off.

    If you can reproduce it, please send me the exact sequence of keys/taps whatever.
    --jaslo
  20. jaslo's Avatar
    Posts
    64 Posts
    Global Posts
    65 Global Posts
       #60  
    Hi,

    I made some changes to the key handling.
    Please try version 1.5 beta, attached here.
    Attached Files Attached Files
    --jaslo
Page 3 of 4 FirstFirst 1234 LastLast

Posting Permissions