Results 1 to 13 of 13
  1.    #1  
    For the past few days, when I take the Treo out of my pocket, I'm itnermittently finding that it's been on already. My battery, while still easily lasting a day, is definitely running down faster than it used to. I had this problem when I first got the Treo in October, when I had SnapperMail checking my mail automatically - because the signal is often out of range in the hostpital at which I work, and that, together with keyguard, would induce the Treo to go on and stay on for extended periods. Since I switched over to manual email checking this had not been an issue anymore, until a few days ago.

    Any ideas?
  2. #2  
    The built in software is smart enough to keep keyguard activated even during an alert and to re shut down the screen. I would work backwards and look at the last software I installed or the last config changes I made.

    The issue is an application which turns on the screen + disengages keyguard. If your buttons are being depressed or the screen brushed, the lcd will remain on and the cpu in its highest power state.
  3.    #3  
    The only one that comes to mind is the Profile Manager that's been touted on this board for the past few weeks, which I had installed around the time this started. I've deleted it though, and the problem is continuing.
  4. #4  
    I'm having this problem too. My battery is barely making it through the day because of this. Any new thoughts?
  5. #5  
    I've been having this problem as well.

    I believe it's a bug that happens when the Treo goes in (out?) of coverage areas. What happens for me is that it wakes up, but just sits there with the keyguard message and doesn't go back to sleep.

    The only programs I have installed are Bob's Alarm & (v2.0) and Handspring's Treo 600 beta e-mail client.

    Please see if your wakenings happen on entering/leaving signal areas & post if this is (or isn't) the same as your problem. If enough people are suffering from this, perhaps Handspring will do something about it...
  6.    #6  
    As I've carefully observed this problem, I'm not totally convinced anymore that the Treo is going on by itself. Rather, what may be happening is that some piece of software is disabling the "auto-off" feature. I've been in the habit for several years of putting my Palm Pilots in my pocket without shutting down, relying instead on Auto-Off after 30 seconds (this started as a battery-saving move, since when I press the off switch I have Backup Buddy set to backup several files to the expansion card).

    I think that I have some piece of software on my Treo that is disabling that feature. My best guess so far is the audible book player from audible.com, which seems to have trouble shutting off the screen with keyguard set - even though the "turn off screen" setting is selected, it won't go off till I manually press the power button. So far it seems that when I use the audible software in the morning & then just put the Treo in my pocket without shutting off, it stays on. I'm watching carefully to see, now that I press power off every time, if I ever take the unit out of my pocket anymore to find the power on by itself.
  7. #7  
    Originally posted by darrenorb
    As I've carefully observed this problem, I'm not totally convinced anymore that the Treo is going on by itself. Rather, what may be happening is that some piece of software is disabling the "auto-off" feature. I've been in the habit for several years of putting my Palm Pilots in my pocket without shutting down, relying instead on Auto-Off after 30 seconds (this started as a battery-saving move, since when I press the off switch I have Backup Buddy set to backup several files to the expansion card).

    I think that I have some piece of software on my Treo that is disabling that feature. My best guess so far is the audible book player from audible.com, which seems to have trouble shutting off the screen with keyguard set - even though the "turn off screen" setting is selected, it won't go off till I manually press the power button. So far it seems that when I use the audible software in the morning & then just put the Treo in my pocket without shutting off, it stays on. I'm watching carefully to see, now that I press power off every time, if I ever take the unit out of my pocket anymore to find the power on by itself.
    I would agree that there is something going on with Audible too (maybe a combination of factors).

    In this post I discuss a reproducible interaction with Audible and TreoAlertMgr
    http://discussion.treocentral.com/tc...threadid=44623

    It's getting very annoying. I emailed PDAApps about the problem, and they say they can't reproduce the problem.....

    So, I guess we're all just stuck with this annoying problem?
  8.    #8  
    I don't have TreoAlertManager on my Treo (I don't even know what it is), so it's not the cause of my problem.
  9. #9  
    I've been fighting this problem as well. I've narrowed it down to a communication issue - entering or exiting a coverage area, built-in-mail checking the pop server, ChatOpus touching base with the jabber server, etc. Every time the GPRS communications stack is used, the screen backlight comes on...

    For now, I've shut down ChatOpus and reduced the mail client's polling interval to 30 minutes; I'm getting through a 16 hour day without recharge now.

    I haven't bothered trying to open a case with Handspring, as I'm sure they will point to third-party apps first (after reviewing this and other related threads). Has anyone else been able to reproduce it with only the built-in mail client?
  10. #10  
    I am also experiencing random "on" moments. The battery lasts about 2/3 of the day and could easily go dead with a long call. Very frustrating. Will check Business Connect and Snappermail (which I think I turned off) to see if they are the prob. Will also remove TreoAlertManager
    J.
    Palm, Palm III, Palm Vx, Treo 300, Treo 600, Treo 650, Treo 700p, Treo 755p, and Palm Pixi
  11. #11  
    I don't have Audible or TreoAlertManager installed and I'm having this problem.

    I think it's a Treo 600 firmware bug where:
    -- it wakes up if the signal status changes and the keyguard/etc. display appears, but
    -- it doesn't go back to sleep after the normal ~5 second display; instead it stays on, draining the battery.

    In areas where the signal is good, this never happens. In areas where the signal is really marginal, almost any time I look at the Treo, the screen is on.

    MY WORK-AROUND:

    Go to Prefs -> Sound. Select "Tones". Turn "Service Tone" to "On.". The phone will now make a low beep when the signal appears/vanishes. Manually turn the phone off each time you hear the tone. It's annoying, but the battery lasts much longer...
  12. #12  
    Quote Originally Posted by JohnLar
    I don't have Audible or TreoAlertManager installed and I'm having this problem.

    I think it's a Treo 600 firmware bug where:
    -- it wakes up if the signal status changes and the keyguard/etc. display appears, but
    -- it doesn't go back to sleep after the normal ~5 second display; instead it stays on, draining the battery.

    In areas where the signal is good, this never happens. In areas where the signal is really marginal, almost any time I look at the Treo, the screen is on.

    MY WORK-AROUND:

    Go to Prefs -> Sound. Select "Tones". Turn "Service Tone" to "On.". The phone will now make a low beep when the signal appears/vanishes. Manually turn the phone off each time you hear the tone. It's annoying, but the battery lasts much longer...
    Battery drain is certainly an issue, but for me personally it's more just a case of constantly worrying that the phone is doing "things" without my knowledge. I hate that. Geez, I guess I almost sound paranoid, huh?

    Anyway, this bug is something I have been searching for a solution for for a LONG time. (sigh) Like almost since I got the phone (which I'm proud to say I'm still on my original October '03 purchase!). Everytime I walk towards the center of my office building (and especially if I enter the elevator) the signal drops and the phone lights up. Not such a big deal when leaving a service area, but when you enter one and it lights up again, now the phone can theoretically make an actual call. It's always so frustrating to see in the Call Log after the fact that your phone has been making 5 and 10 minute calls to people without your knowledge.

    If it truly IS a bug in the Treo, does that mean then that there is not a way to code around it? What I have been hoping someone would create (if this is possible) is some kind of utility tool to get around this bug/feature (depends on your perspective, right?)so that whatever "keyguard" functionality you are using works as advertised. I want my phone to be answerable when I'm getting a call, the screen to light up when I get an SMS message or press the power button, and the rest of the time to just sit there and DO NOTHING! Argh. This would definitely be something worth paying money for!
  13. #13  
    Well, I don't know if this is anyone else's problem, but I have fixed it for myself. I use Datebk5 and when I have Datebk5 handle alarms, I get the Treo turning itself on all the time. This does not occur when I turn off the option for Datebk5 to handle alarms.

    This is a bummer, but has been 100% effective in solving my problem.

    Craig

Posting Permissions