Results 1 to 4 of 4
  1.    #1  
    I have a Cingular Treo 600 and tried to use a SIM from a prepaid service provider in South Africa called Cell C.
    This is what happned:
    1) Swapped the SIMs; was welcomed to the Cell C network; got signal
    2) According to the instructions I had to call 411 to finish the setup.
    3) When I dialed the "4", my Treo just died -completely !

    I tried all the resets - nothing ! It's completely dead. no flashing LED, no screen - nothing.

    I tried the resets with both the Cingular and Cell C SIMS as well as with my 256 SD card and without. I believe I coverred all the combinations

    Is my Treo 600 dead. or can anybody suggest anything else ?

    Thanks in advance !

    PS: Last night, I was able to swap SIMs with my dad's cellphone on another GSM carrier here called MTN and could place and recieve calls. After this I decided it was worthwhile for me to buy prepaid service and get a local SIM for just little over $1.
  2. #2  
    plug it into the powere cord for a while. hopefully it just went back to the out of box state.
    Felipe
    On the road to 5,000 posts
    Life is what happens between Firmware releases.
  3. #3  
    A dead battery or something like that caused the same to happen to mine. I plugged it in for a while and haven't had the problem since. Thing is - it was fully charged!

    Ben

    Originally posted by TechPuzzle
    I have a Cingular Treo 600 and tried to use a SIM from a prepaid service provider in South Africa called Cell C.
    This is what happned:
    1) Swapped the SIMs; was welcomed to the Cell C network; got signal
    2) According to the instructions I had to call 411 to finish the setup.
    3) When I dialed the "4", my Treo just died -completely !

    I tried all the resets - nothing ! It's completely dead. no flashing LED, no screen - nothing.

    I tried the resets with both the Cingular and Cell C SIMS as well as with my 256 SD card and without. I believe I coverred all the combinations

    Is my Treo 600 dead. or can anybody suggest anything else ?

    Thanks in advance !

    PS: Last night, I was able to swap SIMs with my dad's cellphone on another GSM carrier here called MTN and could place and recieve calls. After this I decided it was worthwhile for me to buy prepaid service and get a local SIM for just little over $1.
  4. #4  
    Originally posted by TechPuzzle
    I have a Cingular Treo 600 and tried to use a SIM from a prepaid service provider in South Africa called Cell C.
    This is what happned:
    1) Swapped the SIMs; was welcomed to the Cell C network; got signal
    2) According to the instructions I had to call 411 to finish the setup.
    3) When I dialed the "4", my Treo just died -completely !

    I tried all the resets - nothing ! It's completely dead. no flashing LED, no screen - nothing.

    I tried the resets with both the Cingular and Cell C SIMS as well as with my 256 SD card and without. I believe I coverred all the combinations

    Is my Treo 600 dead. or can anybody suggest anything else ?

    Thanks in advance !

    PS: Last night, I was able to swap SIMs with my dad's cellphone on another GSM carrier here called MTN and could place and recieve calls. After this I decided it was worthwhile for me to buy prepaid service and get a local SIM for just little over $1.
    I know you said you "tried all the resets" but in case you overlooked the hard one:

    Letter K and Backspace key and soft Reset button all simultaneously. Screen will go blank and Treo will appear to be dead. Plug in charger for 5 seconds and the Treo will come to life. Perform Hotsync to re-install apps and data.

    *** If you have valuable data, back up first. This procedure WILL wipe your Treo clean and bring it back to out of box state, as mentioned by Felipe. I hope this helps.

Posting Permissions