There is a major problem with some of cingulars treos/account setups. When you are in cingular extend (which happens alot in Chicago because of all the GSM towers with cingular and AT&T) it often does not allow your gprs to work correctly. The reason is because cingular is not setting the DNS server correctly to work when roaming. The fix is to go to prefs, then network, modify the cingular express and then go into details and advanced and uncheck query DNS. You have to set the primary DNS to 66.209.10.201. I would also like to know if anyone else ran into this problem. (We had it on 3 treo 600's today at the office and it took over 4 hours and 11 different cingular people before they would give me the dns servers and acknowledge there was a problem.)

-David