Results 1 to 16 of 16
  1.    #1  
    I've got a Cingular T600 on T-Mobile here in NYC. My service so far has been excellent, including the GPRS service (I'm on the $20 unlimited VPN plan).

    I've been concentrating on learning the phone part mostly, this first week of owning the T600. About the only thing that isn't working as I expected is the "Block outgoing caller ID" function.

    I have always had my provider set my service to block caller ID on all outgoing calls, and I entered a *82 before a phone number if I wanted that call to show my caller ID. Verizon Wireless (CDMA) and before that, AT&T (TDMA, but not GSM, as this was before AT&T had GSM) all worked this way. I do the same thing with my wired home phones.

    GSM phones are different in this regard, I guess. I don't have to call T-Mobile to set this up, I have an options screen on the T600 where I can set caller ID to be sent or blocked. So I check the box, and sure enough, my caller ID isn't sent. This works fine, and if I want a given call to show my caller ID, I just enter #31# before the phone number (instead of *82), and for that call only, my phone number shows up.

    So what's the problem?

    When I power the T600 phone down (not the organizer, the phone part), the network (T-Mobile) forgets that I have outgoing caller ID blocked. Turn off phone, turn on phone, make a call, they see my phone number.

    When I go to the options screen, the "Block outgoing caller ID" setting is still set (turned on). If I then use the "Get Status" button, so the T600 queries T-Mobile for the setting, the "Block outgoing caller ID" checkbox disappears. The T600 still thought I had it set, but the network didn't.

    So every time I turn the phone on, I have to reset the "Block outgoing caller ID" function. This sucks.

    Both T-Mobile and Handspring, though very easy to get through to, and very nice on the phone, seem to be clueless.

    Can anyone shed some light on this? I don't know if it's a GSM thing, a T-Mobile thing, or a Handspring thing. How does your phone work in this regard?

    When I put my T-Mobile SIM in my Sony Ericsson T-200, the two caller ID functions in its options menu were dimmed out and not even available. I have a Samsung X105 that I got when I signed up with T-Mobile, but I haven't even taken it out of its box and charged it (so I don't know how it works in this regard).

    Thanks for any help!

    (Oh yeah, is there any way to "chain" numbers together, like for a long distance calling card? So I can dial the LD carrier and the PIN, then chain to an out of country number already in my directory?)

    Bill S

    ps I couldn't decide if this was a T600 question or a GSM question; is it improper procedure to post the same question in both sections? (I didn't).
  2. #2  
    Help!
  3.    #3  
    Are you using your T600 on Cingular or T-Mobile? (If on Cingular, then it sort of rules out the carrier and points to the T600 or how GSM works in this regard).

    Bill S
  4. #4  
    I'm using a Cingular phone on Rogers (AT & T) in GSM mode. Everything else works without problem.
  5.    #5  
    I have a little more info on what's going on, but I don't have a complete solution to getting caller ID working exactly the way I want.

    I just wanted it to work the same way it works on land lines and every other wireless service other than GSM

    The problem:
    If you have your outgoing caller ID blocked (via the checkbox in the phone preferences), it will stay blocked until you power cycle the phone, at which point the system (in my case, T-Mobile), will remove the caller ID block, and your phone number will start showing up to callers again. The checkbox in the phone's preferences still shows as checked (ie blocked), but if you use the status button to get the system's idea, the check will go away.

    I've discoverd that loosing service does NOT cause this to happen, only power cycling the phone.

    You can use the GSM command codes to check the status of your caller ID block, and to set and reset it. This is much easier and faster than going to the preferences.

    *31# will enable caller ID block
    #31# will disable caller ID block
    *#31# will tell you the status of caller ID block

    You don't have to hand enter the numbers; they work from a speed dial or contact dial.

    These are not the "one time" versions of the commands. You only have to enter them once and they stick (except, of course, until you power cycle the phone).

    What I haven't figured out how to do yet is get the "only for the next call" command to turn off caller ID block to work.*

    There are a few numbers I dial that I always want to get my caller ID. Theoretically I should be able to dial the number #31#+1.212.555.1212 and have my number show up, but it doesn't seem to work. If/when I figure it out, I'll post another message about it.*

    Bill S

    * [edited] I figured out more. #31# does work. See my message two messages after this one.
    Last edited by tvBilly; 12/12/2003 at 09:31 PM.
  6. #6  
    its usually *82 or *67 before the phone#
  7.    #7  
    Originally posted by image
    its usually *82 or *67 before the phone#
    Except on GSM systems.

    *82 works for me on my landlines and worked for me on Verizon, but it doesn't work on T-Mobile.

    Bill S
  8.    #8  
    Just as a further update to what I've found. This is for T-Mobile in the USA. Dialing the following codes on the phone does:

    *#31# displays the current state of my outgoing caller ID.
    *31# sets my outgoing caller ID to Blocked.
    #31# set my outgoing caller ID to Shown.

    These are NOT one call settings; they stick until changed. (Or in the case of the Treo 600, until the phone is powered off).

    If I have outgoing caller ID blocked, dialing #31#+1.212.555.1212 will show my caller ID for that call only.

    If I have outgoing caller ID showing, dialing *31#+1.212.555.1212 will block my caller ID for that call only.

    On my Treo 600, I can dial all five of the above from the keypad, and they work, and from the contact (phone book) application they all work. But only the first three work from the favorites (speed dial) screen. The two "for one call only" codes don't work from the favorites screen.

    This is not the end of the world; I put my home number (which has an answering machine) into the contacts list with the name starting with an asterisk (*) so it sorts to the top. At the main phone (dialpad) screen, I just push the down button to get to contacts, and then the center button to dial my home phone. This turns off the caller ID block for that call (so my answering machine doesn't immediately answer with its "I hate blocked numbers" message), and I can tell if there are any new calls by the number of rings.

    The only down side is that I can't append extra numbers to the phone number in the contacts application to enter my answering machine's security code, I have to enter them "by hand". Only the favorites (speed dial) screen allows you to enter extra digits to be dialed.

    The up side is that it takes half the time to dial home this way; down button, center button takes way less time than holding down the 2 key (or whatever).

    For what it's worth...

    Bill S

    ps More esoteric stuff: If you have your T-Mobile voicemail set to not ask you for your password when you dial in for messages from your mobile phone, it will still ask you if you have caller ID blocked.
  9. #9  
    It is a Treo 600 problem. When I swapped the SIM card to my Nokia phone, everything works fine. The Treo 600 Block function does not work properly at all.
  10. #10  
    for tvbilly

    on my gsm t600 the codes *31# and #31# works in the opposite way, please check.
    Ciao

    Ettore
  11. #11  
    Here's an interesting finding. I have T-Mo.

    If I type *31# only and hit DIAL, it blocks my caller ID for all subsequent calls, however, #31# does not unblock like it would when it does the *31#.

    Also *#31# does not give me the correct state.

    I confirm that via the phone app > Menu > Options > Call Preference > Get Status.

    At this point, unchecking the checkbox "Block outgoing caller ID" would result into unblocking. Its the only way I can unblock.

    If the phone is blocked via *31#, any calls I make has my caller ID blocked, even if I prefixed it with #31# + phone number. Same is true with the reverse, that is if I had caller id unblock, *31# does not block caller id for that call.

    So at this point, I could hit *31# to block caller ID for all but no command to unblock and also no specific call where I can choose to block or unblock. To unblock, I use the phone app > Menu > Options > Call Preference > Get Status and if the box for Block outgoing caller ID is checked, I need to uncheck to unblock.

    In summary, my options are block or no block for all calls.
  12. #12  
    I am on TMobile, *31# blocks my caller id until. It stays until I enter #31# to unblock it. Unfortunately, #31# reports an incorrect state on the Treo. However, they both work they way they are supposed to. I've never gotten the "Get Status" option to report correctly.
  13.    #13  
    The firmware update before this last one broke the indicator code in the Treo600. Also the turn on and turn off callerID codes both give you the same message (either that callerID is not sent, or is sent, I forget which).

    The codes to turn outgoing callerID on or off still work, even though the message you get is wrong for one of them. As you note, the code to tell you what your current outgoing callerID state is has been broken as well.

    The built in preference screen that one uses if they don't know about the GSM codes still works, but as always, is slow.

    The "broken" code is still in the current version of the Phone.prc application.

    Bill S
  14. Plop's Avatar
    Posts
    1 Posts
    #14  
    I have a nokia on Tmoblie and i cant figure out how to block my number from showing up on the caller IDs the *32# dosent work or *82 and *67 or something....

    can anyone help me?
  15. #15  
    If you have your phone to block ALL outgoing calls, like I have mine setup for, the *31# works to "unblock" individual calls. If your phone is not setup to block ALL calls the #31# works to "block" individual calls for T-Mobile.


    Hope this helps someone.

    Jake...
  16. #16  
    Hello,

    I've got the same problem, but in reverse:

    My phone says that my Caller ID will be shown to whoever I call. But, when I call someone, they can't see my number. If I type the *31# or #31# code it'll show my Caller ID (I don't remember which one to use for showing it), and my network says that my Caller ID will be shown. It won't work without the code before the number.

    Any thoughts?

    Thanks.

Posting Permissions