This really sucks. Why does this browser suck so much we're all having problems? Is the older version compatible with the Treo?