Results 1 to 6 of 6
  1.    #1  
    When I charge my 270, the red light is on but goes out after a few seconds. I tried charging two ways: through my USB port and through the AC charger but to no avail.

    However the red light remains on for about two minutes when I do it this way: the lid is open and I make a phone call. Then red light dies.

    What's wrong? My wife says the battery must be dead. I got my 270 June of 2002.

    Help!!!

    jojoc
  2. #2  
    You battery is dead. If your service is with T-Mo, you can bring it to their stores and they can confirm that your battery is dead or the internal charger is defective.
  3. #3  
    Hi,

    I have that same problem and this is what I have done. This is meant for the NIMH battery pack for a home cordless phone system but I have use this very same method for my Treo 270 which has the same symthoms as yours and so far I do not have any problem with the battery.

    !!!!!!!!!!!!!!Please keep in mind that your Treo battery may EXPLODES!!!!!!!!!!!!

    http://cygnion.org/forum/ShowPost.aspx?PostID=8579#8666
  4. #4  
    Just replaced mine, east to do if your careful

    Got mine for about 1/2 of handspring or battery.com price @$26 w shipping

    Battery is hnd 14-0024-01 on the 270

    http://www.goldmine-elec.com/

    good luck
  5. #5  
    Originally posted by TrySpammingMe
    Just replaced mine, east to do if your careful

    Got mine for about 1/2 of handspring or battery.com price @$26 w shipping

    Battery is hnd 14-0024-01 on the 270

    http://www.goldmine-elec.com/

    good luck
    That's a good find. Any ideas if the product is genuine or really new. How is battery performance working out for you so far?

    Thank you.
    Last edited by ronbo2000; 12/20/2003 at 11:47 PM.
  6. #6  
    Originally posted by jojoc
    When I charge my 270, the red light is on but goes out after a few seconds. I tried charging two ways: through my USB port and through the AC charger but to no avail.
    Don't let the Treo battery becomes totaly drained. As soon as you get the Red level message recharge it.

    Now... I you got the problem this is what I do... 1) Plug the battery charger to the TREO 2) Quickly open the Treo an do soft-reset 3) Once is reseted login into your provider's network 4) Set the become dark parameter at General Settings (mine is in spanish so I don't know the exact name in english) to 3 minutes 5) Left the Treo open while charging... and 6) THE MOST IMPORTANT step... left the Treo charging open inside a drawer or inside a metal-box or in a place where there signal level is 1.

    Then in 3 hours or 4 the Treo will charge totaly. What I discover is that having the Treo in a low signal area while charging helps in this situation. For me it's working.

Posting Permissions