Results 1 to 13 of 13
  1.    #1  
    Does anyone else have screen issues involving what I'm calling "hot spots"? My screen has two areas in which the coloring/brightness is off a bit. This is most apparent in black screens (like a game), but is noticeable in every application.

    Anyone else have this issue? Anyone try to resolve it with Handspring yet?

    Thanks.
  2. SMc
    SMc is offline
    SMc's Avatar
    Posts
    3 Posts
    #2  
    Unfortunately, I think we're in the same boat....

    - I have a 'bright spot' about the size of a nickel in the lower left
    hand corner of the screen.

    - Data/Information is still visible, however, the screen is definitely
    corrupted.

    It almost appears that something within the device is burning hot under that portion of the screen.

    Not sure what device you have, but I'm running the Sprint branded Treo 600 hardware version C.

    * As I'm sure you noticed, Handspring is referring all hardware
    issues directly to Sprint for these devices:
    http://support.handspring.com/esupport/html/repairs.jsp[/URL]

    I'm stopping by a Sprint PCS store tonight to see what their take is on this.
  3. #3  
    I'm stopping by a Sprint PCS store tonight to see what their take is on this.

    Keep us posted

    -rob
  4. #4  
    Same thing here. Has anyone actually called HS about it? Or are we just going by what the website says. I bought mine directly from HS so I would think they would do something for me...
  5. #5  
    I have the same problem, a spot on the lower center of the screen. It occoured after I accidentally hitting the screen on a desk top corner while the unit is in the HS Form Fit Case. I called HS. HS will ship a replacement unit in 2-3 weeks. They will do so if your unit is within the 90 day of the purchase.

    PY
  6. #6  
    I just got off the phone and my new Treo600 is on its way and will be here in 3-5 bus days! The yellow spots were really annoying but I figured I would just live with them. But for $600 you kind of expect it to be better quality than that.

    Just to let everyone know exactly what my experience was:

    First I called HS at 888-565-9393. They referred me to another phone number which was also HS (877-426-3777) and told me to ignore the options and hit 6. This got me to a tech support guy who had me soft and then hard reset my Treo. Of course neither helped, so he gave me a case # and told me to call Sprint! I thought I was over it then. I've heard so many horror stories about Sprint's customer care I thought that was the end of the line and I would be stuck with the yellow globs. Well I called Sprint and to my surprise - she was the most helpful customer rep I've ever talked to!! She was very nice and helpful and apologetic! Anyways she put my replacement order in along with a box to ship my other one back and I'm all set. She didn't even ask me for a case number! I guess Sprint is starting to really take an interest in how they treat their customers (or I just got lucky

    Anyways, thats my story. To the rest of you - I would definately get a replacement if you are unhappy. $600 is nothing to turn your nose up at - If its broke - FIX IT!
  7. #7  
    Check this thread out:
    http://discussion.treocentral.com/tc...threadid=39558

    It appears it's a growing problem. Thanks for the info, I'll be calling Sprint today for my replacement. See? I really dont NEED a case, I'm getting a new one already! hehe

    The white spot isn't really all that distracting, but it doesn't look good either, especially for something relatively new. I think I'm going to go with a better quality screen protector(non-stick), just in case.
    -Treo 600 on Sprint
  8. SMc
    SMc is offline
    SMc's Avatar
    Posts
    3 Posts
    #8  
    While it took two phone calls to Sprint <very frustrating>, I found a rep. who was able to send out both a return kit and new device.

    - He says I should have it in 3-5 days.


    One caveat; They bill your account immediately for the new device. They will credit your account when they receive the old one back <don't put off that return too long !>
  9. #9  
    I have to look for the yellow spots. They do not really jump out. They are more apparent on black screens. Same for you guys?

    If I were to take it into a store they would think I was crazy...

    -rob
  10. #10  
    Originally posted by SMc
    While it took two phone calls to Sprint <very frustrating>, I found a rep. who was able to send out both a return kit and new device.

    - He says I should have it in 3-5 days.


    One caveat; They bill your account immediately for the new device. They will credit your account when they receive the old one back <don't put off that return too long !>
    I just did the same. I called in and told them that the stores weren't able to help me because they are out of stock on the t600's. I told them i wanted to get a replacement and send in my damaged one in and they did just that. They will bill you for another t600, but they will also credit you for the t600 that you return so it balances out to $0. Thanks for the tip SMC
  11. #11  
    Originally posted by Blacknell
    Does anyone else have screen issues involving what I'm calling "hot spots"? My screen has two areas in which the coloring/brightness is off a bit. This is most apparent in black screens (like a game), but is noticeable in every application.

    Anyone else have this issue? Anyone try to resolve it with Handspring yet?

    Thanks.
    Oh, GREAT! Now I got one too!
    The size of an application icon, just a tad to the right of the camera icon in the upper right corner when looking at the factory application launcher screen.

    What's worse, mine is a GSM bought "long distance" from Singapore, so I guess an easy HS replacement is out of the question.

    No chance the yellow spot will be gone when I wake up tomorrow, is there?

    /Christopher
  12.    #12  
    Nope. In fact, mine just developed a second. Definitely taking the time to call and spend some time with Sprint tomorrow.
  13. #13  
    Had a dark discoloration the size of a half nickel on the left center of screen. At first, I was able to mask out the discoloration it by changing the brightness. After a few days it got worse. I did a hard-hard reset, charged the battery full and somehow it disappeared. Could be some video chip that needs to be refreshed.

Posting Permissions