OK, tell me there's a way to fix this!!

I keep a lot of information in long memos and when I open the memo and use the directional pad to scroll down, it takes me straight to the bottom of the memo (but the scroll bar doesn't even show this).

This happens because when entering the memo, the OS puts the cursor at the bottom, instead of the top, of the memo. I think this is to facilitate use of the buttons at the bottom of the screen.

Anyone figured out how to put the cursor at the top? (or at least toggle this option)?