go to Pref's
go to General turn System Sound to Off. That will turn off the clicking noises. Unless you mean the natural sound that the buttons naturally make.