Page 2 of 2 FirstFirst 12
Results 21 to 29 of 29
  1. #21  
    I live in the East and my solution is to create a new home city with its timezone set to Central with DST on which is what Sprint's network broadcasts. I entered my correct coordinates and it's better than new.
  2. #22  
    hey, that works! thanks.

    I guess the timezone really doesn't affect anything, so this just keeps citytime happy.
  3. #23  
    I have a GSM Cingular Treo600 and had the same problem. Was not caused by the auto synch problem you guys are having on Sprint. My problem was caused by somehow corrupted data for the timezone in the Date and Time preferences. If you looked at it, it was some ridiculus value like GMT + 32 which doesn't exist on the planet anywhere! So it couldn't map to any city in it's database.

    The way I fixed this was to go through the Welcome app (the one that asks you to setup the stylus calibration and the date/time prefs). In the date/time prefs there, if you are VERY patient (think like 1-2 minutes) you can click on the timezone field and it will eventually give you a list you can select the correct time zone from. Once you do that, the crashes in citytime will stop (probably will cause crashes elsewhere also).
  4. #24  
    The problem is that along the East Coast, Sprint is setting the Treo's timezone to Central _Daylight_ Time, instead of Eastern Standard Time. Both yield an offset of GMT-5 hours so the local clock continues to display correct TIME, and you'd never notice that there was a problem unless you used City Time, which looks at the timeZONE settings as well.

    I got the runaround from Sprint too. Customer Service said "they understand my concern" and mumbled something about network time, while clearly failing to understand local time. The referred me to my local Sprint store, and then to Sprint Technical Support.

    The Tech Support agent was surly and insisted that it had to be a problem with my handset, because "otherwise everybody would be having this problem and calling us about it". He didn't seem to appreciate that few users would ever launch City Time.

    At the Store, the tech was surprisingly attentive, asked the usual "did you do a hard reset" (of course), and took the phone back to check my firmware revs. Meanwhile, I confirmed that all of the Treo 600's on display in their showroom displayed the same problem, and reconfirmed it with a Treo-using buddy of mine on travel in North Carolina. The tech returned, did a few experiments of his own, and agreed with me that Sprint was setting the wrong timezone info.

    I tried checking the Samsung i500 to see if it had the same problem, but it doesn't appear to use network time, and in any case lacks timezone support, being a PalmOS 4 device.

    Needless to say, this isn't exactly a Priority One bug for them. I'm going to call them again on Monday to open a ticket, but I think the only way we're going to see it fixed is if we shame them into doing something about their own apparent stupidity. There is still a chance, I suppose, that the bug is in the PalmOne firmware, but I doubt that they'd have such a problem with one timezone and not the other three spanning the lower 48...not to mention the other timezones where they have CDMA service.

    If you're wondering why I'm certain it's their network, the test setup (here on the East Coast) is to go to Prefs->Date&Time and uncheck the "Enable Local Network Time" box. Manually set the zone to "USA(Eastern)" and Daylight Saving to "Off".

    Turn wireless mode off using the switch next to the antenna. Now check the "Enable Local Network Time" box and wait a minute, then uncheck it. The timezone settings do not change.

    Turn wireless mode back on. Again check, wait, and uncheck the "Enable Local Network Time" box. If you have Sprint signal, it will have set the timezone to "USA(Central)" and DST to "On".

    I'm still trying to see what timezone gets used when my phone roams onto Verizon's network.

    -dave
  5. Minsc's Avatar
    Posts
    967 Posts
    Global Posts
    974 Global Posts
    #25  
    I'm in central and the network sets me to mountain with dst on.
    Exactly, same thing happening for me. Kind of an annoying bug that I'm sure Sprint won't fix.
  6. ceb
    ceb is offline
    ceb's Avatar
    Posts
    253 Posts
    Global Posts
    538 Global Posts
    #26  
    I had the same eastern time zone problem and resolved it by accident. Since I use WorldMate I didn't need CityTime, but since it's in ROM it can't be deleted. The only part that can be deleted it the database. Delete it and the annoying Chicago problem goes away. The database will be recreated with the appropriate time zone.....
    Cheers

    Charles
  7. aviduser's Avatar
    Posts
    86 Posts
    Global Posts
    222 Global Posts
    #27  
    I hate to resurrect an old topic (actually, not really), but I have been having this @#$%^&* timezone problem with Verizon ever since Daylight savings began this year. I am on Verizon (obviously) and in DC. If I use network time, my timezone settings switch to Atlantic (GMT-4). (this shows up in DateBk5, which is timezone aware) For all of you really smart timezone folks, you will realize that EDT is also GMT-4.

    If I uncheck sync with network time, the wrong timezone (Altantic) shows up with DST unchecked. Checking DST and enabling network time again fixes the problem. That is until some random event that causes it to revert to Atlantic.

    A few notes: (1) it is not hotsync related; (2) it often happens overnight; (3) I never turn off the radio; (4) it really bugs the p*ss out of me.

    My guess is that when Verizon updated its master network clock for DST, they did not simply turn on the DST setting, but rather set the clock back one hour. My thermostat has a dst button, as does the Treo. My Mac has a DST button. What gives here?

    If anyone else is having the same problem with Verizon, please post.

    ~aviduser
    1995- Newton Message Pad 2000
    1998- Palm V
    1999- Palm V8 (upgrade)
    2000- Palm m505
    2001- Palm m515
    2003- Kyocera 7135
    2004- Treo 600 (woc)
    2006- Treo 700p (wc)
    2007- Treo 680 (wc)
    2008- Another Treo 680 (wc) (unlocked)
  8. #28  
    Quote Originally Posted by tjd414
    If you enable local time in the Prefs, that's what you get -- the local time from Sprint.
    I can't seem to find the pref for local time on a Tmobile phone. Tmobile users, does this exist or am I just blind? I travel quite a bit and have always wondered why when I change time zones the phone doesn't sync with the local time like my nextel did. Is this setting in City Time or in the main preferences?
  9. #29  
    Quote Originally Posted by tjd414
    I'm in the eastern time zone and when DST changed I had no problems.

    I did see something else though ...

    Go to City Time & hit Menu, then Utilities, then Change Location. See what your city is that your Treo 600 is "living" in and see if it matches where you are. If it is in the central time zone, tell it you are moving to your real city and see if that does the trick.

    BTW, did you all get yours shipped to you or did you get it at a store? I bought mine thru an upgrade and picked it up from a local Sprint store. They provisioned it while I waited ... maybe this is the problem.
    I've had this problem since I had my 600 but your tip about changing the location worked. From the beginning in preferences I have been unable to set the time zone as the device crashes and I have to do a soft reset. I'm so pleased to have this facility again especially as I'm off to Canada and Alaska shortly and will be crossing time zones. Thanks a bunch. Mel Jones.
Page 2 of 2 FirstFirst 12

Posting Permissions