Results 1 to 3 of 3
  1.    #1  
    Ok, here are the issues I'm having with my treo, 2 in particular.

    1. My five way button feels really "loose." When I press the left direction the button get raised really far on the right side, almost to the point where I worry about it eventually falling off. Any one else have this problem? When I go and press down the right side I feel the button click down into place before I can actually press the right direction and hear the real click.

    2. I'm getting seemingly random soft resets. It has happen 3 times in a week. Once when I was switching to speaker phone mode. And twice while I was using the browser. I'm not sure but it might be tied to bad coverage areas, because all 3 times this happened I was in a spot with poor coverage. Could this be a sprint issue (i.e. incorrectly programmed phone).

    If I opt to call HS and get a replacement, any idea on how long it'll be before I can get it. I suppose I'll have to send this one back with an RMA first...

    Advice anyone?
  2. #2  
    Originally posted by rchang713
    Ok, here are the issues I'm having with my treo, 2 in particular.

    1. My five way button feels really "loose." When I press the left direction the button get raised really far on the right side, almost to the point where I worry about it eventually falling off. If I opt to call HS and get a replacement, any idea on how long it'll be before I can get it. I suppose I'll have to send this one back with an RMA first...

    Advice anyone?
    Definately not supposed to be doing that...send it back.

    ask them if they will cross ship. they'll probably hold a credit card on file as security until they receive the defective unit.

    don't know for sure as I've never dealt with HS on a RMA
  3. #3  
    1) don't know would have to see it.

    2) software issue prob due to ur programs . . . this is common for early adoption . . . we are basically beta testers . . .send email to hand on feedback section about what's happening so they will know what to fix

Posting Permissions