No matter what setting I have on my Treo, the caller ID is not transmitted when I ring other people who have the facility to see it.

I transfer my sim card to another phone and confirm it is active. ie My ID is sent with the call. but put it into the Treo 270 and it is not sent no matter what the setting is in the Call Preferences.

The box next to Block outgoing caller ID is not ticked.

Any suggestions.?