Page 8 of 19 FirstFirst ... 34567891011121318 ... LastLast
Results 141 to 160 of 365
  1.    #141  
    Not many changes from 0.27. There was a lid_open test which was kinda flaky on my 300, so maybe that will fix the lid sounds. Also I reduced the number of phone service classes I was registered to, in that perhaps some of the SIM services were wasting cycles.

    I also changed the alert scheduling slightly to make sure none would be passed-up inadvertently. And finally, fixed a situation where if you had a connection error dialog up, then it wouldn't do the phone on/off until it was dismissed.

    http://rallypilot.sourceforge.net/treohelper.html
  2. #142  
    Originally posted by potatoho

    Can't think of any reasons for those offhand. I'll try to isolate any questionable features and make sure that when they are "off" that they don't execute anything.
    potatoho,
    it definitely is TreoHelper that is causing the button on the earpiece to not work properly. When uninstalled the button works perfect, when installed it fails.
    Darren Greenspoon
    www.allstarsportscamp.ca
  3. #143  
    I have Treohelper installed and the button on my headset works fine. Perhaps it's a conflict of some sort?
  4. #144  
    Originally posted by kschoenberg
    I have Treohelper installed and the button on my headset works fine. Perhaps it's a conflict of some sort?
    kschoenberg
    Are you using a Treo270? I know it has to do with TreoHelper because when I remove the program, the button works fine, but after installing the program, the button does not work properly.
    Darren Greenspoon
    www.allstarsportscamp.ca
  5.    #145  
    Originally posted by dgreensp
    I know it has to do with TreoHelper because when I remove the program, the button works fine, but after installing the program, the button does not work properly.
    Is the answer/hangup button not working at any time, or is it 50/50. On my 300 I successfully tried it a few times. On your 270, what does it do when you try to use the button, ignore it? What about multiple presses?

    Did you try 0.28? I was using phnServiceAll, which would have subjected me to SIM events and other stuff I'm not interested in. I believe the service classes I have now are the bare minimum needed for the events I use.
  6. #146  
    I'm on a 300. I was using it today and yesterday with .26 and .27 and the button worked...at least for the calls I was making (about 7 or 8).

    ...ken
  7. #147  
    I just downloaded the 0.28 and I will try it out tomorrow morning. The button works 10% of the time. When I go to hangup a call, it sounds like it is clicking in, but the phone never hangs up. I have to actually open up the Treo 270 and press the hangup button. I will let you know if I have any success tomorrow.
    Darren Greenspoon
    www.allstarsportscamp.ca
  8. #148  
    Another problem I am finding:
    When my phone automatically turns on or after a soft reset, I get the Error: Your phone is still searching for a network. (0x7002). I have to open up the lid and tap the OK button to allow Mr. Flip to continue searching for the phone network. The delay to search for the data network needs to be longer - any solutions?
    Darren Greenspoon
    www.allstarsportscamp.ca
  9.    #149  
    It's actually supposed to wait for registration before attempting. Evidently the GSM has more stages to the network search, so i'll make the test more specific. I think the code right now is written as "if not searching then blah blah".
  10. rfg17's Avatar
    Posts
    204 Posts
    Global Posts
    237 Global Posts
    #150  
    I'm still getting in the occasional state where the PDA won't shut off unless I do a soft reset. Doesn't seem to matter what the settings are. I noticed that when in this state it won't hotsync either. Works fine after a soft reset.
  11. #151  
    Tried the earpiece button today with v0.28 and it still doesn't work.
    Darren Greenspoon
    www.allstarsportscamp.ca
  12. #152  
    Originally posted by potatoho
    There was a lid_open test which was kinda flaky on my 300, so maybe that will fix the lid sounds. [/url]
    Thanks potatoho, that seems to have fixed my no sound on lid flp problem.
  13.    #153  
    Originally posted by dgreensp
    1) The pickup and hangup button on the handspring earpiece is not working all the time when TreoHelper is installed
    I was preparing to debug it with my friend, Marc, and turns out that his earpiece hangup button doesn't work at all.. even without TH installed.

    So then I searched these forums and found about 2^32 people complaining about the handsfree button being flaky on the 270. Seemingly working/not working at random interval with various softwares etc. Really surprised me, I guess they fixed it in GPRS 1.1 or something.

    There is a link to a PhoneHalLib.prc patch in these forums. I have no idea whether it is outdated or will help or whatnot. The threads of people experimenting are many many pages long.

    If I find out any more information, I'll post.
  14. #154  
    My earpierce button has never been flakly and as I said it doesn't work when TreoHelper is installed and it does work when TreoHelper is removed.

    The other frustrating aspect is the automatic turning on or after a soft reset, I get the Error: Your phone is still searching for a network. (0x7002). I have to open up the lid and tap the OK button to allow Mr. Flip to continue searching for the phone network.

    So the Auto-OK Connection Progress Dlg is not working here and the auto-login when phone turned on needs to wait longer.
    Darren Greenspoon
    www.allstarsportscamp.ca
  15.    #155  
    Originally posted by dgreensp
    My earpierce button has never been flakly and as I said it doesn't work when TreoHelper is installed and it does work when TreoHelper is removed.
    I don't mean to imply that TH is not the cause, just that it may be something that is indirect, such as a timing issue which tickles an OS bug. The threads I've read they were having issues with all kinds of software.

    There is one event in particular which occurs at phone hangup. I use this phnEvtDisconnectInd event for the Auto-OK. If the Auto-OK is not enabled it does virtually nothing. That's the only place I can think of right now.

    I had a friend inspect the code for issues and nothing popped up with him either. So it's gonna be a bit of a trial & error to figure it out, I imagine.

    The other frustrating aspect is the automatic turning on or after a soft reset, I get the Error: Your phone is still searching for a network. (0x7002). I have to open up the lid and tap the OK button to allow Mr. Flip to continue searching for the phone network.
    I believe I've fixed that in 0.29. The prior code was assuming only two states to network search; i.e. searching, and registered. Now I've tested to make sure it waits until registrationHome or registrationRoaming before trying the Auto-Login.

    Here's 0.29;
    http://rallypilot.sourceforge.net/treohelper.html
  16. #156  
    Headset button with 0.29 doesn't answer or hangup. Does seem like a timing issue. When the button is pressed, something does happen, you can hear it. Treohelper may not be allowing the OS to handle the event before it changes state causing some events to be lost while Treohelper is checking triggers for one of the many enhancements it provides.

    I still love this software. I may try to contribute to your project if I can find some time to get up to speed on Palm programming.

    Thanks for a great product!
    Rob
    Rob
  17.    #157  
    Originally posted by rmcalister
    Headset button with 0.29 doesn't answer or hangup. Does seem like a timing issue. When the button is pressed, something does happen, you can hear it. Treohelper may not be allowing the OS to handle the event before it changes state causing some events to be lost while Treohelper is checking triggers for one of the many enhancements it provides.
    Ok let me run some test cases by you guys. Here's a version with some of the events unhandled. In particular, this test version will not do the auto-ok nor SMS support.

    http://rallypilot.sourceforge.net/wo...elper-test.zip

    BTW was there a version in the past which did work properly on the 270 with the headset button?
  18. #158  
    Originally posted by potatoho

    Ok let me run some test cases by you guys. Here's a version with some of the events unhandled. In particular, this test version will not do the auto-ok nor SMS support.

    http://rallypilot.sourceforge.net/wo...elper-test.zip

    BTW was there a version in the past which did work properly on the 270 with the headset button?
    This test version didn't work. Same results with the earpiece. I have only been using TreoHelper for the past few weeks and I have not come across a version that did work.
    Darren Greenspoon
    www.allstarsportscamp.ca
  19. #159  
    Is there a way to dismiss a SMS popup without deleting it from the SMS program?

    I'd like to automatically dismiss some of the popups that announce SMS messages, but still have a record of them in the SMS program. Is there a way to do this?
  20.    #160  
    Is there a way to dismiss a SMS popup without deleting it from the SMS program?
    I haven't added a feature like that yet. I think I know an easy way to do it which shouldn't be too much trouble.

    As for the 270 handsfree button, what I'm going to do is optimize the phonelib events so that it uses the minimum cycles for events which I don't specifically handle. They're kinda lumped into one launchcode and right now I load a bunch of prefs & stuff for any and all phonelib events, so I'll strip that down.

    Okay I optimized the LoadPrefs in 0.30. Give this a shot.

    http://rallypilot.sourceforge.net/treohelper.html
    Last edited by potatoho; 05/03/2003 at 03:05 PM.
Page 8 of 19 FirstFirst ... 34567891011121318 ... LastLast

Posting Permissions