Results 1 to 15 of 15
  1.    #1  
    Is anyone here using Palm VNC (1.4) to connect to their home PC using AT& broadband (cable) as the ISP?

    I'm getting the following message on the PalmVNC:

    Connecting to "xx.xx.xx.xx:5900"...
    ConnectToTcpAddr: cannot connect
    Unable to connect to "xx.xxx.xx.xx":5900
    ERROR: cannot connect to "xx.xxx.xx.xx:5900"

    I know port 5900 is commonly used for VNC apps but is AT&T blocking that somehow?

    For extra credit - can you still use it if you have a router? i.e., you're sharing your connection so the IP addresses for your PCs would be local (by the way, I'm trying connecting just one PC directly to the cable modem at this time).

    Any suggestions will be greatly appreciated!

    Thanks,

    Ismenio
    Pittsburgh,PA
  2. #2  
    In order to connect to a computer within your home network that is behind the router/firewall, you need to enable port forwarding.

    Forward port 5800 and port 5900 to the internal IP address that the computer w/ VNC Server is on.

    I have done this in the past and it works great. Looks REALLY good, especially with Palm VNC 2.0 w/ high resolution on my Tungsten
  3.    #3  
    MitzEclipse,

    Thanks so much for the info. That certainly gives me a starting point.
    If I may, can I ask you for more details on the port forwarding?
    This is how I have my current configuration (BTW, I own a Treo 300)

    Scenario 1:

    [Cable_Mode]-->[Desktop_PC] (I use ZoneAlarm but I had it disabled for the test)

    This is the ideal configuration that I would love to have:

    Scenario 2:

    [Cable_Modem]
    |
    v
    [LinkSys_Router]
    | | |
    | | |__[PC1_with_VNC_Server]
    | |
    | \__[PC2]
    |
    \___]Laptop]

    I haven't played with port forwarding before but I can try to find how to do that. Would you recommend a site for that? And the other question is, should I still have to do it in scenario 1 when I'm not using the router?

    Again, thank you so much for your help!

    Ismenio

    “I was dreaming in binary but it turned into a nightmare! I think I saw a two”
  4. #4  
    Ismenio,

    What type of router do you have? I have an SMC router, and basically to enable port forwarding, I do the following:

    1) open IE, point the web browser to: http://192.168.123.254
    2) login and click on virtual server (i think , this is from memory, don't have the router at the moment)

    Now, you should see a list of open ports that you can forward to a specific IP address. Input 5800 and make it forward to the IP of your computer (your computer IP should be the internal ip address , something like 192.168.x.x). Now, do the same for port 5900.

    Save your settings and make sure to reboot the router.

    It should work! Please let us know if it doesnt...
  5.    #5  
    Hi MitzEclipse,

    I have a LinkSys (BEFSR41) and I've found the configuration for port fowrading. The options I have are listed below. I tried to set them up based on your suggestions but I still can't connect. I'll keep playing to see what I can get.

    I have on the main page:

    Ext.Port (from-to range)
    Protocol-TCP [check box]
    Protocol-UDP [check box]
    IP Address[192.168.1.2] ( .2 is the PC with the VNC server isntalled)
    Enable [check box]

    I also have options for UPnP forwarding and Port Trigerring that show some interesting options:

    Application name (with the standard ones listed such as FTP, Telnet, etc.But not the VNC one)
    Protocol (selection: TCP or UDP)
    Internal port #
    IP Address
    Enable [check box]

    Just so I'm understanging this right. On the Treo (VNC client) I would enter the IP address that I have assigned by my ISP right? And on the router I would translate port 5900 to link it to the internal IP address of the PC with the VNC server, right? Do I have to scan my ports to assign any internal port # to the external 5900?

    Thanks again!

    Ismenio
  6. #6  
    Ismenio,

    I don't have any linksys routers around me (nor do any of my friends) so I can't give you detailed help .. I'll try though:

    All what you basically have to do is make it so whenever a request from port 58/5900 goes to the external IP (the one IP address that you have received from AT&T @HOME), the router will recognize the request and forward it to the internal IP - which ever the PC is on.

    Don't worry about the standard FTP, Telnet, etc.. those are just the default ports that are either enabled/disabled - those are the standard/common ports.

    All what you're worried about in this scenario is port 5800 and 5900.

    CONNECTING:
    On the Treo VNC Client, all what you do is enter in : 192.168.1.2 , the ip address of your PC that you're trying to remote control - If you are connecting from within your network.

    If connecting from an external location, you must enter in your IP address that AT&T @home gave you, then the router will forward the port to the home PC.

    ...now that I think about it, you don't even have to enable port forwarding if you're within your internal network trying to connect to the PC. It's only if you're on the outside trying to connect inside.

    Just so I'm understanging this right. On the Treo (VNC client) I would enter the IP address that I have assigned by my ISP right?
    Only if you're connecting from an outside network. If you're connecting on the inside, you can do this too - just make sure you enable port forwarding, OR you can use the internal IP address - 192.168.x.x

    And on the router I would translate port 5900 to link it to the internal IP address of the PC with the VNC server, right?
    Right, that is what port forwarding is for.

    Do I have to scan my ports to assign any internal port # to the external 5900?
    Not that I know of, just forward ports 58/5900 to the internal ip address of the PC and you should be golden!

    Let us know if it works/doesn't work.

    Good luck.
  7. #7  
    Don't you have to set a static IP address somewhere in there?
    I played around with WinHand which I thought was very cool but I'm completely lost when it comes to dealing with a router and port forwarding.
    I have a very similar arrangment as Ismenio. I'm with AT&T Broadband using the same router as he is.
    The IP address changes with ATTBI everytime I open IE and somewhere in the WInHand instructions it talks about doing a port forward and having to set the router to a static IP address and you have to disable the router's DHCP function when doing a port forwarding but I'm afraid I'm gonna screw everything up!
    I tried it directly from the cable modem while bypassing the router and it works awesome but putting the router back in the equation and I'm lost.
  8.    #8  
    MitzEclipse,

    I'm sorry to report that I'm still having issues. I even uninstalled
    everything and installed v2.0. I decided to play with the port to see what I could get and the manual helped there (I try to only ask for help after I try everything I can).

    When I changed the VNC setup in the Palm and the Windows REGISTRY to use port 80 (since I'm not running a web server), I get this:

    Connecting to xx.xxx.xx.xx:80...
    Network connected
    read failed (Err=0x1212)
    ERROR: cannot initialize xx.xxx.xx.xx:80
    Connection closed

    (millerhifi, do you get this when you connect directly?)

    So it seems a connection is established but it errors out right after that bummer!

    Changing back to use port 5900, same old error:

    Connecting to xx.xxx.xx.xx:5900...
    ConnectToTcpAddr: cannot connect
    Unable to connect to " xx.xxx.xx.xx":5900
    ERROR: cannot connect to xx.xxx.xx.xx:5900

    I'll keep trying and I just posted this as a feedback to you and to tell you not to feel obligated to reply. For me it's just one of those things that it's now “personal”. I won't rest until I can figure what's wrong with this! If I get it to work, I'll post it here for the benefit of others who may have the same problem.

    And the strange thing is that millerhifi can get it when connecting direct bypassing the router. I think later on I will try the WinHand.

    millerhifi: One thing I don't get is the change in the IP address that you're having every time you launch IE! Mine only changes when I reset my router or power cycle the cable modem!

    Well thanks a lot for your help MitzEclipse! I accomplished a lot more after your hints

    Ismenio
  9. #9  
    Ismenio,

    What Palm type device do you have? Treo? Visor?
  10.    #10  
    I have a Treo 300
  11. #11  
    Originally posted by Ismenio
    I have a Treo 300
    Okay, so I'm assuming you're trying to connect using Sprint's network right?

    Were you able to get this fixed by toying with your settings last night?

    I don't know what additional support to give you other then to recheck your port forwarding settings.
  12.    #12  
    Yes, I'm through Sprint. Also I haven't had a chance to try again today. Will do tomorrow and post my results here.

    Once again, thanks!
  13. #13  
    You might try installing a VNC viewer on your other computer to see if you can connect locally.

    BTW, is version 2.0 new? I'm using Win-Hand because it was much faster than Palm VNC as of a few months ago, but I have to daisy chain it with VNC to connect to my Linux box.
  14. #14  
    Originally posted by markshelby
    You might try installing a VNC viewer on your other computer to see if you can connect locally.

    BTW, is version 2.0 new? I'm using Win-Hand because it was much faster than Palm VNC as of a few months ago, but I have to daisy chain it with VNC to connect to my Linux box.
    Yup, v2.0 VNC is new! Supports HiRes!
  15. #15  
    Ok, first off, i'm a newbie and this BB has enabled me to go out and spent my not yet received tax refund on a new Treo 300 because i'm a gadget freak like the rest of ya..

    Onto the questions.. I'm using XP Pro, Netgear 314 wireless router, I've enabled portforwarding to my PCs. I'm able to use my laptop to access my desktop locally using VNC but have no success with accessing either desktop or laptop using my Treo 300. I kept getting the same error message. Am I forgetting some settings or need to do something else? Thanks in advance for the help.

Posting Permissions