Results 1 to 16 of 16
  1.    #1  
    I have noticed my Treo's screen turning on repeatedly in areas that the signal strength is not very strong. I know this is causing the battery to drain faster than it needs to. Is there a program or hack or something that can help prevent this from happening?

    I only want the screen to turn on when I open the lid or when I have the earphone plugged in. Any suggestions? Anyone else having this problem? Is this normal?

    Thanks!
  2. skidoo's Avatar
    Posts
    345 Posts
    Global Posts
    366 Global Posts
    #2  
    Maybe try turning off digital roaming? Phone->Menu->Options->Call Preferences.
  3. #3  
    I don't have a solution for the "screen lighting up" issue, but I don't think you need to be too concerned with your screen eating up battery life. I've used my Treo 300 as a PDA for hours at a time without any significant battery drainage. Having your screen turn on and off a few times every hour, or so, shouldn't have a noticeable impact on your battery life.

    The most significant battery drainage on the Treo occurs whenever the "radio" is transmitting a signal, either voice or data. On that note, be sure you have digital roaming disabled if you don't use this feature. In weak signal areas, enabling digital roaming may significantly drain your battery. (disable digital roaming by going into your "call preferences" menu item in the phone application and unchecking the "Enable Digital Roaming" checkbox)
  4.    #4  
    I tried changing the settings like both of you mentioned. It seems to have better reception actually but the problem still happens when it is fading in and out of coverage.

    this just also looks funny if I am walking in a dimly lit place with the treo on my hip and the screen starts to glow. I have people point to me and say "dude, your phone is on". I mean the phone is big enough as it is, I don't need to draw any more attention to it

    Hope someone can find a solution. Is this a problem that only I am experiencing or are other people having the same problems?

    thanks
  5. #5  
    One more !
    There are now at least 15 threads related to this bug.
    Delete any pending SMS message from the "unsent" SMS folder and your screen will stop turning on.
    TreoBuddy
    TreoFrance , la première communauté francophone entièrement dédiée au Treo
  6.    #6  
    how do you do that? This is my second post on this subject and the last responce I got for that post was maybe the treo is turning on because it wants to talk.

    I have looked under the options in the SMS and can't find where there are pending messages to be sent. Do you mean remove all the messages that are in the in box? (meaning received messages)

    Thanks
  7. #7  
    Then disconnect the data when you're not using it.

    It won't solve your screen problem, but it will probably solve your battery drain problem.
    --invention is the mother of necessity
  8. #8  
    Just delete the unsent messages from the outbox. Not the received SMS
    TreoBuddy
    TreoFrance , la première communauté francophone entièrement dédiée au Treo
  9.    #9  
    i can't find any outbox in the sms. I would just delete it if I could find it. Any step by step pointers for me? I am sure it is right in front of me but I just can't seem to find it.
    Thanks
  10. #10  
    Currect. Treo300 does not have a way of sending SMS directly (without the use of a 3rd party app such as PDAapps Treo300SMS). The person resonding to you probably has a non-sprint / 300 phone. You shouldn't have any "unsent" SMS messages.

    ---bry
  11.    #11  
    I have that software. I just cant seem to find the outgoing box.

    I would rather not turn of the connection because I want my calls to come through.

    Is there another way to prevent this from happening?
  12. #12  
    I don't know if you were responding to my suggestion, but I meant disconnect the data connection, not turn off the phone.

    You will still get your calls, you just have to suffer the inconvenience of having your data apps pause while they reconnect.

    Or perhaps I am misunderstanding your objection.
    --invention is the mother of necessity
  13.    #13  
    I did not try that but I am figuring that won't fix it as well. I believe it still does it even when I am not connected to the data connection.
  14. #14  
    I don't think it's SMS or being connected to data. It's just the way the Treo works when any event occurs, like a BusConn sync or perhaps the roaming thing. I don't know that there's a way around it, unfortunately, other than getting a case that covers the Treo.

    And I wouldn't worry about a battery drain either, if you leave data connected. This issue has been discussed at length, and the consensus is that it doesn't drain your battery. If your battery is draining too fast, there's a separate issue going on.
  15. #15  
    I would have to concur with MobileDave. I don't use/get SMS message, and all of my apps are configured to disconnect from the data connection upon exiting, so my data link is normally not on. Still, I've seen the device come on at odd hours of the night, almost like it is ready to recieve a phone call. Since I've got the "auto off" set to a couple of minutes, it really doesn't bother me that much about the amount of power these rare occurances take.

    --- bry
  16.    #16  
    My phone must be possesed then. I have laid it down on the table and watched the screen cycle on and off repeatedly for aproximately 20 times in a row. It will annoy me so much that I actually shut it off so I will have enough battery juice in case I need to make a phone call. Maybe I should just call up sprint. That wait time just really gets to me though.

Posting Permissions