Results 1 to 7 of 7
  1.    #1  
    Hi all. I've been trying to determine if my Treo can function (via its wireless modem) as a generic "Hayes" AT-compatible modem. My newspaper (I'm on the staff of the Louisville KY Courier-Journal) still uses a dial-in modem to access its internal messaging system; no Web gateway, unfortunately.

    I have a terminal emulator (Mark/Space's Online) in my Treo (I've used it with a Visor Platinum and Global Access modem to connect successfully via landline), but so far I've been unable to get any response with the Treo. Perhaps it's impossible to use AT commands to dial in to a standard modem. I've done some searches of the archives here without finding a definitive answer, so I thought I'd open it up to everyone here.


    thanks in advance...aa.
  2. #2  
    Originally posted by Andy Adler
    Hi all. I've been trying to determine if my Treo can function (via its wireless modem) as a generic "Hayes" AT-compatible modem. My newspaper (I'm on the staff of the Louisville KY Courier-Journal) still uses a dial-in modem to access its internal messaging system; no Web gateway, unfortunately.

    I have a terminal emulator (Mark/Space's Online) in my Treo (I've used it with a Visor Platinum and Global Access modem to connect successfully via landline), but so far I've been unable to get any response with the Treo. Perhaps it's impossible to use AT commands to dial in to a standard modem. I've done some searches of the archives here without finding a definitive answer, so I thought I'd open it up to everyone here.


    thanks in advance...aa.

    The Treo 300 does respond to AT commands and should not have a problem dialing into a regular modem. However, you'll be charged $0.39/minute when dialing in. With Mark/Space Online, you need to set the port to Wireless Modem. By default, it doesn't do local echo so you either need to enter ATE1 or in Terminal settings, choose local echo. You'll see that it responds to AT commands.
  3.    #3  
    Thanks for the quick reply, Scott. I'm still having a bit of trouble, however.

    With my communications settings (in Online) set to Wireless Modem, when I try to go online, I get a "port already open" error message. If set at that point (with my wireless modem connection active) to "Serial" I can go online, but get no response (no "OK") to any AT commands. Local echo is set to ON. I'm probably missing something relatively obvious. Any further advice?


    aa.
  4. #4  
    Originally posted by Andy Adler
    Thanks for the quick reply, Scott. I'm still having a bit of trouble, however.

    With my communications settings (in Online) set to Wireless Modem, when I try to go online, I get a "port already open" error message. If set at that point (with my wireless modem connection active) to "Serial" I can go online, but get no response (no "OK") to any AT commands. Local echo is set to ON. I'm probably missing something relatively obvious. Any further advice?


    aa.
    Disconnect from Vision. Launcher->Prefs->Network->Disconnect. The reason serial works is that you've opened the port, but nothing is connected.
  5.    #5  
    OK, I got it to work. The problem was that the modem I'm dialing into requires a 7-E-2 terminal setting, and apparently even parity settings don't get a response under this setup. Changing temporarily (when dialing) to 8-N-1 worked.

    Why is there a per-minute charge? Is this not under my unlimited Vision plan, but 2G data or something else?


    again, thanks.
  6. #6  
    Originally posted by Andy Adler
    OK, I got it to work. The problem was that the modem I'm dialing into requires a 7-E-2 terminal setting, and apparently even parity settings don't get a response under this setup. Changing temporarily (when dialing) to 8-N-1 worked.

    Why is there a per-minute charge? Is this not under my unlimited Vision plan, but 2G data or something else?


    again, thanks.
    As far as I understand, dialing into anything other than Sprint's Vision network uses 2G data and therefore has a per minute charge.
  7. #7  
    to connect to the high speed network under the unlimited plan you must dial #777 and connect 115200 baud

Posting Permissions