Results 1 to 10 of 10
  1. fareal's Avatar
    Posts
    260 Posts
    Global Posts
    351 Global Posts
       #1  
    My Sprint Centro will no longer connect to the Power Vision service. It was working fine and all of a sudden it now get stuck at that message "Connecting to Power Vision". I've called Sprint and they say they've reset everything on their end and they are having me retry to connect to the Sprint Provisioning service, but my phone won't even do that. Gets stuck at Connecting to Sprint Provisioning.

    While attempting to do a hotsync I noticed that the phone doesn't seem to recognize the sync/usb cable. It won't even charge with this cable. I know the cable is good because it works on my other Centro. The other Centro charges and syncs fine, but this one with the "connection" problem will not.

    I used NVBackup to do the backup instead and then did a Hard Reset and still in the same state. Will not connect to power vision and cable is charging or allowing hotsync.

    Any ideas?
  2. #2  
    Same exact thing happened to me. You NEED a new device, I tried everything for over a month to get it to work on mine & called Sprint CS at least a dozen times. When you call Sprint for a replacement device (I pray you have insurance) make sure you ask for a credit for your data that you couldn't access. I squeesed $50 out of them after two weeks & another 20 when I set up the new device. Then again, I use my data connectuon a lot for work & I'm sure that swayed such a large reimbursement.
  3. #3  
    Maybe try a hard reset and see if it connects before loading any other software back?
  4. #4  
    Quote Originally Posted by TJSunDevil View Post
    Maybe try a hard reset and see if it connects before loading any other software back?
    Quote Originally Posted by fareal View Post
    then did a Hard Reset and still in the same state
  5. fareal's Avatar
    Posts
    260 Posts
    Global Posts
    351 Global Posts
       #5  
    Yes, I did try that. Just to be clear, after the reset before loading my backup, I still could not connect to the Power Vision or Provisioning service.
  6. fareal's Avatar
    Posts
    260 Posts
    Global Posts
    351 Global Posts
       #6  
    I do plan to call today to try to get a replacement. Thanks for the info fstopstigmata.
  7. #7  
    This happened to me, several towers went down in my area and I and they thought that was the cause, but when they started to go back online I was still stuck without it and I would get the same messages. After a month they gave me a replacement, not through insurance. Some on here have said that the phones are refurbs but this one looked brand new so I'm satisfied. Since I have Sero I didn't bother asking for a credit. Now that I know you need a replacement after they tried everything I won't wait as long next time, others on here shouldn't either.
  8. fareal's Avatar
    Posts
    260 Posts
    Global Posts
    351 Global Posts
       #8  
    I ended up calling Palm directly and paid $25 for an advanced exchange. They shipped one overnight and with an overnight return label. I didn't have insurance. This is actually the second time I've done this. The first time was due to a bad headset port. I didn't try getting a free non-insurance replacement through Sprint.
  9. #9  
    I'm familiar with that option but the issue is on Sprint, not with the phone, the phone isn't broken. A new phone should resolve the problem but its not the cause and I heard on here that a new phone doesn't always fix it. I don't think I should have to pay $25 for something that isn't my fault, although I agree that getting a working phone right away is worth it. I'm glad they offered that, maybe surprised even.
  10. fareal's Avatar
    Posts
    260 Posts
    Global Posts
    351 Global Posts
       #10  
    In my case I personally thought that it was the phone because I also could not charge the phone via the sync/usb cable that came with it. The LED would not even turn on as it normally does. I know the cable is good because it works with my other Centro. Ofcourse it would not sync either, but my other phone would. And also frequently the phone would go into Phone Off mode and would not turn on (although it went through the motions, sound and all) unless I pulled the battery and put it back in.

Posting Permissions