Results 1 to 14 of 14
  1.    #1  
    I just installed a replacement screen/digitizer on my 680. After reassembling it everything works correctly except the built-in MIC. The rear speaker works fine. As does a headset plugged into the jack.

    I checked the 2 connection tabs on the MIC and they appear to touch the motherboard.

    Any ideas on why the built-in MIC does not work.

    thanks,
    Pilot 5K->Palm IIIc->Tungsten T/T2->Treo 650/680 -> Pre+ (1.4.5 & Uberkernel)
  2.    #2  
    I tried repeatedly to reposition the MIC to get it to work. Nothing worked. A replacement MIC is $35 which is more that I want to invest in this device.

    The 680 is now for sale on Ebay. It has a brand new screen.
    http://cgi.ebay.com/ws/eBayISAPI.dll...m=130246490822

    Bid early, bid often.
    Pilot 5K->Palm IIIc->Tungsten T/T2->Treo 650/680 -> Pre+ (1.4.5 & Uberkernel)
  3. #3  
    Quote Originally Posted by swieder View Post
    I tried repeatedly to reposition the MIC to get it to work. Nothing worked. A replacement MIC is $35 which is more that I want to invest in this device.

    The 680 is now for sale on Ebay. It has a brand new screen.
    http://cgi.ebay.com/ws/eBayISAPI.dll...m=130246490822

    Bid early, bid often.
    Jesus that was cheap, I would of bought it and add to my collection of 680 full units and parts.

    What device are you gonna get now?
  4. #4  
    Do a search for my re-assembly instructions, I cover the problems with the mic, how to adjust it and test it before final assembly.

    James
    Alcohol, Tobacco, Firearms. Who's bringing the chips?
  5.    #5  
    Quote Originally Posted by E2EK1EL View Post
    Jesus that was cheap, I would of bought it and add to my collection of 680 full units and parts.

    What device are you gonna get now?
    I got another Treo 680 off of Ebay.

    I am considering iPhone, Android or the next PalmOS down the road. For now I just wanted to get my Treo back.
    Pilot 5K->Palm IIIc->Tungsten T/T2->Treo 650/680 -> Pre+ (1.4.5 & Uberkernel)
  6. sna66's Avatar
    Posts
    9 Posts
    Global Posts
    32 Global Posts
    #6  
    u mean there is actually a way to fix this?? i bought a brand new one because I did the same shyt u did. i'm off to search and try to fix this one
  7. #7  
    Before you do this ... take a pic of the mic, so you know which way does the pin inserts into the rubbing housing

    Take the mic totally a part, rebuild it and make sure everything is adjusted perfectly.

    Took me forever, b/c we didn;t realize the pins was in the wrong way and it kept flicking all over the place. Almost lost it 100x! Once we found out ... really took less then 4 secs to place it back.

    Give it a try.
  8. #8  
    Quote Originally Posted by swieder View Post
    I got another Treo 680 off of Ebay.

    I am considering iPhone, Android or the next PalmOS down the road. For now I just wanted to get my Treo back.


    I'm glad you didnt jump ship like the rest of the losers ... the funny thing is, so many have returned back to Palm OS.

    You never know what you had until its gone
  9. #9  
    I did the search for you: Here are my re-assembly hints and tricks

    http://discussion.treocentral.com/sh...d.php?t=158636
    Alcohol, Tobacco, Firearms. Who's bringing the chips?
  10.    #10  
    I sold my broken 680 on ebay for a little more than I paid for the replacement screen. thanks for the information.
    Pilot 5K->Palm IIIc->Tungsten T/T2->Treo 650/680 -> Pre+ (1.4.5 & Uberkernel)
  11. SoTacMatt's Avatar
    Posts
    61 Posts
    Global Posts
    74 Global Posts
    #11  
    Red Beard helped me before with the very same problem. Still working!
  12. #12  
    Quote Originally Posted by SoTacMatt View Post
    Red Beard helped me before with the very same problem. Still working!
    same here!
  13. #13  
    Hi, recently dismantled my Treo 680 to remove the camera as my work place not able to bring in camera phone. After installing back the casing, I found my mic not working. Have gone the steps that RED BEARD have highlighted but still no use. When I do recording on the memo, I only hear a faint static sound. So how do I determine whether the connection is not there or the mic is spoilt?? Pls advise as I hate to lose my Treo.
  14. #14  
    Any one to help me??

Posting Permissions