Results 1 to 6 of 6
  1.    #1  
    Hopefully someone can give me a little help with this. I was going through my preferences in Datebk4 yesterday and decided (stupidly) to see what would happen if i unchecked "Compress Day View." Well, I hit Done, and was presented with a blank screen. No matter what I pushed (any of the hard or soft buttons, or even the power button) nothing happened. After about a minute, a Fatal Exception with the old Reset button showed up on the screen. So I went through the reset and tried to open Datebk4 again. Same thing. This time I hit the reset button on the back of the Visor and, after letting the unit go through the reset cycle, tried opening the program again. You can see where this is going.

    Next step: I erased Datebk4 and its attendant programs from the Visor's memory and tried running the backup copy I keep in my 8MB module. Same problem. Opened Datebook+, and that still works fine...all of my data is still in there. So I removed all the Datebk4-related apps from the module and reinstalled the program from my PC. Went through dbScan and dbSetup and dbstub, and tried to opend Datebk4, and still got the same problem. Removed Datbk4 and tried Datebook+ again...that at least still works fine.

    So my big questions are...what did I do, and how do I fix it, so that I can still use Datebk4? In case it matters, I'm running a 2MB Visor with the 8MB module installed, no hacks.
  2. #2  
    Sounds to me like DB4 put it's preferences in the "saved preferences" db. Some programs don't delete the preferences when you delete the program. When you are reinstalling, that preference is already there from the previous install. When you did the restore from the backup, did you restore the entire unit or just the specific files related to DB4? You might need to restore your saved preferences db. Restoring that file really sucks because you may have to reset some settings in other programs.

    First thing I would do, is email the author of DB4, tell them the situation and see if they can help. Then I would look at restoring the file mentioned above.

    Do you have a recent full backup (before the problem happened)? When I have problems, I usually do a FULL restore using my backup module.

    Are you using a backup module or just the 8meg flash card to do backups?
  3.    #3  
    Hmmm...this doesn't sound so good. I use the Backup module for data backups, but I had the extra copy of the program on the 8MB module. And I did a backup to the backup module before I tried to reinstall Datebk4 from the original PRC file, so the Saved Prefs db is going to have the same data both on the backup module and in the Visor's internal memory.

    I'll try writing to the developer and post the reply here.

    For future reference, are there any programs that let you go in and edit the Saved Prefs db?
  4. #4  
    Originally posted by tulrich
    Hmmm...this doesn't sound so good. I use the Backup module for data backups, but I had the extra copy of the program on the 8MB module. And I did a backup to the backup module before I tried to reinstall Datebk4 from the original PRC file, so the Saved Prefs db is going to have the same data both on the backup module and in the Visor's internal memory.

    I'll try writing to the developer and post the reply here.

    For future reference, are there any programs that let you go in and edit the Saved Prefs db?
    I have not seen any progs to edit saved prefs. There is one that was suppose to delete any "orphaned" records from deleted programs. But it seriously screws up the db (at least for me it did). It deleted preferences for programs that were still installed. The concept of the program was good, the execution sucked.

    Hopefully the developer can help you out. What happened sounds really wired. I would think that making a single pref change wouldn't screw things up so bad.

    Good Luck!
  5.    #5  
    I love it when a plan works out...

    Here's the reply I received from CESD at Pimlico:

    ======================================================
    First, I suspect this was more of a coincidence than
    anything having to do
    with changing that preference item - something that
    has likely been done
    many thousands of times in the history of DateBk4
    (it's been downloaded more
    than one million times, so you can be quite sure that
    everyone has done just
    about everything with it as this point).

    There are two likely possibilities:

    1. The DateBk4DB preference database is corrupt. Just
    go into the main
    application screen with the icons and delete
    DATEBK4DB. When you next run
    DateBk4, it will automatically rebuild a valid
    preference database - then
    you can re-enter your preferences and registration (if
    you are a registered
    user).

    You might then repeat that step with the compress day
    view preference just
    to verify that it causes no problem by itself. If it
    does, then 2 below is
    more likely

    2. Memory is corrupt on your organizer and something
    shifted in memory about
    the same time you changed that preference setting and
    that was actually the
    cause of the problem. In this case, only a hard reset
    will correct a memory
    problem (and I'm talking about a soft memory problem,
    not hardware).

    There is also a theoretical possibility that the
    DateBk4 program itself has
    been corrupted, although this seems a bit more
    unlikely if you have
    re-installed from a backup. You could try downloading
    a new copy to
    eliminate that as a possibility. You can download the
    current version of
    Datebk4 (V-4.0d) by going to the Pimlico home page:
    http://www.PimlicoSoftware.com
    and tapping on the download arrow next to DateBk4
    (Palm Software) in the
    left-hand sidebar.
    Cheers!
    CESD, Pimlico Software, Inc.
    ==========================================================

    Sure enough, when I deleted DATEBK4DB and reinstalled the whole DateBk4 software package, things started to work again.
  6. #6  
    Glad to see everything worked out!

Posting Permissions