Results 1 to 9 of 9
  1. lordbah's Avatar
    Posts
    341 Posts
    Global Posts
    435 Global Posts
       #1  
    Is there a way to hide the "Service Connection Progress" dialog? It seems to have a habit of popping up at inopportune times when I want to use the device to do something else. Even "Cancel" takes several seconds. I just want it to attempt its connection in the background without interrupting me. (I'm attempting to do something non-network-related; it's trying to connect for Chatter or something - which I still want it to do)
  2. #2  
    Why not have it connect when the phone is turned on? It may eat some battery to keep it on all the time, but at least it won't pop up trying to connect randomly. To do this, go to Network in Prefs, then menu -> options -> preferences, and check the "Connect to the data network whenever the phone is powered on." box.

    There is a box there that says "Ask before connecting to the internet." So you could probably do that as well, and have it ask you before it starts to connect.

    I don't believe there is a way to hide the service connection dialog box though.
  3. lordbah's Avatar
    Posts
    341 Posts
    Global Posts
    435 Global Posts
       #3  
    > Network in Prefs, then menu -> options -> preferences, and check the "Connect to the data network whenever the phone is powered on." box.

    Does that mean connect to the network *only* when the phone is powered on? If so, will email not be delivered to Chatter while the phone sits in my pocket? That would be a loss.

    If the point is that it should connect as soon as I power on the phone, that seems even worse than it is now. Every time I turn on the phone I'll have to suffer through the dialog.
  4. #4  
    Quote Originally Posted by lordbah View Post
    Does that mean connect to the network *only* when the phone is powered on? If so, will email not be delivered to Chatter while the phone sits in my pocket? That would be a loss.
    No, it just automatically connects at that time. It will still connect/disconnect normally.

    Quote Originally Posted by lordbah View Post
    If the point is that it should connect as soon as I power on the phone, that seems even worse than it is now. Every time I turn on the phone I'll have to suffer through the dialog.
    How often are you turning on your phone that this would be worse?
  5. lordbah's Avatar
    Posts
    341 Posts
    Global Posts
    435 Global Posts
       #5  
    > How often are you turning on your phone that this would be worse?

    Whenever I want to jot down a note, or check my schedule, or change which project I'm charging my time to, or I need a stopwatch, or ... rough guess 20 times each day. Right now, perhaps 10 times I take it out of my pocket, hit the power button, and I can do what I want to do. 10 other times I take it out, hit the power button, and have to wait for the Service Connection to finish before I can do what I want to do. It sounds like if I check the box you recommend, 20 times out of 20 I will have to wait for it.
  6. #6  
    It sounds like your network connection is not staying connected. Once its connected, it should stay on in either active (green arrows) or idle (gray arrows) state. The option I was referring to means that when the actual phone radio part of the device is turned on (either after a reset or manually by holding the power button) immediately following, the service connection screen will pop up and connect. Just waking the device up from sleep does not affect the radio, i.e. if it was off before it went to sleep, it will remain off, and if it was on, it will remain on. Perhaps your network connection is having trouble maintaining connection, and something (e-mail I'm guessing) is causing it to reconnect every so often. Are you in a low service area, or is there something else causing the network connection to disconnect?
  7. lordbah's Avatar
    Posts
    341 Posts
    Global Posts
    435 Global Posts
       #7  
    I see, I think. I leave the radio powered on always.

    Sprint has a hard time inside the building where I work. The data ("Power Vision") connection is often down, sometimes the phone connection is down also ("No Service"). Ideally, yeah, the network connection would remain up always, but that doesn't happen here. At home it stays up most of the time (but not all of the time).

    It turns out the option you reference doesn't exist on my phone, or at least isn't on that form. Prefs / Network / menu / Options / Preferences has two checkboxes, "Ask before connecting..." and "Send voice calls to voicemail during active Power Vision data connection". There is not a "Connect to the network whenever the phone is powered on". This is Treo700p-1.10-SPNT.

    It's too bad there is no way to hide this dialog.
  8. #8  
    Ah its different between Verizon and Sprint then, but thats not really a help to you anyway.

    My advice would be to turn off your e-mail auto sync if thats whats causing it to attempt to reconnect all the time.

    Another option would be to check that "Ask before..." box so you would at least have a choice before it basically freezes for about 20 seconds.
  9. #9  
    FWIW, I recently changed to the Sprint Simply Everything plan. During the switch, my account got munged and my phone was no longer set for EVDO. When this happened, I would get the service connection pop up about every 30 seconds to 2 minutes. Very annoying. They had to delete and recreate my account and now everything is good.

Posting Permissions