Results 1 to 17 of 17
  1.    #1  
    I've had this 755 now on *Verizon* for a couple months now, after upgrading from the 650 which I had for two years.

    I was initially very excited to have the phone. The sleeker form factor, EVDO access, lack of antenna... these things and more made this more than a suitable upgrade from the 650.

    Slowly, over time, I've begun to get more and more frustrated with it. At first, it had a soft reset issue, which may or may not have been related to some third party apps. Eventually, it locked up totally, and I was forced to do a hard reset. Since then, the resets have stopped totally, and the phone is at least "Stable."

    But I would be lying if I said the phone was a pleasure to use. The biggest problem is delayed responses in almost everything it does. When I push the power button to turn it on, there's a consistent 5-10 second wait. Then it comes on, and may or may not be responsive right away. If I'm getting a call, it's hit or miss whether the call will be answered on the 1st, 2nd, or 3rd time I I push the green button. On more than one occasion, I've pushed the touchscreen Answer button, with no response, only to have it answer the call and then immediately hang up because it received two inputs on the button (one for Answer and one for Hang Up.

    The same problems persists in almost all applications. If I'm using Chatter, and want to switch to datebook, I can expect an estimated 10 or 15 seconds with a blank gray screen while it's switching programs. During these types of hangups, any screen or button pushes in the interim get stacked up and then executed when the phone starts responding again. This leads to all sorts of annoying additional delays.

    In short, the phone does its job, but its quirky, unpredictable, and most of all, SLOW AS A TURTLE in doing just about everything.

    Where does this leave me? I'm keeping a close eye on Verizon's inventory. As soon as something a little more reputable comes up (say a decent blackberry with 3G), I intend to try and sell my 755p and switch to whatever the new device is. I don't think I can stand another year or more of this stuff!
  2. #2  
    That sounds like behavior I experience in marginal service areas. What is the signal reception like on the phone?
  3. #3  
    Might want to try setting the date/time/timezone setting to Nothing.
  4. #4  
    ^Good points. My vzw 755 is BY FAR the best and most stable Treo I've owned (Visor Phone - 180 - 270 - 600 - 650 -700p - 755p). RLock & Reset Doctor are major contributors to stability.
    Visor-->Visor Phone-->Treo 180-->Treo 270-->Treo 600-->Treo 650-->Treo 700P-->Treo 755P-->Centro-->Pre+-->Pre 2
  5. #5  
    CleanStart, to limit the # of apps that are started on a soft reset might help also.
  6.    #6  
    Quote Originally Posted by cavingjan View Post
    That sounds like behavior I experience in marginal service areas. What is the signal reception like on the phone?
    It gets much worse in marginal service areas... I know the problem you're referring to. If I go into a subway, you can guarantee the delays get intolerable. I don't even bother trying to turn on the device at that point... too much of a pain.

    The delays I'm referring to are minute-to-minute, regardless of signal strength.

    Quote Originally Posted by papped
    Might want to try setting the date/time/timezone setting to Nothing.
    I believe I have tried this before, to no avail. And anyway, I want a consistently accurate time update. If this phone can't handle that, I'd rather move on.

    Quote Originally Posted by pdxtreo
    ^Good points. My vzw 755 is BY FAR the best and most stable Treo I've owned (Visor Phone - 180 - 270 - 600 - 650 -700p - 755p). RLock & Reset Doctor are major contributors to stability.
    As I said, my phone is *stable*, but also painfully *slow*. Do you have this problem also? I don't get any resets nowadays, just slow behavior.
  7. #7  
    Mine, for the most part, has been stable. However, it is never slow. If you have a lot of apps installed, then that's a different case.

    After you hard reset, do a selective restore. Move your backup folder somewhere else and start off fresh. Usually that will fix the lag problems.
    Be sure to check out SmartDeviceResource!


    Device Timeline: Palm III → RIM 950 → RIM 957 → Tungsten W → Kyocera 7135 → Treo 600 → Treo 650 → Treo 700p → Treo 755p & 800w → Treo 755p & Pro
  8. AMVMommy's Avatar
    Posts
    68 Posts
    Global Posts
    91 Global Posts
    #8  
    My VZW 755P is doing the same thing. Freezing up for no reason, skipping in Audible, games slow to a crawl, etc. Trying to answer or hang up a call is a real pain because sometimes it works, sometimes it doesn't and I have to keep pressing Hang Up which then sends everything into a tiff. The phone will do all the things I tried to do when I was trying to hang up. Heaven forbid you want to make a call right after a call. I have to wait at least a minute or 2 after a call before I make another or it just won't connect. Also, having a terrible time with my hands free in the car since some times it will call and sometimes it won't. I had a 650 for years and loved it, but this is making me crazy. I have a VERY strong signal - live and work close to VZW cell towers - and have very little additional stuff on my phone. But it is so frustrating with all the little glitches!!!!!!!!!!

    If I could have another type of Treo I'd switch in a second. Is there any info on a VZW 755P update to take care of some of this frustration?

    Thanks!
  9. #9  
    So weird that Verizon phones seem to have issues that the other carriers don't...
  10. #10  
    Interestingly, the same types of problems happened with VZW Kyocera 7135s, or so I read. VZW was the last to bring out the 7135 and the 1st to bail out. Most of the problems were on VZW phones. Seems VZW demands many changes in device software while Alltel and others do not. I wonder if this makes the device unstable?

    While my Alltel 755p is very stable, loaded with LOTS of 3rd party apps, and overclocked.....I read of these VZW 755ps that are nearly factory fresh and completely unstable.

    My 2 cents...
    bk
  11. EWT
    EWT is offline
    EWT's Avatar
    Posts
    41 Posts
    Global Posts
    53 Global Posts
    #11  
    I'm less than thrilled with my VZW 755 after 4 days of use. I got one as a 700P replacement from Asurion last week. I definitely like the form factor better - it feels much nicer in hand, and the lack of an antenna is nice, but I'm experiencing several resets a day, and it now resets every time I get mail with versamail. Additionally, I'm getting lots of lag at random times, but especially when I start up Blazer. I installed the same software that was working fine on the 700P, which only reset itself once every couple of weeks at most. The only difference is that I installed the 4.x version of versamail rather than the 3.5x I had on the 700P. I may try uninstalling 4.x and put the old version back on to see if there is any change in the resets. I haven't noticed any improvements other than smarter account setup with 4.x.
  12.    #12  
    Quote Originally Posted by robin24k View Post
    Mine, for the most part, has been stable. However, it is never slow. If you have a lot of apps installed, then that's a different case.

    After you hard reset, do a selective restore. Move your backup folder somewhere else and start off fresh. Usually that will fix the lag problems.
    Where is my backup folder located? I've always created a new HotSync ID after hard reset, but this would be much better!
  13. #13  
    My Documents\Palm OS Desktop\YOURHOTSYNCID\
    Something like that

    Move the folder that is your hotsync id
  14. #14  
    Quote Originally Posted by pdxtreo View Post
    ^Good points. My vzw 755 is BY FAR the best and most stable Treo I've owned
    Ditto.

    ET
  15.    #15  
    Quote Originally Posted by papped View Post
    My Documents\Palm OS Desktop\YOURHOTSYNCID\
    Something like that

    Move the folder that is your hotsync id
    Thanks will try it...
  16. #16  
    I would agree it's more stable but its still has bt issues and talk to vzw and palm and they want me to get a old bt they say is compatible with the phone. I hate the blackberry but I might have to get the curve.
    I'm StayFly, its not just a name its a lifestyle, so get some style in your life
  17.    #17  
    Little update... I decided to skip the hard reset, and instead just went through and deleted some old applications i wasn't using, and updated a couple out of date things (including SafeGuard). I also turned off monitoring Palm events on Safeguard, and noticed a substantial speed increase from that.

    More importantly, however, I am trialing LightSpeed... Boy, that really seems to make a difference. I've only had it on there for half a day, but I definitely notice a speed increase, that keeps the phone humming. Very satisfying!

Posting Permissions