I checked based on the palm website and it said that if it ends in SPNT then it needs the update...

I have software: Treo700p-1.10-SPNT

When I go to look for bluetooth devices, nothing shows up...I don't know what to do...