Results 1 to 16 of 16
  1.    #1  
    After a year since the last update, we've finally released a new version of RNS:: Hi-Launcher today.

    Hi-Launcher - Windows-like Start Menu in your Palm! Switch between applications immediately!

    The major changes in the new version 3.4 include:
    • Direct Preferences Panels launching.
    • New item type which initiates the HotSync operation using the connection method that was used previously (useful for syncing via Bluetooth or WiFi).
    • Menu navigation with side buttons of Treo 650 and newer.


    And a lot of other new features, enhancements, as well as bugfixes. The complete list is available at www.hilauncher.com/history.php

    Visit www.hilauncher.com for more information.
    Download Hi-Launcher directly from here (ZIP).

    RNS:: software for your Treo! www.ranosoft.net/treo
  2. #2  
    First, Hi-Launcher is an absolutely indispensible app for me! I love it's functionality and how customizable it is. But, I tried the new version 3.4 last Monday, and ended up restoring the older version 3.3 that has been working flawlessly for a very long time.

    After I installed 3.4, when I tried to launch Hi-Launcher from my programmed hard key, I got a very quick (less than a second) pop-up message saying something like "many changes have been made and Hi-Launcher will now launch automatically to install the updates" (I'm doing this from memory, so I'm sure the words aren't exactly right, although I'm fairly certain that's the gist of it). Then the pop-up would disappear very quickly and nothing would happen (and my Hi-Launcher menus would not launch). I went into LauncherX and opened the Hi-Launcher app, checked the "About" screen to confirm I had 3.4 and exited and tried to launch using the programmed hard button again, with the same lightning-speed pop-up with nothing else happening. I tried a soft-reset and a battery-out reset, I tried re-programming the hard key in Hi-Launcher and went into "Design the Menu..." and made a couple of changes and saved, but the same thing kept happening.

    Since I was completely stumped and now had a non-working version of Hi-Launcher, I went back to the old version.

    Any ideas how I can fix this?

    By the way I have an unlocked GSM 680.
    Last edited by ChristieC; 01/09/2008 at 01:11 PM.
  3. #3  
    I hope the answer isn't "start fresh" because my Hi-Launcher menus are extensive
  4. #4  
    Quote Originally Posted by khaytsus View Post
    I hope the answer isn't "start fresh" because my Hi-Launcher menus are extensive
    I'm feelin' THAT!!!
  5. #5  
    Odd. My update went smoothly. I had a similar screen show up on my saying it was updating, but everything worked fine after that. Curiouser and curiouser.
  6. #6  
    I haven't tried it yet, I think I'll have to sit back and watch this one. Honestly a little bit of a disappointing update.
  7. #7  
    After seeing Patrick's post, I re-downloaded the 3.4 zip file from the RNS website, reinstalled and tried again. Same exact result, except I can now tell you (after seeing the pop-up flash up again about 20 times as I tried to make it work) that it actually says, "Major changes occurred. Hi-Launcher will now be launched to update its setup automatically."

    Then I had a crazy idea and tried completely changing my trigger button. I had been using the Mail button on a press and hold for Hi-Launcher, and it kept flashing the pop-up and opening the Messaging app (which I have as my primary user of the Mail button through the button prefs), without completing the update.

    So I changed the programmed launcher button for Hi-Launcher to the Option key, saved the setting, pressed and held the Option key and the pop-up stayed open this time, allowing me to click "OK" and then I got another pop-up message that the setup was complete.

    Hi-Launcher 3.4 is now functioning on my 680, and I didn't need to change any menus!!!!

    And by the way, I'm now back to the trigger button I'm used to, and it's working fine now, too.
  8. #8  
    Wacky... I guess I'll give it a shot today. I have my backup, JIC
  9. #9  
    mine went fine, I use the green button set to a long hold so it won't screw up the last numbers dialed popup in the phone app.
    French Pre3, UK Pre2, US Veer, German gsm Pre, 680, garmin ique 3600 & still have my working palm pilot 1000 with the 1 Mb adapter

    Please remove UberCalendar and google sync behavior patches prior to system updates.
    patch Google calendar sync behavior for 2.x.x and TouchPad (Oauth2 and advanced sync requirements enabled)
    Preference guide for MetaView's UberCalendar patch
  10. #10  
    Same here, but I went into the menu>load>choose menu and picked my menu and it was fine after.
    Hi-Launcher for me too is indispensable.
  11. #11  
    I love HI-Launcher. Great program.
  12. roninksb's Avatar
    Posts
    90 Posts
    Global Posts
    556 Global Posts
    #12  
    I am a big fan of HiLauncher as well but I do have one big recurring complaint.

    When launching a URL/bookmark with Hi-Launcher it reloads the browser each and everytime even if in the browser already. I note that I have tried the similar functionality in ZZTechs "Launch-Anywhere" and it does not do this, the URL is sent to the browser without a relaunch much the same way it would occur if I was entering the URL manually in Blazer or from the built-in bookmarks. Of course, this method is much faster because the browser is not re-loaded into memory.

    Anyone else notice this? Anyone else bothered by it?
    Regards, RoninKSB
  13. #13  
    Quote Originally Posted by RoninKSB View Post
    I am a big fan of HiLauncher as well but I do have one big recurring complaint.

    When launching a URL/bookmark with Hi-Launcher it reloads the browser each and everytime even if in the browser already. I note that I have tried the similar functionality in ZZTechs "Launch-Anywhere" and it does not do this, the URL is sent to the browser without a relaunch much the same way it would occur if I was entering the URL manually in Blazer or from the built-in bookmarks. Of course, this method is much faster because the browser is not re-loaded into memory.

    Anyone else notice this? Anyone else bothered by it?
    That is about the only thing that I have ever disliked about Hilauncher. But, it is certainly no issue. I would not stop using the program simply because of that. Hilauncher works extremely well!
  14.    #14  
    Quote Originally Posted by ChristieC View Post
    First, Hi-Launcher is an absolutely indispensible app for me! I love it's functionality and how customizable it is. But, I tried the new version 3.4 last Monday, and ended up restoring the older version 3.3 that has been working flawlessly for a very long time.

    After I installed 3.4, when I tried to launch Hi-Launcher from my programmed hard key, I got a very quick (less than a second) pop-up message saying something like "many changes have been made and Hi-Launcher will now launch automatically to install the updates" (I'm doing this from memory, so I'm sure the words aren't exactly right, although I'm fairly certain that's the gist of it). Then the pop-up would disappear very quickly and nothing would happen (and my Hi-Launcher menus would not launch). I went into LauncherX and opened the Hi-Launcher app, checked the "About" screen to confirm I had 3.4 and exited and tried to launch using the programmed hard button again, with the same lightning-speed pop-up with nothing else happening. I tried a soft-reset and a battery-out reset, I tried re-programming the hard key in Hi-Launcher and went into "Design the Menu..." and made a couple of changes and saved, but the same thing kept happening.

    Since I was completely stumped and now had a non-working version of Hi-Launcher, I went back to the old version.

    Any ideas how I can fix this?

    By the way I have an unlocked GSM 680.
    You were right, ChristieC, there was a bug in Hi-Launcher that caused these problems if your Menu trigger is set to press-and-hold of any button.

    There were a few workarounds, like the one described in this thread, or simply tapping "Design the Menu" and "OK" in Hi-Launcher, but now I also released version 3.4.3 that fixes this bug totally. This hotfix is also available for registered users after logging in to their accounts.
    RNS:: software for your Treo! www.ranosoft.net/treo
  15.    #15  
    Quote Originally Posted by Longstrider View Post
    That is about the only thing that I have ever disliked about Hilauncher. But, it is certainly no issue. I would not stop using the program simply because of that. Hilauncher works extremely well!
    I'm aware of this behavior. In fact that was a workaround to a bug in Blazer that crashed if I normally asked it to open an URL when the application was already running.

    I think I'll fix it in the next release by implementing advanced methods used in TreoOfflineViewer.
    RNS:: software for your Treo! www.ranosoft.net/treo
  16. roninksb's Avatar
    Posts
    90 Posts
    Global Posts
    556 Global Posts
    #16  
    Quote Originally Posted by RaNo View Post
    I'm aware of this behavior. In fact that was a workaround to a bug in Blazer that crashed if I normally asked it to open an URL when the application was already running.

    I think I'll fix it in the next release by implementing advanced methods used in TreoOfflineViewer.
    thanks.
    Regards, RoninKSB

Posting Permissions