I use Verizon wireless sync to push e-mail from several accounts to my Treo.
I can't seem to get an audio alert when new e-mail arrives on the phone. I've gone to Wireless Sync > Options > Settings > Notifications and have the Notify when data received box checked, and Tones set to Alarm with Volume set to 5 ... and still no sound alert when a new e-mail arrives on the phone.