Help!

We're moving to Exchange 2003 in my office, and have four Treo 650 phones to migrate to Versamail + EAS. We've updated their firmware to 1.05a, installed Versamail 3.5.4 and the EAS update on them. When we try to sync in Versamail, I get "Security is an older version. Please upgrade to at least version 4.2"

Does anyone know what this means? Upgrade WHAT to version 4.2?!

Device: Treo 650 (Verizon)
Firmware: 1.05a
Software: Versamail 3.5.4 + EAS update

Thanks in advance.