hey guys...I need a little help...

Just got my new treo 680 and noticed that the backlight doesn't dim when i'm on a call. I went to preferences --> power, and put the option of "dim after 30 seconds while on a call," but still doesn't seem to work...

anyone have any ideas? thanks!