Results 1 to 13 of 13
  1.    #1  
    I haven't been on this board in months. My t-600 has been chugging along. Until this past week. The unit has been dropping call constantly even when I have three or four bars showing. I think it could be a bad battery but I am not sure. I have done a search on the board and read through the Network search problem threads but I don't get any message on my phone it just keeps dropping calls and goes back to the keypad screen. It first started a week ago and I noticed that the batt level was around 30% but this past week it has been doing it when the level is over 70%. Any Help??? If I need a new battery I will do it, any recommendation on where to purchase one? Thanks
  2.    #2  
    Any Help??? It has gotten so bad I sometimes can't even use the phone.
  3. ktm97's Avatar
    Posts
    341 Posts
    Global Posts
    392 Global Posts
    #3  
    Do a search on google, I went thru 3 batteries, one was great the other 2 were crap did not last longer than 3-6mos. it's a crap shoot. But they are easy to replace.
  4.    #4  
    KTM97, Thanks for the reply. I have already ordered a battery off of ebay. I did a google search and came up with a bunch. I went with ebay for the price. $40 to $45 vs. $16 on ebay. The seller had excellent feedback so I gave it a shot. As for now I just continue to keep my phone on the charge and keep the batt % as high as possible until the new batt arrives. I will report back when I do the switch.
  5. ktm97's Avatar
    Posts
    341 Posts
    Global Posts
    392 Global Posts
    #5  
    If you are getting the buzzing sound you can also take care of that when you open up the phone.
  6.    #6  
    Quote Originally Posted by ktm97 View Post
    If you are getting the buzzing sound you can also take care of that when you open up the phone.
    What Buzzing Sound?? No thank god I don't have that problem.....Knock on wood. If I get it what should I do?

    As for the batt problem I got the new batt last night and I replaced it today. It took all of 15 mins. The hardest part was unsticking the existing battery from the unit. Other than that is was a piece of cake. I am currently charging the batt and lets see how things work out.
  7. ktm97's Avatar
    Posts
    341 Posts
    Global Posts
    392 Global Posts
    #7  
    On some units there would be a buzzing sound in the earpiece while on a call, the solution was to wrap a small piece of tinfoil on the battery wire, You can do a search and find instructions, good luck hope the new battery works.
  8. #8  
    I just bought a replacement battery for my t600 from itrimming.com. Worked for me.
  9. #9  
    mister mike did it work ??? i have teh same problem !
  10. #10  
    I also have the same problem. For no reason it wont let me dial a call or drops it and goes back to the main screen. My first Treo purchased about 3 weeks ago had the speakerphone problem. I like the phone, but this is annoying.
  11. #11  
    Who is your carrier? and was is your local?
  12. #12  
    Quote Originally Posted by bgonyeau View Post
    I also have the same problem. For no reason it wont let me dial a call or drops it and goes back to the main screen. My first Treo purchased about 3 weeks ago had the speakerphone problem. I like the phone, but this is annoying.
    Sounds like a battery problem which is not surprising.
    Palm III > Palm V > Palm Vx > (Sprint) Kyo 6035 > Handspring Treo 300
    > Handspring Treo 600 Oct.'03 > Palm Treo 700P May'06 > Treo 755P Aug.'07 > Pre(-) June'09 + TouchPad July'11 LONG LIVE webOS!!!
  13.    #13  
    Hi i'm back!! I got the replacement battery off of ebay and it worked for a few months. But now I am having the same problem so I need to get a new replacement batt. Does anyone have any sites they can recommend? Thanks

Posting Permissions