Results 1 to 10 of 10
  1.    #1  
    Curious how they are and would they work with my new 755p utlilizing SAG?
  2. #2  
    If those were the rectangular ones, yeah I got them in black and they worked pretty well on my 700P with SAG. Using the buttons on the side for calls was something entirely different though... maybe with this MR it changed, but since I got them I only used them for 3 weeks then stopped because the sound quality just wasnt there for me, even after Jabra eargels, plus bulky.

    IF I could do it over again I woulda checked out how to work those Ericcson/Sony/Motorola whatever earbuds that are tiny normal sized earbuds with a BT thingy dangling from them.
  3. #3  
    Thanks, banana, for pointing out that the NC1 will work on a POS Treo. I'm not sure why all of the marketing for this headset portrays it as something exclusive to the 750. I've been looking for a collapsible BT stereo headset that would fit in my pocket for quite some time now, and this product looks like exactly what I need if it works with the 755p.
  4. tc600's Avatar
    Posts
    305 Posts
    Global Posts
    306 Global Posts
    #4  
    To each his own regarding the audio quality - I think they sound quite good with Jabra medium eargels. The audio is very good with the latest version of SAG (v1.12) and all the highest quality settings enabled. However, that version still causes other issues with my set of software (particularly delayed SMS's on Sprint), so I've downgraded back to 1.08.899 for the time being.

    I use the larger LC1's as I sometimes have them on all day at work, getting around 7-8 hours on a fully charged battery. For most of the day, I have the audio coming from my work computer, then only use them with my 700p while I'm commuting. Even with the MR installed and only Medium settings on SAG 1.08, I do get a bit of skipping whenever I try to multitask with pTunes playing in the background (particularly when it's using the data connection), far more than if I plug in regular headphones. However, I've conditioned myself to be used to the shortcomings by now though, as I *LOVE* the freedom of the wireless connection.
  5. #5  
    No skipping on the 755p with SAG v1.12 and no SMS delivery problems.
  6. #6  
    I guess my ears are funny shaped, but the bass just seemed to seep out pass the lousy ear connection the Jabras made (yet better sounding than the stock setting).

    Plus man, if you wear these things in public , its a little dorky looking to say the least, looks like 2 BT headsets on your head. I'd only say , with moderate regret of what I should of done, is check out the smaller BT headphone units, the ones that look like normal earbuds , except with a small BT receiver hanging off the wire.
  7. #7  
    That's a horrible name for a company. Hopefully it's water-based.
    MaxiMunK.com The Forum That Asks, "Are You Not Entertained?"

    Remember: "Anyone that thinks the Treo should just work right out of the box, shouldn't own a Treo..."
  8. #8  
    Quote Originally Posted by nsxprime View Post
    No skipping on the 755p with SAG v1.12 and no SMS delivery problems.
    Just got my Lubix headphones with a 755p, but I'm new to SAG (the latest download from Palmgear was 1.11.1109) and the Lubix Bluetooth Headset isn't on SAG's compatibility list, so it refuses to work. The error message is:
    This device is not in the compatility list for this application. Please contact Softick.
    How are you guys getting SAG to recognize the Lubix? Do I need to download a more current version directly from Softick? I'm trying to avoid installing multiple demos in case there are any registration issues.
  9. tc600's Avatar
    Posts
    305 Posts
    Global Posts
    306 Global Posts
    #9  
    Quote Originally Posted by Gameboy70 View Post
    Just got my Lubix headphones with a 755p, but I'm new to SAG (the latest download from Palmgear was 1.11.1109) and the Lubix Bluetooth Headset isn't on SAG's compatibility list, so it refuses to work. The error message is:
    How are you guys getting SAG to recognize the Lubix? Do I need to download a more current version directly from Softick? I'm trying to avoid installing multiple demos in case there are any registration issues.
    It isn't the Lubix that's causing the issue for you, it's the version of SAG. Go to the Softick website to pick up the latest version (1.12) ... it's the only one that works with the 755p's.
  10. #10  
    That did the trick, tc600. This is my first time using a wireless stereo headset, and I was braced for being let down on the sound quality, but the sound is fantastic. I'm registering SAG tonight. Thanks!

Posting Permissions