Results 1 to 12 of 12
  1. RobeJazz's Avatar
    Posts
    70 Posts
    Global Posts
    75 Global Posts
       #1  
    Hello All,

    I dont post all that much - avid reader of TC though!!

    I figured I would add my thoughts to the growing list of comments about the 755p.

    I have had this device for a week -I was one of the lucky ones that was able to get a device "by chance" on sat morning (Sprint store in Allentown, PA)

    This Treo is fast and stable - no resets and no lags, at least in the begining. As i added apps, i noticed some slowness, but still no crashes or resets. The feel is great and the EVDO is fast!!!!! Bluetooth is GREAT - they fixed it, they really fixed it. Call clarity and volume are greatly improved.

    Basically I find that this device fits my needs and is everything I expected the 700p to be and more.

    That said, here are some concerns that I have noticed a long the way:

    1. I get a serious lag (can be just as long, but different than the 700p) when I have Agendus and ANY email program installed. Going into and out of agendus or versamail or chatter is slow. This even slows down blazer. This happens in all types of areas - weak or strong signal. I have removed all email programs, did the asc file removal and deleted Agendus and the thing is back to lightning fast. By the way, what I do with email is just forward to my sprint pcs account and I get an sms when I have mail - I have a link to go directly to the sprintpcs inbox in blazer and I get my mail. Actually faster than "pulling" using versamail or Chatter. Not an elegant solution but it works. I do miss agendus so looking forward to any fix that is possible.

    2. I think it 'munged' up my contacts - I am on a mac and use missing sync with address book and ical. My contacts stopped syncing - no error report and I would never have noticed if I did not check certain contacts, so check yours - I am not sure what happened or whether it was me or the treo or the computer, but check yours and see. I switched to entourage and things are back to normal - again, check yours and see if you can confirm.

    OK - long enough. I'll add some more if this thread gets some momentum. anyone have similar experiences?

    Ciao,

    Robe
  2. #2  
    By the way, does the 755p give you any type of alert or message when someone leaves a voice mail? I thought I read this was an issue with the 700p and I was curious how it works on the 755p.

    Also, how is the web browser application, Blazer? I wish there was a better alternative. Almost forgot, do you have thoughts on the battery life so far? I keep reading that the emails apps like Chatter, Snapper, etc. will drain the battery fast. Thanks.
  3. RobeJazz's Avatar
    Posts
    70 Posts
    Global Posts
    75 Global Posts
       #3  
    Battery is OK so far - I am coming from a 700p with the extended battery from Seido.

    No real issues yet - but not as good as the seido (of course)
  4. eodell's Avatar
    Posts
    182 Posts
    Global Posts
    184 Global Posts
    #4  
    Chatter is working well, but takes a little care to get running properly. Notifications will not go to the Phone App, and no LED. Switching out of the app is a touch slow, but not as bad as it was in the 700p.

    Whatever you do, don't enable "Quick Exit (700p). Instant soft reset.
  5. #5  
    Quote Originally Posted by RobeJazz View Post
    Hello All,

    here are some concerns that I have noticed a long the way:

    1. I get a serious lag (can be just as long, but different than the 700p) when I have Agendus and ANY email program installed. Going into and out of agendus or versamail or chatter is slow. This even slows down blazer. This happens in all types of areas - weak or strong signal. I have removed all email programs, did the asc file removal and deleted Agendus and the thing is back to lightning fast. By the way, what I do with email is just forward to my sprint pcs account and I get an sms when I have mail - I have a link to go directly to the sprintpcs inbox in blazer and I get my mail. Actually faster than "pulling" using versamail or Chatter. Not an elegant solution but it works. I do miss agendus so looking forward to any fix that is possible.

    2. I think it 'munged' up my contacts - I am on a mac and use missing sync with address book and ical. My contacts stopped syncing - no error report and I would never have noticed if I did not check certain contacts, so check yours - I am not sure what happened or whether it was me or the treo or the computer, but check yours and see. I switched to entourage and things are back to normal - again, check yours and see if you can confirm.

    OK - long enough. I'll add some more if this thread gets some momentum. anyone have similar experiences?

    Ciao,

    Robe
    Hi Robe!

    Your post caught my eye because like you, I'm using a Mac, Agendus Pro, the Missing Sync and Entourage.

    Previously. using the 700P I had no problem syncing Entourage so it was a disaster when I found that suddenly I was having a major problem with the Missing Sync and Entourage. I keep getting error messages about, first the Entourage conduit and after reinstalling MS I keep getting different conduit errors saying "so and so" conduit is improperly asking "Exit to Shell" over and over. Each time I start up MS it's another conduit and finally MS won't even start up.

    I was up until 3 AM, using every fix that I could think of, but no luck. I've sent a message to Mark/Space, but they're closed until Monday, so I'm out of ideas and luck for now.

    Otherwise the 755 seems great. It even seems to have better signal strength than the antenna carrying 700P which couldn't pull in a steady signal where I live.

    Good luck with your problems.
  6. #6  
    Wow, same problem. Agendus was giving me the fits and I deleted it. I hope the update it for the 755p. I also came from the Seidio 2400 mAh battery and although battery life is less it is definitely acceptable. As far as volume and lag it definitely is fixed. I don't use Bluetooth much so I haven't tested that.
  7. #7  
    Actually, Agendus seems OK, except that I have no contacts or calendar events. Otherwise, I can move around in it with no lags. Likewise, no lags between it and other apps/screens.

    I can't imagine why I'm having all these problems, even after a totally removing the MS and reinstalling it???
  8. #8  
    Quote Originally Posted by RobeJazz View Post
    I think it 'munged' up my contacts - I am on a mac and use missing sync with address book and ical. My contacts stopped syncing - no error report and I would never have noticed if I did not check certain contacts, so check yours - I am not sure what happened or whether it was me or the treo or the computer, but check yours and see. I switched to entourage and things are back to normal - again, check yours and see if you can confirm.
    Yep, same think with Mac and Missing Sync. I found that I need to sync them with Entourage app, not the address book app, or I have problems. Switched back to Entourage and it seems OK now.

    I auto sync my Entourage and Address Book on the mac anyway, so it really doesn't matter the I only sync to Entourage from mac to treo. Found problems with iCal syncs to treo too. Now just do Entourage sync instead.
  9. #9  
    Quote Originally Posted by printergirl1 View Post
    Yep, same think with Mac and Missing Sync. I found that I need to sync them with Entourage app, not the address book app, or I have problems. Switched back to Entourage and it seems OK now.

    I auto sync my Entourage and Address Book on the mac anyway, so it really doesn't matter the I only sync to Entourage from mac to treo. Found problems with iCal syncs to treo too. Now just do Entourage sync instead.
    It appears that we have different issues. I can't get The Missing Sync to sync anything, much less Entourage. I just get error after error when I launch MS.
  10. #10  
    Does the Treo 755p come with a Palm screen protector? How good is it? I'm wondering if I need to order a Boxwave ClearTouch Crystal before my 755p arrives.

    Al
  11. #11  
    Treolo it does come with one Palm screen protector that you have to cut to size as always. Not a bad plan to get a better one,
  12. #12  
    Quote Originally Posted by Treolo View Post
    Does the Treo 755p come with a Palm screen protector? How good is it? I'm wondering if I need to order a Boxwave ClearTouch Crystal before my 755p arrives.

    Al
    I use the palm screen protector that came in the box (with the cd and software package) and it works fine. I'm sure the Boxwave ones are better but this one suits me just fine.
    diane

Posting Permissions