Results 1 to 6 of 6
  1.    #1  
    Hello, my treo started function little weird recently.
    I exchanged my phone once a month or two ago thru equipment replacement program thru sprint (so it's a refurbished one).
    Everything was fine till last week, now when i use a phone battery goes down super fast, like yesterday i used phone for about 15 mins and battery went down to 15%.. and as soon as i hung up the phone, it goes back up to 49% (it was around 65% when i started talking on the phone
    is it my treo being weird? or i have to replace the battery??
    anybody had same problem as i did??
    any inputs will be appreciated
    thanks
  2. #2  
    Do you have any third party apps running in the background or are you in a poor signal area when it happens? If not, I would try another battery to see if it's a hardware problem. Maybe the battery just needs replacing...
  3. #3  
    Did you keep your old battery with the swapout or did they give you a 'new' one?

    Sprint Pre & Motorola H300 BT headset

    Dead devices: Palm Pro; Palm III; Treo 600, 650, 700p, 755p; Centro
    Yes, I finally updated my tagline!
  4.    #4  
    Quote Originally Posted by HandyDJs.com View Post
    Did you keep your old battery with the swapout or did they give you a 'new' one?
    they put my original battery back into my phone
  5.    #5  
    Quote Originally Posted by Christinac130 View Post
    Do you have any third party apps running in the background or are you in a poor signal area when it happens? If not, I would try another battery to see if it's a hardware problem. Maybe the battery just needs replacing...
    nope, do'nt have any third party program runs on background other than z launcher.. i guess i have to buy new battery.. ugggh
  6. #6  
    My 650 was acting up a few months ago. It would have 98% battery and the phone would shut off and say there was not enough battery to power the phone. Then I would try again in a minute or two and it would work. A new battery fixed the problem.

Posting Permissions