Results 1 to 12 of 12
  1.    #1  
    I can charge the 680 until the cows come home and the most the battery ever shows is 98%

    Is this normal?

    I've drained it all the way down a couple of times and it's still the same.
  2. #2  
    I'm not a 680 user but that doesn't sound normal to me...
    Grant Smith
    A+, Net+, MCPx2, BSIT/VC, MIS

    eNVENT Technologies
    Use your imagination.
    --
    Sprint HTC Evo 4G

    DISCLAIMER: The views, conclusions, findings and opinions of this author are those of this author and do not necessarily reflect the views of eNVENT Technologies.
  3. #3  
    It's not necessarily "normal", but it's common. If you actually read the forum instead of just starting new threads you might find some useful information for yourself...
  4.    #4  
    Quote Originally Posted by Christinac130 View Post
    It's not necessarily "normal", but it's common. If you actually read the forum instead of just starting new threads you might find some useful information for yourself...
    You would be bored if I did not start useless threads !!
  5. ktm97's Avatar
    Posts
    341 Posts
    Global Posts
    392 Global Posts
    #5  
    It appears normal from all of the poster's here, anywhere between 96 & 98% appear's to be the average after unplugging.
  6. #6  
    Quote Originally Posted by ktm97 View Post
    It appears normal from all of the poster's here, anywhere between 96 & 98% appear's to be the average after unplugging.
    That's... odd...

    *goes back to tinkering with his 700wx*
    Grant Smith
    A+, Net+, MCPx2, BSIT/VC, MIS

    eNVENT Technologies
    Use your imagination.
    --
    Sprint HTC Evo 4G

    DISCLAIMER: The views, conclusions, findings and opinions of this author are those of this author and do not necessarily reflect the views of eNVENT Technologies.
  7. #7  
    Quote Originally Posted by Hooterville View Post
    You would be bored if I did not start useless threads !!
    That's true...I would have no one to harass

    Is your 680 not even reaching 100% while on the charger? It's pretty common for it to drop right after unplugging it, but if you've "conditioned" the battery and recalibrated the meter, it should at least hit 100% while still on the charger...

    Quote Originally Posted by gksmithlcw View Post
    That's... odd...

    *goes back to tinkering with his 700wx*
    It's not so odd...my 650 does the same thing...
  8. #8  
    Quote Originally Posted by Hooterville View Post
    You would be bored if I did not start useless threads !!
    That was an exceptionally mature and lighthearted response.
  9. #9  
    I have done a full-drain/reset/charge conditioning to my battery twice, and my phone always shows 99% right off the charger in the morning after an overnight charge. The Graphite one I had before actually showed 100% once, but then went to 98-99% like my Crimson does now. No big deal...
  10. #10  
    I was so excited when my 680 hit 100% on the charger after a month of having it!
  11. #11  
    Quote Originally Posted by Christinac130 View Post
    I was so excited when my 680 hit 100% on the charger after a month of having it!
    That gives me hope that maybe mine will too.
  12. tck
    tck is offline
    tck's Avatar
    Posts
    127 Posts
    Global Posts
    128 Global Posts
    #12  
    Mine will always goes up to 100% then trickle down to below 100% when pluged in. When unplugged it will be less than 100% - value depends on how long it has been plugged.

Posting Permissions