Results 1 to 7 of 7
  1.    #1  
    Hey gang -

    Lately I've had issues with my 600's battery. Ordered a battery replacement online, got it in some time back but only today did I finally go hunt around for how to crack the case on this sucker.

    Got it open, and found that the battery in the unit is different than the battery I ordered - the replacement has a small 4-pin cable socket. Idea is, you unplug the battery off the one in the unit, drop new battery in and plug the cable back up.

    Thing is, the battery in the unit HAS no socket - the cable is attached directly to the battery! And the instructions I read said to detach the cable from the battery and NOT from the main unit itself. Regardless of this, if I did detach the cable from the main unit, I'd still have no way to connect the new battery.

    Any suggestions?
    --Scott
  2. #2  
    The later hardware versions and refurbs did away with the connector. Luckily mine had the connector so it was easy to swap batteries. However, I must warn you of all the non-OEM batteries out there. I've tried several (from different sellers on ebay) and all of them failed within a month - most didn't have enough juice to connect even with a full charge. I recently bought a used OEM battery (again from ebay) for $1.99 plus s/h. This one is working the best. It came with a double ended connector which I didn't need. I could mail it to you. Let me know.
    Palm III > Palm V > Palm Vx > (Sprint) Kyo 6035 > Handspring Treo 300
    > Handspring Treo 600 Oct.'03 > Palm Treo 700P May'06 > Treo 755P Aug.'07 > Pre(-) June'09 + TouchPad July'11 LONG LIVE webOS!!!
  3.    #3  
    Quote Originally Posted by ChemEngr View Post
    I recently bought a used OEM battery (again from ebay) for $1.99 plus s/h. This one is working the best. It came with a double ended connector which I didn't need. I could mail it to you. Let me know.
    Might be a plan - could you snap a pic of it so I can see if it's gonna do the trick, connector-wise?

    The other issue I've had with my 600 of late is the battery charge indicator - the unit has lost it's connection with the battery as far as detecting a charge. I get the empty-battery-red-X icon now. Nothing I've done (soft/hard reset, the battery reset by holdiing K/backspace and tapping the reset button) have done diddly. I've let the battery drain down to empty a couple of times and that hasn't helped either.
  4. #4  
    Give me this weekend for the pic. Later.......
    Palm III > Palm V > Palm Vx > (Sprint) Kyo 6035 > Handspring Treo 300
    > Handspring Treo 600 Oct.'03 > Palm Treo 700P May'06 > Treo 755P Aug.'07 > Pre(-) June'09 + TouchPad July'11 LONG LIVE webOS!!!
  5.    #5  
    No huge hurry. Thanks much!
  6. #6  
    FYI, Sprint did that for me free of charge. I bought the battery online (they suggested it at the Sprint store), and brought it in, and about 2 hours later, came back and picked it up. Sprint is aware of the battery issue...
  7.    #7  
    Well maybe I'll take this battery by my local Sprint store and see what they can do. I doubt much of anything - it's two models out of date. Hell, last year sometime, when my car charger died, I dropped by there to see if they had one in stock, and the Sprint guy chuckled, saying that the phone was so old, they didn't carry anything for it anymore. 2.5 years "old". Amusingly, they had a car charger for it laying around and he just gave it to me.

    That said, I don't have much hope for them being able to handle this issue, about a year after that bit. :P

    I just want the phone to hold out another few months...

Posting Permissions